Omerod 2 Z Probe Calibration Query



  • Hello There,

    I have an Omerod 2 (528.3) now with the new Duet Wifi.

    Normally in the past,with 0.6 duet or 0.85, I would calibrate the Z probe as per documentation on the RepRap Pro site.

    1. Lowered the Z probe down to the bed (enough to catch a piece of paper). This gave me a sensor reading of 966

    2.Send G92 Z0 to set for reference

    3.Lift up the Z probe incrementally until 600 +/- 20 ( My reading was 606 with a Z probe height of 3mm)

    Could someone be as kind enough to guide me to what section of the config.g file (or other file ) that I need to edit. I have tried numerous times editing G31 in the config.g file but the z probe stop at the same position all the time, (which is about 5 mm above the bed) no matter how many times I have edited the config.g file
    G31 P606 Z3 .Have tried reconfiguring with the RRF Configuration tool as well with no luck.

    This is probably quite an easy fix but I am stuck here in Western Australia trying to work it out and there are not to many crew over here that know what this is all about, it is the last piece in the puzzle.The rest of the duet wifi setup has been exactly as described and it has been a buzz trying to work it all out.

    Warmest Regards,

    Dennis Zovko


  • administrators

    I presume you are using the original Ormerod 2 4-wire IR sensor. It sounds to me that you are doing the right thing. Some things to check:

    • Do you have M558 X1 Y0 Z1 P2 in config.g?
    • Check that you don't have more than one G31 command in config.g, or a G31 command in a homing file or in bed.g.
    • When the probe stops 5mm above the bed, what is the Z probe reading, and is the probe still in mode 2? Send M558 with no parameters to find out. AFAIR, the original RepRapPro homing files switched the probe to mode 1 for X homing. This probably isn't necessary any more because the modulation frequency is higher than in the original firmware.


  • HELLO DC42,

    Played around again with the config.g and associated files as mentioned. Things seem to be working well now, but I would like to mention to other users if they read this that sometimes it is really important to clear browsing data on the web browser.

    Initally to compensate for the 5mm height I edited homeall.g | homex.g | homez.g by uncommenting and changing it to G1 Z-4.2 F6000

    This worked well. I then cleared the web browser cache and edited it to the below and now it works and prints perfectly.

    =============
    ; Lower Z again
    G91
    G1 Z0 F6000 <–------! This one (homeall.g | homex.g | homez.g )
    G90

    I have found that when I make changes sometimes things do not take change until I clear the web browser. I have moved from Safari to Chrome for printing purposes.

    I cant stress out for the newbies(of which I am one) that sometimes when you have reconfigured the files and you still get an error report, have a try a clearing the cache (browsing data) first before going psycho. I have spent a week of really late nights trying to sort this.

    As a final comment. The duet wifi is a fantastic product and anyone with an Omerod 2 should not be shy moving forward with it.

    Many Thanks....



  • Out of curiosity, why does clearing your browsing data clear up the problem? I am seeing weird things on occasion (like it seems a config.g edit didn't work) but thought this was just me not paying close enough attention to what I was doing. I'm using Chrome, if it matters.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.