Wiper Start GCode Issues



  • I am trying to set up a wiper for my Dbot. I have gone through it all a couple times manually and through the macro. Problem is when it comes to print it isn't setting the first layer height, once stopped I can't adjust z like it is locked. Needed a reboot. I am not sure if it is the relative/absolute or what the issue could be. Anyone have any thoughts? Original start code and new start code with wiper below. Thanks!

    Original

    [[language]]
    G21 ;metric values
    G90 ;absolute positioning
    M82 ;set extruder to absolute mode
    G28 X0 Y0 ;move X/Y to min endstops
    G28 Z0 ;move Z to min endstops
    G29 S1 ;load mesh
    G1 Z15.0 F9000 ;move the platform down 15mm
    G92 E0 ;zero the extruded length
    
    

    WIth Wiper

    [[language]]
    G21 ;metric values
    G90 ;absolute positioning
    M82 ;set extruder to absolute mode
    G28 X0 Y0 ;move X/Y to min endstops
    
    M208 X320	 			;Set Max X for wiper
    M208 Z-10 S1   			;Set Depth for wiper
    
    G91						;Set Relative Mode
    G1 Z10					;Move bed out of the way 
    
    G90			 			;Absolute Mode
    G1 X312 Y162 F3000 		;Move X & Y Into Position
    G91 					;Relative Mode
    G1 E3 F1				;Extrude / Prime Filament
    G1 E-3 F3				;Retract/Clean Filament
    G90						;Absolute
    G1 Z-2.70 F3000 		;Move Nozzle to Wiper
    
    G91 			 		;Relative Mode
    G1 Y-3 X2 				;Wiping
    G1 Y-3 X-2
    G1 Y-3 X2
    G1 Y-3 X-2
    G1 Y-3 X2
    G1 Y-3 X-2
    G1 Y-3 X2
    G1 Y-3 X-2
    G1 Y3 X2 
    G1 Y3 X-2
    G1 Y3 X2
    G1 Y3 X-2
    G1 Y3 X2
    G1 Y3 X-2
    G1 Y3 X2
    G1 Y3 X-2
    
    G90						;Absolute Mode
    G1 Z15
    M208 X300	 		;ReSet Max X for wiper
    M208 Z0   			;ReSet Depth for wiper
    
    G28 Z0 ;move Z to min endstops
    G29 S1 ;load mesh
    G1 Z15.0 F9000 ;move the platform down 15mm
    G92 E0 ;zero the extruded length
    
    

  • administrators

    1. The problem is this line:

    M208 Z0 ;ReSet Depth for wiper

    I think you meant to include S1 in that line.

    2. Instead of resetting the axis dimensions using M208 commands, you could use M562 M564 S0 to disable axis limits, then M562 M564 S1 to re-enable them afterwards.

    3. In this sequence:

    G91 ;Relative Mode
    G1 E3 F1 ;Extrude / Prime Filament
    G1 E-3 F3 ;Retract/Clean Filament
    G90 ;Absolute

    the G91/G90 will have no effect on extrusion. Use M83/M82 instead.



  • Great. I am going to try that. Which setting is it in when it prints,, guessing the extruder is in relative mode? Also, what about printing, does it print in relative or absolute? Thanks!



  • Also, is M562: Reset temperature fault?


  • administrators

    I'm sorry, I meant M564.


  • administrators

    Whether you print in absolute or relative extrusion mode depends on how you configure your slicer. You have M82 in your start gcode, so I presume you slice in absolute mode.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.