Did stepper current change in 1.19?



  • I finally upgraded from 1.18 to 1.19.2 today on the Railcore. Upgrade went fine, first print was fine, just had to invert the Y motor. After that prints started getting worse and worse. Finally I noticed my extruder stepper was very hot, much hotter than usual. I dropped it down by about 50%, and it cleaned up the issues I was seeing. I also notice my X & Y steppers are both pretty hot - hotter than they'd typically get as well. I checked the release notes, but don't see anything about needing to adjust currents. Did something change?


  • administrators

    No, there was no change made to the motor control code. What did you have the motor currents set to, and what is the rated current of your motors? Which Duet is it?



  • Duet Wifi, I'd tuned the currents by making sure they were at 60c with a thermocouple.

    The extruder stepper is this one:
    http://a.co/bzDYh7p

    Rated at 0.9 amps. Previously was set to 800ma, now I've lowered it to 400ma and it's running much better.

    Pic of what I was getting when it was running hot:
    https://imgur.com/NAfT6dI

    Tested with multiple filaments, couldn't figure it out.

    All of my steppers were running hot yesterday, though, and I haven't touched the currents to them since I built the machine.

    Currents before / now:

    ;M906 X1200 Y1200 Z1000 E800
    M906 X800 Y800 Z700 E400 ; 1.19.2

    Edit: initially linked to the wrong stepper, sorry!



  • This was my first print after upgrading: https://imgur.com/uYoLFK5

    And I'd never seen anything like these prior. But then suddenly all my steppers were way too hot, and everything was printing like that. It seemed related to speed, I slow down for smaller layers, and those were fine, but at higher speeds it would fail to extrude properly.

    I'll run some more test prints today, I'm just baffled why my stepper currents that have been good for months suddenly were causing issues.



  • Sigh… ok, so first print today, same stepper settings as above, confirmed with M906:
    Motor current (mA) - X:800, Y:800, Z:700, E:400:400:400:400:400:400:400:400:400, idle factor 60%

    And my print is looking like that again. Steppers are cool to the touch.

    Back to the drawing board. Might have to try downgrading to see if that resolves it, at least for now. I am at a total loss.


  • administrators

    @kraegar:

    Duet Wifi, I'd tuned the currents by making sure they were at 60c with a thermocouple.

    The extruder stepper is this one:
    http://a.co/bzDYh7p

    Rated at 0.9 amps. Previously was set to 800ma, now I've lowered it to 400ma and it's running much better.

    Pic of what I was getting when it was running hot:
    https://imgur.com/NAfT6dI

    Tested with multiple filaments, couldn't figure it out.

    All of my steppers were running hot yesterday, though, and I haven't touched the currents to them since I built the machine.

    Currents before / now:

    ;M906 X1200 Y1200 Z1000 E800
    M906 X800 Y800 Z700 E400 ; 1.19.2

    Edit: initially linked to the wrong stepper, sorry!

    As the rated current of that stepper is only 0.9A, at 0.8A you can expect it to get hot. I suggest 0.5A to 0.7A.

    If you want to check the current setting, you can connect a multimeter in series with one of the stepper motor phases. Do it securely with croc clips or similar so that it won't become disconnected while you have the power on. Then move the motor in very small increments to find the maximum current.


  • administrators

    Did you make any changes to your jerk or pressure advance settings? Can you see or hear any difference in the head movement on those curves compared to how it used to be?



  • Alright, can do that for setting the current closer… still, changing the current isn't fixing the print issue. I got a good sphere print last night, and a good spiral vase print of the same sphere. But when I attempt a "normal" print (4 exterior walls, 20% infill or whatever) it comes out like the above example every time.

    I'm testing other slicers, speeds, etc to try and figure this out. Perhaps it was just bad timing to try a sphere after the upgrade, and it has nothing to do with firmware.



  • I didn't change anything in the config file other than inverting the Y stepper (and now the stepper currents). The movement appears smooth, but the results are as in that picture.


  • administrators

    If the movement appears smooth then I suspect a problem with your extruder.



  • Seeing it in prints from Slic3r, too. https://imgur.com/IVwRxKi

    Only seems to be happening in sphere shapes, on the bottom side of the sphere. Doesn't seem to be cooling related, slowing things down doesn't change it. Very puzzling to me.

    I don't have pressure advance configured, and haven't adjusted my jerk settings.

    M566 X1000 Y1000 Z30 E20 ; Maximum jerk speeds mm/minute



  • Interesting that's what's in my config.g (and is the only time I see M566, it's not in the config-override, either) and yet it reports this:

    Maximum jerk rates: X: 1000.0, Y: 1000.0, Z: 60.0, E: 60.0:60.0:60.0:60.0:60.0:60.0:60.0:60.0:60.0

    at the console


  • administrators

    That's because the firmware enforces a minimum value of 1mm/sec i.e. 60mm/min. If you think that's too high, I can reduce it. The reason for having a minimum is to avoid the firmware doing stupid things if someone sets the jerk zero or negative.



  • Ah, nah, that's fine. Just hadn't realized it before. Thanks for the explanation there. I wouldn't think it'd be the jerk being too high for the extruder at 60 anyway. I've adjusted my config.g to match the minimums for the extruder and Z.



  • Hmm. I was starting to think this was just an overhang issue, but I did a 75mm cube (zero bottom layers, zero infill, 4 perimeters) and it shows in the last 3mm on each corner.

    I don't have any pressure advance configured at all, so I don't think it's that. Not sure what else to look at.

    I'd misconfigured my first layer with all this testing, which caused a bit of warping. Reprinted where it stuck, and the corners on the test cube look good.



  • Issue is resolved, was something strange going on in my slicer(s) with sphere prints. Not sure what all contributes, but it was having 4 perimeters + 4 bottom layers. I lowered that to 3 perimeter, 2 bottom layers, and they print beautifully. Worked to resolve it in both s3d & slic3r.

    As for the steppers, I did lower the currents a tad from where they were. Didn't have to be 50%, but did have to go down some.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.