E1 Stepper Stopped Mid Print After a Few Hours Of Use… Blown?



  • I noticed someone with a similar issue who posed yesterday but I think my scenario is different enough to put it in my own thread. I also dont want to take his over…..

    I have had my duet wifi installed in my from scratch build for about a month. After tuning my single extruder to perfection I decided to add a second extruder this weekend. It all seemed to be ok. I ran through half a dozen test prints to align the heads. I even bought simplify 3d today to make my life easier. As I set up my first real print, the E1 extruder stopped halfway through the skirt. I have tried different wire and steppers and everything else I can think of.

    I am religious about following the rules when i comes to no power when connecting motors and checking my crimps. I have a 120mm PC fan blasting the back of the board which is always on and my steppers are well under the max amperage rating. The chip looks fine on visual inspection.

    I can hear the motor wine if I try to extrude however it wont lock and it doesn't move at all. It sounds like bad wiring, but it is not -as I have repeated the issue on 3 separate stepper motors with 3 different wires. It just seemed to quit. I contacted filastruder to see what they could do but I was looking for a way to diagnose it. I will pull some info from my printer and post below.



  • I dont think I have changed anything since the issue has started and since it started in the middle of a print, im pretty sure it isnt the result of me tweaking.

    Here are the diagnostics after starting up, homing and trying to cold extrude 5mm on the steppers
    M122
    === Diagnostics ===
    Used output buffers: 3 of 32 (13 max)
    === Platform ===
    RepRapFirmware for Duet WiFi version 1.19.2 running on Duet WiFi 1.0
    Board ID:
    Static ram used: 21176
    Dynamic ram used: 96344
    Recycled dynamic ram: 1264
    Stack ram used: 1304 current, 4936 maximum
    Never used ram: 7352
    Last reset 00:03:50 ago, cause: power up
    Last software reset reason: User, spinning module GCodes, available RAM 6452 bytes (slot 0)
    Software reset code 0x0003, HFSR 0x00000000, CFSR 0x00000000, ICSR 0x00400000, BFAR 0xe000ed38, SP 0xffffffff
    Error status: 0
    Free file entries: 10
    SD card 0 detected, interface speed: 20.0MBytes/sec
    SD card longest block write time: 0.0ms
    MCU temperature: min 27.8, current 28.7, max 28.9
    Supply voltage: min 23.8, current 23.9, max 24.2, under voltage events: 0, over voltage events: 0
    Driver 0: stalled standstill
    Driver 1: stalled standstill
    Driver 2: stalled standstill
    Driver 3: stalled standstill
    Driver 4: standstill
    Date/time: 2017-10-22 20:00:16
    Slowest main loop (seconds): 0.005951; fastest: 0.000092
    === Move ===
    MaxReps: 1, StepErrors: 0, FreeDm: 239, MinFreeDm 238, MaxWait: 10909ms, Underruns: 0, 0
    Scheduled moves: 4, completed moves: 3
    Bed compensation in use: none
    Bed probe heights: 0.000 0.000 0.000 0.000 0.000
    === Heat ===
    Bed heater = 0, chamber heater = -1
    Heater 1 is on, I-accum = 0.0
    === GCodes ===
    Segments left: 0
    Stack records: 1 allocated, 0 in use
    Movement lock held by null
    http is idle in state(s) 0
    telnet is idle in state(s) 0
    file is idle in state(s) 0
    serial is idle in state(s) 0
    aux is idle in state(s) 0
    daemon is idle in state(s) 0
    queue is idle in state(s) 0
    autopause is idle in state(s) 0
    Code queue is empty.
    Network state is running
    WiFi module is connected to access point
    WiFi firmware version 1.19.2
    WiFi MAC address
    WiFi Vcc 3.11, reset reason Turned on by main processor
    WiFi flash size 4194304, free heap 39672
    WiFi IP address 192.168.1.201
    WiFi signal strength -77dBm
    Reconnections 0
    HTTP sessions: 1 of 8
    Socket states: 2 0 0 0 0 0 0 0
    Responder states: HTTP(1) HTTP(0) HTTP(0) HTTP(0) FTP(0) Telnet(0)



  • 8:18:06 PMM913
    Motor current % of normal - X:100, Y:100, Z:100, E💯100💯100💯100💯100:100
    8:17:32 PMM906
    Motor current (mA) - X:1600, Y:1600, Z:1400, E:1500:1500:0:0:0:0:0:0:0, idle factor 30%



  • Take a picture of the board and post it. If the driver is blown, you'll likely see a burnt dot on it.



  • Fixed… It sounded so much like a bad connection i knew it had to be something loose. One of the molex header pins on the board wasnt making good contact with the board. Hopefully it didnt ruin anything else! Nothing like 5 hours of troubleshooting!

    I'm just kidding. Thats why we do this right?


  • administrators

    Good to hear you fixed it, thanks for the detailed troubleshooting!


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.