Blown Z axis driver?



  • Hi all new to this forum and Duet3d and I have a problem with my recently purchased duet wifi. I'm building a Hypercube Evo and partly wired up the Duet board to test the motion. All worked well I tried the z axis on a single stepper and then later a dual stepper all worked OK. I then shifted to test the XY motion and that worked OK. The problem came this evening when trying to run both X,Y and Z axis - while X and Y worked fine, the Z axis was moving slightly then stopping, I intially thought it was binding or one motor was fighting the other and when I checked the connections while the continuity was OK, somehow one of the cable was wired wrongly, so I fixed that and thought it would work but it doesn't in dual configuration I can get one motor to run unloaded but there isnt any power to drive the axis also is suddenly very noisy whereas before it was very quiet. So Ive swapped cables, swapped motors and eventually configured E0 to run the z axis which successfully proved the z axis channel has a fault. Is there any further diagnosis I can do I don't really want to write it off so early into the build - I thought the drivers were bullet proof (the wiki tends to make you believe that you would have to try pretty hard to destroy something) so I'm surprised that it looks like I have killed it even though I took precautions to always power down while changing connections. I also noticed a little red LED between the drive connectors was lit - is that significant as I have come across any documentation for it?


  • administrators

    Hi Rich

    It does sound like you have a blown Z driver. if you bought it from us please contact me on info@duet3d.com, if you bought it from a reseller please contact them in the first instance.

    Cheers

    Tony


  • administrators

    The LED is the endstop state indicator, nothing to do with the driver.

    Assuming that you are using only one of the Z motor connectors, please check that there are 2 jumpers in the other one.

    Is there any sign of damage to the Z driver chip? Is it getting hot?

    The drivers are quite tough, but their infant mortality rate is higher than we would like.



  • Errr slightly embarrased now as I went back to it to have another fiddle after writing the post and its all working again, the only thing I can think of either a dodgy connection or I tweaked something wrong in setting up the firmware. All I did was download a basic set up from reprap and try to run a single motor off a known good cable and all was OK. I then removed the jumpers added the second stepper in and both worked OK but were quite noisy. Maybe I was trying to drive the steppers too fast because now I've tweaked the Esteps value to something closer to the eventual calibration setting and is back to its super quiet norm. Slightly bemused but happy đŸ™‚



  • Just to close this issue…turns out I had decided that 3mm/s z axis speed was way too slow so had set it to 30 mm/s so the problem was that I was just trying to drive the steppers way too fast.



  • That sounds like you should decrease either your acceleration, your instantaneous speed change setting, or both, for your z axis. As well, you should determine a maximum speed for that axis and set it appropriately. Ideally, any g-code should result in a permitted amount of movement without error, even if the gcode requests parameters outside of the physical viability of the printer mechanics.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.