Trying to get IDEX up and running, need help U3 not working



  • I have installed duet5 board to get additional x axis. I am using the the following:
    ; Movement section
    M569 P0 S1 ; Drive 0 goes forwards (change to S0 to reverse it)
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M569 P4 S1 ; Drive 4 goes forwards
    M569 P5 S1 ; Drive 5 goes forwards
    M584 X0 Y1 Z2 U3 E4:5 ; Create U axis for second X carriage before we try to configure it
    M574 X1 Y1 Z0 U2 S1 ; Set endstop configuration (X and Y endstops at low end, U endstop at high end, active high, no Z endstop)
    M906 X800 Y800 U800 Z800 E1000 ; Set motor currents (mA)
    M201 X800 Y800 U800 Z15 E1000 ; Accelerations (mm/s^2)
    M203 X15000 Y15000 U15000 Z100 E3600 ; Maximum speeds (mm/min)
    M566 X600 Y600 U600 Z30 E20 ; Maximum jerk speeds mm/minute
    M208 X200 Y200 U250 Z200 ; Set axis maxima (adjust to suit your machine)
    M208 X-50 Y0 U0 Z-0.2 S1 ; Set axis minimum (adjust to make X=0 and Y=0 the edge of the bed)
    M92 X80 Y80 U80 Z2560 ; Set axis steps/mm
    M92 E420:420 ; Set extruder steps per mm
    G21 ; Work in millimetres
    G90 ; Send absolute coordinates…
    M83 ; ...but relative extruder moves

    Everything is working except the newly created axis. It sounds like it moved however it does not move. I have it plugged into the E2 MOTOR position on the DUET 5 and the end stop in the 1st end stop position. All other axises work. Help please



  • @ronnien59:

    I have installed duet5 board to get additional x axis. I am using the the following:
    ; Movement section
    M569 P0 S1 ; Drive 0 goes forwards (change to S0 to reverse it)
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M569 P4 S1 ; Drive 4 goes forwards
    M569 P5 S1 ; Drive 5 goes forwards
    M584 X0 Y1 Z2 U3 E4:5 ; Create U axis for second X carriage before we try to configure it
    M574 X1 Y1 Z0 U2 S1 ; Set endstop configuration (X and Y endstops at low end, U endstop at high end, active high, no Z endstop)
    M906 X800 Y800 U800 Z800 E1000 ; Set motor currents (mA)
    M201 X800 Y800 U800 Z15 E1000 ; Accelerations (mm/s^2)
    M203 X15000 Y15000 U15000 Z100 E3600 ; Maximum speeds (mm/min)
    M566 X600 Y600 U600 Z30 E20 ; Maximum jerk speeds mm/minute
    M208 X200 Y200 U250 Z200 ; Set axis maxima (adjust to suit your machine)
    M208 X-50 Y0 U0 Z-0.2 S1 ; Set axis minimum (adjust to make X=0 and Y=0 the edge of the bed)
    M92 X80 Y80 U80 Z2560 ; Set axis steps/mm
    M92 E420:420 ; Set extruder steps per mm
    G21 ; Work in millimetres
    G90 ; Send absolute coordinates…
    M83 ; ...but relative extruder moves

    Everything is working except the newly created axis. It sounds like it moved however it does not move. I have it plugged into the E2 MOTOR position on the DUET 5 and the end stop in the 1st end stop position. All other axises work. Help please

    Fixed it did not have the correct motor mapped. Still working on endstop..



  • Okay I have solved my motor issue however I cannot for some reason set up the endstop. I have the end stop connected to E2 on the Duet 5 and the motor leads connected to E2 motor. the motor is setup in config file: M584 X0 Y1 Z2 U5 E4:5 and this works. I have the endstop config as: M574 X1 Y1 Z0 U0 S0, this works for all axis except U. I have the same switch on all endstops except Z. Using z probe for this axis. Can someone give me a little direction on endstop setup



  • Using E0 as U endstop. The problem now is when it hits the endstop it appears to work the it begins to travel word the X axis and I have to stop the machine. It is not staying at home.



  • At wits end Here is what I have:
    M584 X0 Y1 Z2 U5 E3:4 ; Create U axis for second X carriage before we try to configure it
    M574 X1 Y1 U1 Z0 S0 ; Set endstop configuration (X and Y endstops at low end, U endstop at high end, active high, no Z endstop)

    U axis travels in correct direction to home hits the home switch and executes:
    Home U file
    G91
    G1 Z4 F200
    G1 U240 F3000 S1
    G1 U-4 F600 S2
    G1 U10 S1
    G1 Z-4 F200
    G90
    Here is where it departs. It then moves toward my x axis and i have to stop machine before it crashes. Can anyone help me


  • administrators

    The U endstop is at the high end of the axis, therefore you need U2 in the M574 command not U1.

    Also make sure you have set up the axis limits in the M208 S0 and M208 S1 commands.



  • I have changed to U2 earlier but was still having issues. I think i had found the problem in the max limit set up but i lost my WiFi and have been trying to get the duet wifi working. I have another duet WiFi and have updated to latest and setup the macro. i am getting a bad command in M587:
    M552 S0
    G4 P1000
    M587 S”Ronald’s Wi-Fi Network” P”lead9376”


  • administrators

    Which firmware are you running? Use M115 to check. If it's 1.20beta8 then this is a known bug, in which case please upgrade to 1.20beta8+1.

    Please note, the single-quote character in your ssid will need to be sent as two single quote characters in the M587 command. This is because within a double-quoted string, one single-quote character means force the following character to lowercase.



  • I am using the 1.20beta8+1.

    SENT: m115
    READ: FIRMWARE_NAME: RepRapFirmware for Duet WiFi FIRMWARE_VERSION: 1.20beta8+1 ELECTRONICS: Duet WiFi 1.0 FIRMWARE_DATE: 2017-11-18
    READ: ok

    Not sure what you mean about the single quote. Do i need to do the following:

    M552 S0
    G4 P1000
    M587 S”Ronald”s Wi-Fi Network” P”lead9376”

    I have tried this and it still returns:

    SENT: M98 P/macros/SetNetwork
    READ: WiFi module started
    READ: M587: Bad or missing parameter
    READ: ok


  • administrators

    I think you may be using the wrong double-quote characters because the ones in your post are angled. Also, between the letter d and letter s you need two single quote characters, not one double quote. Like this:

    M587 S"Ronald''s Wi-Fi Network" P"lead9376"

    Cut and paste that line, and try it. I just tried it on one of my printers and it worked. When you send M587 without parameters to list remembered networks, you should see this:

    Ronald's Wi-Fi Network IP=0.0.0.0 GW=0.0.0.0 NM=0.0.0.0



  • Still not working. I will try again later. I may change my SSID to a simpler name and try again.


  • administrators

    Are you now using the correct double quote characters in your macro?

    You may find it easier to send the commands via USB from a terminal emulator program.



  • Yes i think that is the problem. I have just received my Duet ethernet and i am connected. I have everything homing but i cannot get the U axis to move once homed. Here is my config on my movement section.
    ; Movement section
    M569 P0 S1 ; Drive 0 goes forwards (change to S0 to reverse it)
    M569 P1 S0 ; Drive 1 goes forwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M569 P4 S0 ; Drive 4 goes forwards
    M569 P5 S1 ; Drive 5 goes forwards
    M584 X0 Y1 Z2 U5 E3:4 ; Create U axis for second X carriage before we try to configure it
    M574 X1 Y1 U1 Z0 S0 ; Set endstop configuration (X and Y endstops at low end, U endstop at high end, active high, no Z endstop)
    M906 X800 Y800 U800 Z800 E1000 ; Set motor currents (mA)
    M201 X800 Y800 U800 Z15 E1000 ; Accelerations (mm/s^2)
    M203 X15000 Y15000 U15000 Z100 E3600 ; Maximum speeds (mm/min)
    M566 X600 Y600 U600 Z30 E20 ; Maximum jerk speeds mm/minute
    M208 X280 Y304 U280 Z200 ; Set axis maxima (adjust to suit your machine)
    M208 X0 Y0 U0 Z-280 S1 ; Set axis minimum (adjust to make X=0 and Y=0 the edge of the bed)
    M92 X80.62 Y80.08 U80.62 Z400 ; Set axis steps/mm
    M92 E420:420 ; Set extruder steps per mm
    M350 X16 Y16 U16 Z16 E16 I1 ; Set 16x microstepping with interpolation
    G21 ; Work in millimetres
    G90 ; Send absolute coordinates…
    M83 ; ...but relative extruder moves

    Am i missing something?


  • administrators

    What driver are you using for the 6th driver (the U motor): the first driver on a DueX2 or DueX5, or something else?



  • it is on the DueX5


  • administrators

    In this command:

    M574 X1 Y1 U1 Z0 S0 ; Set endstop configuration (X and Y endstops at low end, U endstop at high end, active high, no Z endstop)

    you have specified U1 which means that the U endstop is at the low end of the U axis. However, the U endstop on an IDEX machine is normally at the high end. So use U2 in that command.



  • That has solved the problem. I can now start to calibrate. Thanks so very much for the help. I thought i had changed it and then changed it back for some reason.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.