Cannot Forget Network!



  • Using Firmware 1.19.

    I had originally connect on "Guest-Network" successfully, but my computer could not pull up DWC because of the network settings (my landlord is an IT guy who uses some kind of enterprise security software and has a setting that does not allow communication between devices or something). My landlord set up a new network called "Guest-Network-2" without the security setting and I was able to set up wifi and DWC successfully to control the printer through wifi.

    However, when I make changes to config.g in DWC and reboot from DWC, half the time, the Duet connects to the old network. I remedied this briefly by putting in config.g the forget network g-code command M588 S"Guest-Network" with the exact capitalization and spelling, but the problem showed up again.

    When I enter M552 from printrun, it is showing that it is connected to the old network. Lately I have been sending M552 S0, then M552 S1 until it connects to the right network, but it usually takes a few tries.

    Has anyone been experiencing this? How do I fix this? I am putting the M588 S"Guest-Network" command at the top of config.g, followed by M552 S0. Then closer to the end of config.g, M552 S1 is there. What am I doing wrong?



  • if you are sending that M588 S"Guest-Network" like that, then that is your problem. It is case sensitive and you will need to put apostrophes in the appropriate places.

    alternatively you can sent M558 S"*" and it will forget ALL networks and then just set up the connection to the network you want.

    info about how to use apostrophes to for case sensitivity can be found in the M587 section here:
    https://duet3d.com/wiki/G-code



  • Hi Keegan. Based on the link, it appears that perhaps I should use single quotation marks prior to every letter that should be lowercase. However, I was thinking that this rule only applies to situations where g-code is being sent from DWC or Printrun. In this case, I am including it in the config.g file.

    Nevertheless, I tried it anyway in the config.g file as:
    M588 S"G'U'E'S'T-N'E'T'W'O'R'K"

    but it did not work. I also tried sending it from DWC, and it did not work. Before I try M558 S"*", could you tell me if I did the above correctly?



  • By the way, when setting up the network, I did not have to use the single quotation marks in the macro file. So I'm wondering why I would need to include them for M588 in config.g.



  • When I try M588 S"G'U'E'S'T-N'E'T'W'O'R'K" from printrun, I get an error message saying:
    WiFi reported error: SSID not found

    But I have spelled it correctly.



  • Ok I tried the M558 S"*", then used a macro to fix this. The macro did not need the single quotation marks.

    When I prior tried using the single quotes from pronterface to set the network up, it remembered the network with the single quotes included, so not sure what is going on.


  • administrators

    I think the use of the single quote character to force the following character to lower case may have been introduced at version 1.19.2.



  • Ah I see, just glad I got it fixed. Has been working great ever since I successfully forgot the previous network.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.