Z height incorrect at print time



  • Hi All

    Upgraded a CR-10 to duet wifi, everything is great except prints are coming out as if the first quarter of the print the layers are compressed.

    I have checked the settings in the firmware and 400 steps per mm looks correct and it measures correct when using the head movement controls in Machine Control.

    On printing a 1cm cube as a test I get 10mm x 10mm x 8.5mm approx.

    Slicer is S3D using the standard CR-10 profile

    Firmware Name: RepRapFirmware for Duet WiFi
    Firmware Electronics: Duet WiFi 1.0
    Firmware Version: 1.19.2 (2017-09-01)
    WiFi Server Version: 1.19
    Web Interface Version: 1.19

    ; Configuration file for Duet WiFi (firmware version 1.17 to 1.19)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Fri Dec 08 2017 18:17:14 GMT+0000 (GMT Standard Time)

    ; General preferences
    M111 S0 ; Debugging off
    G21 ; Work in millimetres
    G90 ; Send absolute coordinates…
    M83 ; ...but relative extruder moves
    M555 P2 ; Set firmware compatibility to look like Marlin
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X500 Y500 Z500 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 Z1 S1 ; Set active high endstops
    M558 P0 X0 Y0 Z0 H5 F120 T6000 ; Set Z probe type to switch, the axes for which it is used and the dive height + speeds
    G31 P600 X0 Y0 Z2.5 ; Set Z probe trigger value, offset and trigger height
    M557 X15:485 Y15:485 S20 ; Define mesh grid

    ; Drives
    M569 P0 S0 ; Drive 0 goes backwards
    M569 P1 S0 ; Drive 1 goes backwards
    M569 P2 S0 ; Drive 2 goes backwards
    M569 P3 S0 ; Drive 3 goes backwards
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X80 Y80 Z400 E837 ; Set steps per mm
    M566 X900 Y900 Z12 E120 ; Set maximum instantaneous speed changes (mm/min)
    M203 X6000 Y6000 Z600 E1200 ; Set maximum speeds (mm/min)
    M201 X1000 Y1000 Z600 E250 ; Set accelerations (mm/s^2)
    M906 X800 Y800 Z1600 E1700 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Heaters
    M305 P0 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4725 C7.060000e-8 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Network
    M550 PMy printer ; Set machine name
    M552 S1 ; Enable network
    M587 S"" P"" ; Configure access point. You can delete this line once connected
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Fans
    M106 P0 S0.1 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I0 F500 H1 T45 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Custom settings are not configured



  • If regular movement is accurate but when printing the parts came out short, then my guess is that it's skipping steps.
    It could be that you are trying to move Z too fast or the motor needs more amps.



  • BTW, have you tried with a different slicer?
    Is that a 4 starts 2mm pitch TR8*8 leadscrew?



  • hey I'm experiencing the same issue and have been scratching my head pretty hard… regular non printing move Z measured accurately but when printing upon getting to layer 3rd or so it appear to stay at 2nd layer and thus squashing everything.... I'm on 1.19.2 as well



  • thirty6 what Z motor are you using? you set the current for 1600mA? seems high for regular nema 17?


  • administrators

    I was recently alerted to a bug whereby a M109 command can cause unwanted movement, and it's occurred to me that this could be the explanation for reports of incorrect Z height. To see if that's the reason, edit your GCode file, replacing each M109 command in it by a similar M104 command followed by a M116 command (no parameters are needed on the M116 command).

    This bug doesn't affect everyone, and it is believed fixed in firmware 1.20RC1.



  • dc42 checked my gcode and there's no M109 there.

    sorry thirty6 didn't mean to hijack your thread but seems appropriate to add my issue here

    I have T0 and T1. T0 seems perfectly fine. T0 is the one experiencing this incorrect Z height while printing issue. perhaps something in my Tfree? but there's no M109 there as well


  • administrators

    @stephenc:

    …I have T0 and T1. T0 seems perfectly fine. T0 is the one experiencing this incorrect Z height while printing issue.

    Did you mean that T1 is fine, ot that T1 has the problems?

    Do you have any tool Z offsets set in your G10 commands?

    Are the two nozzles at exactly the same height, or not?



  • I don't have Z offset on my G10

    both T1 and T0 were used starting from 1st layer. 1st and 2nd layer looks perfectly aligned so both nozzles confirmed at same height. and then 3rd layer starting with T1 it start squashing everything that's when I stop the print.

    I used S3D to slice.

    I will try Cura to see if it makes any difference



  • still in S3D. now I'm super confused. I tried disabling Z hop. problem still there.

    I tried printing a simple cube calibration (grey T0) and (white T1) and they were completed fine. so I'm not sure what triggered the issue of Z squashing down…
    (there were ooze shield but I took it off to take the photo)



  • single head printing appear to be not affected by the Z squashing issue. I can print gcode with T0 only and gcode with T1 only both came out perfect.

    it probably just worth upgrading to the latest RC version and see if I can repeat this problem with dual printing..


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.