P0 Bed thermistor channel 0 Ohm at Duet Wifi PCB



  • Hi,

    i have a new Duet Wifi 1.20beta11 with a couple of hours printing time and the bed temperature reports 2000 °C now.
    The bed thermistor including cable is ok, M305 confi is also correct. The bed heater/thermistor worked before.

    When i disconnect the thermistor/cable from the Duet Wifi and measure the resistance with a multimeter, it shows 0 Ohm - it should be MOhm in my understanding (open ADC port). I could not find any short circuit, it seems to come from the Atmel ?!?
    The other thermistor channels work like they should.

    Any suggestions ? What is causing the problem, how to get rid of it ?


  • administrators

    The resistance with nothing connected should read somewhat more than 4.7kohms.

    There is a 10K resistor between the thermistor pin and the Atmel MCU so it can't be the MCU. Check that the underside of the board is not resting on anything that could explain shorting the pins out. Otherwise, it could be a PCB fault or a solder bridge underneath the bed thermistor connector.

    If you are certain there is a short and your board is new, ask for a replacement.



  • I did check the PCB for obvious shorting before, i couldn´t find anything. I cleaned it again with a toothbrush - no change.

    When i measure the resistance when the Duet is powered off, i measure 10 kOhm. When i measure the resistance when the Duet is powered on and no sensor is attached, i get MOhm or 0 Ohm - just by chance (maybe my multimeter cannot measure it correctly when the Atmel is on). I compared this behavior of P0 with other thermistor channels and it is the same there, but the reading of P0 is always 2000 °C (== 0 Ohm), the other channels work. The resistance at the end of the thermistor cable is about 110 kOhm, so this part also works. When i measure the resistance with the multimeter, the Duet shows about 59 °C.

    UPDATE: i did change the thermistor and now it works - although i can measure a varying resistance when e.g. holding the "faulty" thermistor in my hand - so the faulty thermistor/cable seems to be very special ?!?


  • administrators

    I'm glad you got it working again. Standard multimeters can't measure the resistance of anything that has power applied to it.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.