Port Forwarding not working on my Duet Wifi



  • Is there a setting to turn it on, because I have it working on 2 raspberry pi's using octoprint with no issues. And it just refuses to connect.

    Sorry to ask such a simple question but since it's only relative to the Duet Wifi I figured I'd ask here. Thanks!



  • Uh, what do you mean by "port forwarding"?

    The Duet WiFi only responds to HTTP requests on port 80 from any host that can see it. One configuration some people use is a proxy running on a different machine, perhaps a raspberry pi, that accepts connections from the outside world and forwards them to the Duet WiFi. Are you talking about something like this? I haven't set it up, but I'd use SSH to connect from the outside host and use SSH's port forwarding to connect to the Duet; I have this working for other web services. I think it's also possible to use a proxy machine that translates some kind of authenticated HTTPS connection from the outside to an HTTP connection to the Duet.

    The Raspberry Pi is a full-fledged if wimpy Linux machine, so it supports HTTPS itself as well as SSH, which allows you to set up some kinds of port forwarding without using an extra machine. It is not capable of real-time work, so the Duet uses a 32-bit MCU which does not run Linux and provides rather limited network services.



  • I have a similar issues, I can't access the Duet Wifi when I am logged in my VPN.
    VPN devices use a different subnet and are routed via the gateway.
    For me it seems the Duet does not use the gateway to send the data.
    One solution might be to use a reverse proxy but I didn't try yet…


  • administrators

    Currently, the Duet WiFi will always use the gateway address assigned to it by the router using DHCP. Do you need to set a different gateway address to get access via your VPN?



  • Nope I don't need a different gateway, it is just that gateway, it does DHCP and the VPN (and a lot of other stuff).
    But from VPN I don't get a connection…



  • Possibly not relevant, but my router won't show the DuetWifi in the list of attached devices even when it is connected and functioning normally. But knowing its MAC address I can assign it to be allocated the same IP each time reliably.



  • @DjDemonD:

    Possibly not relevant, but my router won't show the DuetWifi in the list of attached devices even when it is connected and functioning normally. But knowing its MAC address I can assign it to be allocated the same IP each time reliably.

    I can do the same, though the MAC address my router shows has nothing in common with the one I set in the config…



  • The Duet WiFi ignores the G-code network configuration; its network settings live aboard the ESP8266 board.



  • @peridot:

    The Duet WiFi ignores the G-code network configuration; its network settings live aboard the ESP8266 board.

    Nice to know… I just changed the files which were on the SD whne it arrived, so I thought what was already in there would work...


  • administrators

    @Alex9779:

    @peridot:

    The Duet WiFi ignores the G-code network configuration; its network settings live aboard the ESP8266 board.

    Nice to know… I just changed the files which were on the SD whne it arrived, so I thought what was already in there would work...

    This and other known firmware issues are listed at https://duet3d.com/wiki/Pre-production_hardware_limitations_and_known_firmware_issues.



  • This and other known firmware issues are listed at https://duet3d.com/wiki/Pre-production_ … are_issues.

    Oh well, I read that page, I can't remember everything 😉

    I am thinking how I can possibly analyse whats going on, but I have only "cheap and unmanaged" network switches so packet analyzing between "other" devices than my computer and the device is not possible…



  • Guys, tell me please. I have a similar problem, but it appeared just after I tried to change my ip to another. The question is whether the fault be a proxy server?


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.