M376 (Set bed compensation taper) not working?



  • I have [c]M376 H0.5[/c] in my config.g, but I just noticed the Z is still continuously being adjusted despite my current print's Z having exceeded 21mm.

    Is there a minimum value (is 0.5mm too low)?

    Or is there some other way M376 could be overridden/cancelled? (I know I don't have any other M376 commands anywhere else.)

    Running 1.20RC1 (2017-12-08)


  • administrators

    Yes 0.5mm is too low. The minimum is 1mm.



  • I think you'd prefer to have the taper over a higher distance anyway. I use 10mm for mine, though with my piezo sensor leveling I only have maybe .1mm difference from high-low points.


  • administrators

    @SuperJETT:

    I think you'd prefer to have the taper over a higher distance anyway. I use 10mm for mine, though with my piezo sensor leveling I only have maybe .1mm difference from high-low points.

    That's why we set a minimum. If you use e.g. 0.2mm layer height, then if the taper height is only 1mm, 20% of the correction will be removed on each of the first 5 layers. So if there are height errors of up to +/-0.1mm, there will be up to +/-0.02mm variation in layer height during the first 5 layers. The firmware doesn't yet correct for this, so this represents 10% over or under extrusion in places caused by the tapering. A higher taper distance will reduce this effect.



  • Thanks everyone. In my mind I'd had it set to 5mm (I must have been thinking cm when I entered it) - was surprised to see 0.5mm in my config, but I still expected it to work (maybe not work WELL) since I didn't see a minimum in the docs.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.