Web interface not working anymore



  • Hi!

    Yesterday, I configured DWC to use my new webcam, based on a pizerow running motioneyeos. Right after saving the config, I didn't see the video flux. I then hit F5 to refresh the GUI, and since this moment, DWC does not work Anymore. I see the main GUI, but the navigator still waits for datas: I can't connect, buttons don't work…

    What puzzles me is I already used a webcam (based on an old RPi 1, running same motioneyeos), and all worked fine. DWC was configured on another machine...

    Any idea what's going on? How can I debug this? I tried to remove all cookies, no change. And I have the same problem under Chromium and Firefox.

    Thanks for your help.


  • administrators

    Have you now disabled the webcam in DWC?

    DWC stores its settings in HTML5 local storage, not cookies. So that's what you need to clear to revert to default settings.



  • As I don't have access to a working GUI, I can't do anything from DWC.

    Where is this HTML5 local storage? On my computer (browser), or on Duet SD card?


  • administrators

    HTML local storage is maintained by the browser. In Chrome I presume it is included in "Cookies and other site data" if you need to clear it.

    Which firmware version are you running, and which version of DuetWiFiserver if mit is a Duet WiFi?

    Web interface issues are sometimes caused by the .js and .html files in DWC becoming mismatched, either because of mixed versions in the /www folder or because the browser has cached the .js file.

    Have you tried pressing control-shift-J to enable the debugging console, to see if there are any exception messages?



  • I tried to remove cookies and all duet related stuffs from Chromium without change.

    I will connect through USB to retrieve firmware versions.

    There are 2 things strange: I did this before, with my previous camera (same motioneyeos config), from another chromium, on another machine, and it worked fine. And this time, when it failed in Chromium, I switched to Firefox, and I had the same symptoms. If the config is browser dependent, why is it not working from Firefox?

    And yes, I tried the debug console, but didn't see anything relevant.



  • BTW, I think the problem was related with the poor wifi signal strength. As soon as I had the camera link, it failed to communicate. With the new ESP module, with antenna, all is working fine.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.