My Beta board experience - :)



  • Gotta wonder at the postal service sometimes, my mailbox is easy to put small boxes in but I happened to look out the window and seen this little box sitting on top and it was a little bundle of joy called a DuetWiFi….... really glad I was both home and it wasn't raining.

    IT's arrived just in time to find my Delta being pulled apart to fix an issue with skewed prints, seems like the last couple of -4c nights have managed to twist the entire frame though it's not obvious how yet...

    OK onto first thoughts and setup at least.

    In no particular order.

    • WiFi antenna looks potentially fragile and will definitely benefit from protection
    • hate all the labelling on the bottom as you can't read it once it's mounted in a case, at least for probe and panel can this be on the top, aware room is limited for labels
    • the heater connections look cramped so close to the 4 pin header.

    Now initial config:
    I must be one of the few people never to have used Pronterface or anything equivalent so I just ignored the great instructions and winged it.
    Removed the SD card, un-commented the M552 line, put card back in and powered up from USB.
    Grabbed the Ipad and searched for the DuetWiFi access point and connected.
    Went to 192.168.1.1 and page loaded.
    Selected my network, entered the secured password and hit enter, page responds all ok please reboot...... oh bother no button to reboot, oh well just hit reset button and pray 🙂
    Waited 30 seconds and checked to see if the DuetWifI point was back and it wasn't... so off to find what IP my DHCP had assigned
    A quick network scan with a network scanner showed a new device amongst the 29 others 🙂
    Tried that and connected without issue.
    Updated the firmware to 1.13b

    So it is possible to commission the board with nothing more than a web browser. It would be good if the initial web page had a reboot button/function available.

    I'll start migrating my config over to this board in preparation for getting the Delta back up and running in the next week as i'll take the chance whilst it is apart to replace the z tower belt that appears to be damaged. I have new 10mm belt ordered but looks like it won't arrive till next Tuesday


  • administrators

    Thanks for your write up of first impressions, looking forward to seeing how you get on and get printing

    one point:

    • the heater connections look cramped so close to the 4 pin header.

    We made a decision to not have any high components over the last 20mm of the board, the side where the SD card etc is, that allows it to be fit between the extrusions on a 20x20 frame easily. This is a common mounting solution on Delta printers built with these extrusions (see David's blog post for an example). That does have the side effect of making the heater screw terminals quite close to the E1 motor connector, however it not so close as to interfere.



  • Thanks Tony, I do remember seeing that 20mm specification before and why… I'd just forgotten, blame the poor ageing brain.

    Cheers


  • administrators

    I agree, the WiFi antenna needs protecting. I plan to design and print a protective cover to go over it, to fit on the Kossel electronics rear panel I published on Thingiverse.



  • Ok, update time finally 🙂

    I've spent the last few weeks rebuilding my large Delta chasing a weird issue and got it back running with the Duet 0.8.5 board, The issue was prints leaning in the positive x-y direction…. seems like i didn't find the issue so decided to swap the boards over anyway today.
    Steps
    Copy all the relevant config from the 0.8.5 config file into the Duet WiFi config file.
    Updated Duet WiFi to the latest firmware, this was done via the web page and went without issue.
    I have not yet had to resort to USB/Ponterface at all.
    Printed a new case for the Duet Wifi on the Delta and with all the settings and speeds backed down it turned out ok

    Pulled the 0.8.5 board out from under the Delta and thought…. am I really responsible for that wiring mess...

    The migration of the wiring is straight forward except for the Bed Sensor connection now being reversed, nearly caught me out!
    I hit a issue though when I went to remove the stepper connections and subsequently I may have found a factor in the issues I've been having…
    I had used pre-crimped headers that were jointed to the stepper cables, the individual pins were high temperature hot glued together.... as you can see from the photo for the x-y steppers at least one phase of the wiring had got the connectors hot enough to not only melt the glue but to melt the plastic housings. This would indicate a high resistance joint and no doubt was causing real missed steps.

    Thankfully these were all pig-tailed connections so easy to unplug and use better connectors for the Duet WiFi.
    Here's the board wired in.

    Of course Murphy had to strike…. I moved from a 50mm blower fan (noisy) for cooling to quiet 75mm blower fan whilst I had moved the entire bed structure down about 5mm during the rebuild so now the board doesn't fit underneath.... guess I'll need to mount it on the outside for the time being.

    Power up was nervous but uneventful. The Duet WiFi connected quickly to the AP in the garage and I'm getting around 560Kb transfer rates.
    The PanelDue connects MUCH faster than for the 0.8.5 board.

    All I've done is run initial movement tests and an initial auto-calibration after checking the Z 0 height was still correct. I tried a print but the autocal set the Z height 0.6mm lower that then caused Z0 to be actually 0.3mm off the bed so a full calibration run tomorrow before trying that again.

    The initial impression is the the steppers are definitely quieter and everything works exactly as expected.

    Kudo's and Thanks to David and Tony


  • administrators

    Cheers for the feedback Phil, fingers crossed you have solved the leaning issue as well!



  • Well a full wasted day later I think I want to throw the damn Delta out….. the Duet WiFi is performing well though. I'm not seeing disconnects like others and it is behaving... I'll kick off a new thread to see if some experts can help me trouble shoot things.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.