Firmware 1.19 connection problems



  • Hi,

    im running duet wifi with duex2 for almost a year now without problems.
    Recently i upgraded the firmware to version 1.29 and now i have a lot of connection problems.:

    1. i cannot connect add all, after restarting the duet or randomly after some time i can connect.
    2. it disconnects me (a lot) . " An AJAX Error has been reported etc.. Error reason : Timeout"

    I dont think this is a wifi problem because it wasnt a problem with the old firmware.

    im running Wifi Server version 1.19.2 and web interface version 1.19.3


  • administrators

    Have you tried the 1.20 release?



  • Was there a bug in 1.19 that is fixed in 1.20 ?

    i read the thread about 1.20 some are also reporting connection problems,

    Maybe i try that one today.



  • 1.20 fixed the problem



  • sorry it did not fixed the problem, i still get the AJAX errors.
    Im running :
    Duet wifi 1.) + Duex2
    firmware version 1.20
    wifi server version 1.20
    web interface version 1.19.3

    Is it possible to go back to the old firmware ? i didnt have this problem before.

    This is my M122 reply.
    M122
    === Diagnostics ===
    Used output buffers: 4 of 32 (10 max)
    === Platform ===
    RepRapFirmware for Duet WiFi version 1.20 running on Duet WiFi 1.0 + DueX2
    Board ID: 08DAM-999TL-MQ4S8-6J9F2-3S06T-9497Z
    Static ram used: 15448
    Dynamic ram used: 99448
    Recycled dynamic ram: 3888
    Stack ram used: 1392 current, 8440 maximum
    Never used ram: 3848
    Last reset 00:12:23 ago, cause: power up
    Last software reset details not available
    Error status: 0
    Free file entries: 9
    SD card 0 detected, interface speed: 20.0MBytes/sec
    SD card longest block write time: 203.5ms
    MCU temperature: min 16.8, current 30.8, max 31.1
    Supply voltage: min 24.0, current 24.0, max 24.5, under voltage events: 0, over voltage events: 0
    Driver 0: ok, SG min/max 0/140
    Driver 1: ok, SG min/max 0/173
    Driver 2: standstill, SG min/max 0/148
    Driver 3: ok, SG min/max 0/180
    Driver 4: ok, SG min/max 0/124
    Driver 5: ok, SG min/max 0/192
    Driver 6: ok, SG min/max 0/187
    Expansion motor(s) stall indication: yes
    Date/time: 2018-01-21 11:39:24
    Cache data hit count 2958946100
    Slowest main loop (seconds): 0.206642; fastest: 0.000045
    === Move ===
    MaxReps: 5, StepErrors: 0, FreeDm: 145, MinFreeDm 105, MaxWait: 2930606083ms, Underruns: 0, 0
    Scheduled moves: 1515, completed moves: 1496
    Bed compensation in use: none
    Bed probe heights: 0.000 0.000 0.000 0.000 0.000
    === Heat ===
    Bed heaters = 0 -1 -1 -1, chamberHeaters = -1 -1
    Heater 0 is on, I-accum = 0.0
    Heater 1 is on, I-accum = 0.1
    Heater 2 is on, I-accum = 0.3
    === GCodes ===
    Segments left: 1
    Stack records: 2 allocated, 0 in use
    Movement lock held by null
    http is idle in state(s) 0
    telnet is idle in state(s) 0
    file is doing "G1 X70.409 Y135.981 E4.72573" in state(s) 0
    serial is idle in state(s) 0
    aux is idle in state(s) 0
    daemon is idle in state(s) 0
    queue is idle in state(s) 0
    autopause is idle in state(s) 0
    Code queue is empty.
    Network state is running
    WiFi module is connected to access point
    Failed messages: pending 0, notready 0, noresp 0
    WiFi firmware version 1.20
    WiFi MAC address 5c:cf:7f:2c:25:2f
    WiFi Vcc 3.32, reset reason Turned on by main processor
    WiFi flash size 4194304, free heap 16416
    WiFi IP address 192.168.2.15
    WiFi signal strength -69dBm, reconnections 0, sleep mode modem
    HTTP sessions: 1 of 8
    Socket states: 0 2 2 0 0 0 0 0
    Responder states: HTTP(1) HTTP(1) HTTP(0) HTTP(0) FTP(0) Telnet(0)



  • i see my wifi strength is not great -69dBm, but i dont think this has anything to do with it.
    For example if i upload file it just works fine even with really big ones,



  • i missed the number of AJAX retries setting, it was set to 1, changed to 5 and it is a bit better,
    But i still get disconnects.
    Maybe i set it to a really high number.
    But it doesnt really fix the problem i think it just makes it workable



  • oke with AJAX retries set to 50 i was connected for 5 minutes. but then i get the AJAx error
    and i could not reconnect again it looks like web server is just down . My browser gives me this error : ERR_CONNECTION_RESET

    When i send ping to the Duet it does reply so it does have a wifi connection.



  • is there a special procedure to go back to the old firmware ?
    i think the last working version (for me) was :

    • DuetWifiFirmware-1.17e
    • Duetwebcontrol-1.14a
    • DuetWifiServer-1.03-ch

  • administrators

    Have you tried both versions 1.20 and 1.20+1 of DuetWiFiFirmware?



  • i download this version : https://github.com/dc42/RepRapFirmware/releases/
    thats 1.20
    Where can i get the 1.20+1 ?

    I prefer to go for the latest version that didnt have the disconnect problems .

    i see on this board users who have this 1.20+1 version and the are also reporting disconnects.

    I dont have a panel due connected so my only option to print is with the webinterface.



  • i will upload the old firmware today and hope it will work.

    • DuetWifiFirmware-1.17e
    • Duetwebcontrol-1.14a
    • DuetWifiServer-1.03-ch


  • i installed the old firmware, and untill now i didnt see any Ajax erros .

    it looks like there is a bug in the 1.19 and later firmware. or my board is broken.

    would be nice if this is fixed so i can also enjoy the new features.



  • its running for 5 hours now and still no AJAX errors.

    So im happy i can print again, but if its not fixed , im stuck with old firmware….


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.