Dual printing Z height appear to refuse to advance starting layer 3



  • so I have updated to 1.20. and I'm still having issue with incorrect Z height while printing at certain layer

    T0 and T1 were printing with no issue and as expected up until layer 3

    layer 1 Z=0.24
    layer 2 Z=0.44
    layer 3 Z=0.64

    upon finishing layer 2, I observed web control status was reporting Z at 0.64 but it was clear that my T1 seems to be still in layer 2… so it was squashing everything...

    not sure what happened here. is it possible that my Z is loosing step? it also appear that this issue is only happening while in dual printing mode.

    I will try to up my z motor from 850ma to 980ma and see if things change...

    Stephen



  • ok… I have confirmed something I'm pretty sure not supposed to happened.

    at the end of my homez.g I have lock both Z drives into one with
    M584 Z2:5 ; join both Z together

    while printing somewhere around layer 5 or so, I observed that T1 which is connected to drive Z5 had stay still and did not advance one layer up while Z2 continue to go up one layer. so the next turn T1 is called to print it was actually printing at the same layer previous layer height.

    I wanted to stop but I let it print for a while and observed that T0 was printing perfectly fine and T1 also continue to advance in Z together with T0. but the damage already done as both Z is not not at the same layer height anymore.

    I can't predict which layer exactly T1 would skip going up in Z.

    I really wanted this dual printing to work. I'm more than happy to provide any information to help troubleshoot this issue.

    Thanks,
    Stephen


  • administrators

    Check that in config.g you are setting the Z motor current with M906 at a point at which both drivers are assigned to Z, to make sure that the M906 command is applied to both drivers. Similarly with any M913 commands that you may be using in the homing files.



  • in my config.g

    I have in this order
    M584 X0 Y1 U6 Z2:5 E3:4
    M906 X950 U950 Y950 Z980 E800:800 I30 ; Set motor currents (mA) and motor idle factor in per cent

    should I do Z980:980 instead?


  • administrators

    @stephenc:

    in my config.g

    I have in this order
    M584 X0 Y1 U6 Z2:5 E3:4
    M906 X950 U950 Y950 Z980 E800:800 I30 ; Set motor currents (mA) and motor idle factor in per cent

    should I do Z980:980 instead?

    What you already have is correct.

    I suspect that either you have a mechanical issue with your second Z axis, or you have set the Z acceleration a little too high.



  • Compared to x y accel, my z accel is set quite low already at 250.

    I did start to wonder if I have a bad Z motor on that T1 tower so I ran a test print only with T1 and was able to complete with no issues. So problem only consistently occurred in dual printing mode.

    I'll try a new motor



  • Turns out it's mechanical issue… I was pulling the belt too tight that the z leadscrew was binding...


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.