Effector z-probe light not flashing



  • Green light for z prob is on but not flashing when bumping it. Using 24v and not using the hotend fan or cooling fan. The board don't need these to work properly correct? Nimble is also installed, pt100, and 24v heater which works. Nimble screws have nylon spacers. I unplugged the 8 pin connector and i get 2.9v-3.0v on the 3.3v and gnd pins. When i plug it in i get 1.3v on the board programming header pins and on the back of the plug solder connections. Should i try to melt fresh solder on the bottom board plug connections. Is my board bad? it is a newer board.

    ; Configuration file for Neal's XXXL Rostock

    ;****************************** Communication and general ******************************
    M111 S0 ; Debug off
    M555 P2 ; Set output to look like Marlin
    M575 P1 B57600 S1 ; Comms parameters for PanelDue
    G21 ; Work in millimeters
    G90 ; Send absolute coordinates…
    M83 ; ...but relative extruder moves

    ;****************************** Ethernet Networking ******************************
    M552 S1 ; Enable Ethernet
    M540 ; MAC Address
    M550 ; Machine name and Netbios name (can be anything you like)
    M551 ; Machine password (used for FTP)

    ;****************************** Axis and motor configuration ******************************
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M569 P4 S0 ; Drive 4 goes forward
    M574 X1 Y1 Z1 S0 ; Set end stop configuration
    M665 L505.30 R220 B200 H1300 X0 Y0 Z0 ; Set delta diagonal rod length, radius, printable radius and homed height
    M666 X0 Y0 Z0 ; put your end stop adjustments here, or let auto calibration find them
    M350 X32 Y32 Z32 E16 I1 ; Set 32x micro stepping with interpolation
    M92 X320 Y320 Z320 E2400 ; Set axis steps/mm *** XYZ(23HM22-2804S) E(42BYGHW811)***
    M906 X2400 Y2400 Z2400 E1750 I60 ; Set motor currents (mA) and increase idle current to 60%
    M201 X5400 Y5400 Z5400 E120 ; Accelerations (mm/s^2)
    M203 X24000 Y24000 Z24000 E3600 ; Maximum speeds (mm/min)
    M566 X2600 Y2600 Z2600 E40 ; Maximum instant speed changes mm/minute

    ;****************************** Tool definitions ******************************
    M106 P1 T35 H1 ; Set temp for 35c then turn on water pump
    M106 P0 T35 H2 ; Set temp for 35c then turn on chamber fan
    M92 E470:470 ; Set Extrude steps per mm

    ;****************************** Hot end 1 ******************************
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 S0 R0 ; Set tool 0 operating and standby temperatures
    M301 H1 P27.5 I0.126 D115.3 ; Set PID for hot end 1
    M305 P1 X200 ; Set to PT100
    M307 H1 A302.8 C223.4 D6.5 B0 S1.0 ; Set process parameters for heater 1, use PID, and limit heater 1 PWM to 100%
    M143 H1 S270 ; Set the maximum temperature of the hot-end to 265°C
    T0 ; Select first hot end

    ;****************************** Bed ******************************
    M305 P0 T100000 B3950 R4700 H30 L0 ; Heater 0 is monitored by a 100K thermistor with B=3950 and a 4.7K series resistor
    M143 H0 S165 ; Set the maximum bed temperature to 165C
    M307 H0 A183.1 C1561.5 D.7 B0 S1.0 ; Set heating process parameters using pid to 100%

    ;****************************** Chamber heater ******************************
    M141 H2
    M305 P2 T100000 B3950 R4700 H30 L0 ; Heater 2 is monitored by a 100K thermistor with B=3950 and a 4.7K series resistor
    M570 H2 P10 T10 ; Set heater fault detection for pin 2, 10 second anomaly, 10c excursion
    M307 H2 A72.0 C71.5 D1.4 B0 S1.0 ; Set heating process parameters using pid to 100%
    M143 H2 S90 ; Set the maximum temperature of the chamber to 90°C

    ;****************************** Z probe and compensation definition ******************************
    M558 P5 X0 Y0 Z0 H3 R0.4 F1000 T2000 ; Set prob type, homing axis, dive height, recovery time, feed rate, travel speed
    M557 R220 S15 ; Set prob grid radius 210mm, spacing 15mm
    G31 P100 X0 Y0 Z-0.1 ; Set trigger value, x/y offset, z height

    ;****************************** Notes ******************************
    ;Chamber fan using fan pwm ~ pin 0
    ;Water pump using fan pwm ~ pin 1
    ;Berd air using fan pwm ~ pin 2
    ;Chamber led using fan pwm ~ red pin 3, green pin 4, blue pin 5, white pin 6



  • Green light stays on when I unplug the six pin harness.


  • administrators

    The sensor part should work with the 6-pin harness not connected. If the green LED is on at full brightness continually, then it sounds like a bad board to me.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.