Driver 3 not working



  • Hello,
    i have a problem with my duet wifi board. My driver 3 seems not to work. I configured in the config.g "M584 X0 Y1 Z2 E3" and my extruder doesnt move, when the hotend is heated up. When i change it to drive 4 with changing the wiring too, then i can move it. I've tried a different motor with another cable with the same result.


  • administrators

    I'm sorry you seem to have a faulty driver on your Duet. Ask your supplier to replace your Duet. If you bought it from the Duet3D web site, email info at duet3d dot com.



  • Yesterday i got my replacement board. Now the driver 3 is working, but with strange noises. When i configure it to driver 4 it works normal.

    I uploaded a video from it:

    https://youtu.be/e1qOTnp0OQM

    My config.g for the drives section:
    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M584 X0 Y1 Z2 E3 ; Apply custom drive mapping
    M350 X64 Y64 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X320 Y320 Z1600 E90; Set steps per mm
    M566 X480 Y480 Z30 E120; Set maximum instantaneous speed changes (mm/min)X2400 Y2400
    M203 X48000 Y48000 Z180 E12000; Set maximum speeds (mm/min)
    M201 X2000 Y2000 Z500 E250; Set accelerations (mm/s^2)
    M906 X1800 Y1800 Z900 E1800 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout



  • I've tried another motor, the noise is the same, when i change it to driver 4 it works perfekt.
    Did i get another board with an faulty driver?



  • Out of curiosity, when you changed to driver 4, did you change the line M584 X0 Y0 Z2 E3 to M584 X0 Y0 Z2 E4 and add M569 P4 S1 ? Or was driver 4 set to use default values?



  • I used the default values, but i also tried the defaults on driver 3.
    I just changed it to M584 X0 Y1 Z2 E4, whitout the line M569 P4 S1.



  • Hmmm. Curiouser and curiouser as they say. One faulty board is very unusual, two with the same fault is a bit like being struck by lightening twice (well maybe not as rare as that but pretty rare). Have you tried extruding filament with just the extruder but no hot end. Just to check if the motor runs, and in the right direction.



  • Not sure if its the same fault, with the first board the motor was not moving, but now it moves with strange noises. When its idle there is a high pitch noise, but just with E0. The motor is rated with 2A, i also tried lower currents.
    With the motor configured to E1 i have already tried to print, and it works so far. But with configured to E0 i just extruded filament, in the video i have filament loaded and disconnect the bowden tube of the hotend side. The moving direction is correct.


  • administrators

    Will it print using E0? It's possible to have a partially-blown driver that will turn the motor when it is not under load, but won't turn the motor when significant load is applied or when the movement is very slow.



  • I've tried that now, just with a simple cube in vase mode. It prints with E0, but with this strange noise. I've tested to higher the extrusion speed, without a hotend. At about 60mm/s the noise disappears.


  • administrators

    If you wish to request another replacement, I will approve it.



  • We just replaced this a few days ago, same symptoms! I did wrote Roland, please keep us informed.


  • administrators

    From the first post in this thread, I thought the symptom last time was that driver 3 didn't work at all?



  • Thats right, the last symptom was the driver was not working.

    This time the driver works, but generating a strange noise on the motor in low speeds.



  • There is something i forgot about when i postet about the second board:
    There was a spot of solder from the production, between C70 and C46, which i removed before i connect something to the board.

    Here is a photo including the serial sticker on the processor.

    To the problem with the blown driver: What can cause this damage? I've checked the wires, the connections and the extruder motor several times and can still not find an issue with these. I did never disconnect a motor, while the board has power.


  • administrators

    C70 and C46 are decoupling capacitors, so not related to the driver issue.

    A small proportion of driver chips have latent fault that our testing does not pick up. Also, moving the axes or the extruder gear by hand too fast while the motors are connected to the drivers can cause drivers to fail.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.