Duet showing TWO tools active at the same time?



  • Running 1.20.1RC2 (and the beta of paneldue that enables the message boxes):

    Two extruders, two hot ends, two thermocouples, two fans, etc. BOTH are showing as active at the same time. The are both showing as being active in both the DWC and on the PanelDue. From the temperature settings, it might be obvious that only T1 should be active. Link to google photos showing images of both:

    https://photos.app.goo.gl/pr6GFqYFJrHWa3142

    The tools are configured as:

    [[language]]
    ; Tools
    M563 P0 D0 H1                                      ; Define tool 0
    G10 P0 X-34.04514634972721 Y0.29743029572304586 Z0 ; Set tool 0 axis offsets (from tool 1 - which is the tool I use to home)
    G10 P0 R0 S0                                       ; Set initial tool 0 active and standby temperatures to 0C
    M563 P1 D1 H2                                      ; Define tool 1
    G10 P1 X0 Y0 Z0                                    ; Set tool 1 axis offsets (I use tool 1 to home)
    G10 P1 R0 S0                                       ; Set initial tool 1 active and standby temperatures to 0C
    
    

  • administrators

    Are you certain you don't have a third tool configured that uses both heaters? If you send T by itself without a tool number, which tool does it say is active?



  • Pretty sure I don't have a third tool. 🙂 When I send "T" from the g-code console… well.. it repeats the last several browser messages (but doesn't say which tool is active):

    [[language]]
    5:59:46 PM    T
        Simulating print of file PLA - R/DL Font Samples.gcode
        File PLA - R/DL Font Samples.gcode will print in 2h 10m plus heating time
        File PLA - R/DL Font Samples.gcode selected for printing
    5:59:44 PM    Message Log cleared!
    
    

    In fact, no matter what I send through the g-code console, it does the exact same thing:

    [[language]]
    6:02:24 PM    SADFASDFASDFASDF
        Simulating print of file PLA - R/DL Font Samples.gcode
        File PLA - R/DL Font Samples.gcode will print in 2h 10m plus heating time
        File PLA - R/DL Font Samples.gcode selected for printing
    
    

    Tried "M408 S0" and just get back those old log messages. (BTW, the simulation shown there was done… 3 hours ago or so.)

    If I close the Chrome window and instead open IE and go to my DWC, I get the exact same responses (tested to ensure it isn't a browser cache issue.)

    Same if I open a Chrome incognito window.

    I don't have telnet active, so I can't try that way.



  • I suspect if I reboot everything it'll clear up. I've seen oddities like this crop up from time to time and I end up pulling the plug to reset everything before it works.



  • More info: If I use the console on the PanelDue, I can send a "T" and get a response: Tool 1 is selected. (Even though the panelDue has both tools highlighted in red/active.)



  • …and more info: M408 doesn't seem to work from the paneldue console, but I was able to activate telnet from it. Then M408 gave this:

    {
    	"status": "P",
    	"heaters": [60.5, 36.4, 195.2],
    	"active": [60.0, 0.0, 195.0],
    	"standby": [0.0, 0.0, 0.0],
    	"hstat": [2, 2, 2],
    	"pos": [-3.449, -37.203, 8.082],
    	"sfactor": 100.00,
    	"efactor": [100.00, 100.00],
    	"babystep": 0.000,
    	"tool": 1,
    	"probe": "0",
    	"fanPercent": [60.00, 100.00, 100.00, 0.00, 0.00, 0.00, 0.00, 0.00, 0.00],
    	"fanRPM": 0,
    	"homed": [1, 1, 1],
    	"fraction_printed": 0.7984,
    	"msgBox.mode": -1,
    	"timesLeft": [1554.5, 1521.2, 1549.9]
    }
    


  • According to the M408 Secret Decoder Ring (https://duet3d.com/wiki/G-code), this is telling me that tool 1 is active, but that both tool heaters are also active (hstat.) How can that be? My tool configuration is in the first post in this thread. There are no other heaters on my duet (and couldn't be: I have no expansion cards.)

    Nothing virtual. Just for the sake of completeness, here's M408 S2 that specifically shows all the heaters (heads, tools, extra):

    [[language]]
    {
    	"status": "P",
    	"coords": {
    		"axesHomed": [1, 1, 1],
    		"extr": [0.0, 6371.4],
    		"xyz": [-56.918, 23.395, 8.442]
    	},
    	"currentTool": 1,
    	"params": {
    		"atxPower": 0,
    		"fanPercent": [60.00, 100.00, 100.00, 0.00, 0.00, 0.00, 0.00, 0.00, 0.00],
    		"speedFactor": 100.00,
    		"extrFactors": [100.00, 100.00],
    		"babystep": 0.000
    	},
    	"sensors": {
    		"probeValue": 0,
    		"fanRPM": 0
    	},
    	"temps": {
    		"bed": {
    			"current": 60.2,
    			"active": 60.0,
    			"state": 2,
    			"heater": 0
    		},
    		"current": [60.2, 36.1, 195.1, 2000.0, 2000.0, 2000.0, 2000.0, 2000.0],
    		"state": [2, 2, 2, 0, 0, 0, 0, 0],
    		"heads": {
    			"current": [36.1, 195.1],
    			"active": [0.0, 195.0],
    			"standby": [0.0, 0.0],
    			"state": [2, 2]
    		},
    		"tools": {
    			"active": [[0.0], [195.0]],
    			"standby": [[0.0], [0.0]]
    		},
    		"extra": [{
    				"name": "MCU",
    				"temp": 29.6
    			}
    		]
    	},
    	"time": 28334.0
    }
    
    

  • administrators

    I suggest you run M563 P1 to check whether it currently has tool 1 configured to use heaters 1 and 2.



  • @garyd9

    If you closely at the DWC display, you'll see that both heaters are active (in the heaters column) but in the column to the left of that (the tools column) Tool 1 is underlined but Tool 0 is not. The underlined tool is the active tool. For both tools to be active, they would both show as underlined.

    If it's any consolation, it caught me out too at first and I have in the past requested that the active tool should be displayed in a more prominent way such as a different colour or in bold. The underline is not obvious at first glance.

    HTH

    Edit. I can't comment on the PanelDue display - I suspect that shows heaters rather than tools as I've only ever seen one column of temperatures for my 4 or 6 tools which all share the same heater. I've never been able to figure out which is the active tool on the PanelDue.



  • Result of M563 P1: Tool 1 - drives: 1; heaters (active/standby temps): 2 (0.0/0.0); xmap: X; ymap: Y; fans: 0; status: standby. (It might be irrelevant as the print job has finished and run M0 which turns off everything.)

    deckingman and dc42: I hope everyone understands that I'm not "complaining" about issues here. I feel that if I'm using software that's being actively developed, and especially a beta or RC version, that it's my obligation to find, try to troubleshoot, and report any issues. The idea that two heaters can be active with only a single tool (and they are configured for one heater per tool) is one of those issues. This particular issue really doesn't impact me, as a heater "active" with a temp of 0 is the same as a heater "off" with a temp of 0. As well, this particular issue was a one-off. I've never seen it happen before, so I could only collect data on it while it was happening with the knowledge that as soon as the print was stopped the tools/heaters would all be turned off.

    There are other issues I've reported that are a bit more significant (such as the one where M116 commands are seemingly ignored.)



  • That's all fine. I was just replying to the title of your post which is that two TOOLS are active at the same time. I guess heaters need to be active on order to maintain standby temperature even if the tool itself isn't active.



  • @deckingman:

    That's all fine. I was just replying to the title of your post which is that two TOOLS are active at the same time. I guess heaters need to be active on order to maintain standby temperature even if the tool itself isn't active.

    I do appreciate you pointing out the underlining of the tool. It helps to make clear that only one TOOL was active/selected while both HEATERS were active. That's one of the differences with the duet (and RRF, I guess) that I haven't quite become used to: "has a" relationships instead of "is a."


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.