PID Autotuning



  • Running PID Autotunning on my hotend

    24v 40W heater, on E3D V6 1.75 with silicone cover

    Sent Code M303 H1 P0.2 S240

    Message:

    Warning: Heater 1 appears to be over-powered and a fire risk! If left on at full power, its temperature is predicted to reach 798C.
    Auto tune heater 1 with PWM=0.20 completed in 635 sec, maximum temperature reached 175.5C

    Heater 1 model: gain 778.7, time constant 227.3, dead time 7.5, max PWM 1.00, in use: yes, mode: PID
    Setpoint change: P7.0, I0.03, D36.5
    Load change: P7.0, I0.35, D36.5

    Why would it say its over-powered if it wasnt able to reach the set temperture? of 240C
    I will try again with a higher P rating.



  • Also trying to run AutoPID on my Bed
    which is a 110v 750W silicone heater connected to a SSR

    Sent Code: M303 H0 P0.25 S80

    It was heating up slowly. i thought it would time out as it took longer then 10 seconds per 1 degree
    but then i got this error

    Message was this.
    Auto tune of heater 0 with P=0.25 S=80.0 cancelled because temperature limit exceeded. Use lower P or higher S in m303 command

    If i lower the P I dont think it will hit the temp.



  • Setting a higher P setting with cause the Temp to overshoot even slightly.
    how are you suppose to get Autotune to complete?



  • Increase the S parameter to allow the heater to reach the desired temp (the S AFAIK sets the max temp to allow the tune cycle to get to) sure DC will be allong to comment before long.

    Doug



  • The S parameter may never be hit when autotuning. It's not used for the autotuning to reach, but as one not to exceed.

    For the bed, I use 140 since it's less than the temp the thermal fuse I installed trips at.


  • administrators

    As Stephen says, the temperature parameter is a "do not exceed" temperature, not a target temperature. So I suggest you increase it.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.