No Calibration and no compensation….Grrrpffddsdf!!!!!!!!!!!



  • Hi,

    i have finish reinstall IR Height sensor, and problems…. similar problems i had while try install BlTouch.

    What works?

    A- I have instaled as web instrucctions say
    B- When start printer, flashes,think 4 times.
    C- When i close an object to IR Sensor, can read in Duet Web Control/Zprobe, arround 500.
    D- When send a [c]G30 S-1[/c], and close the bed or and object, head stops

    Until this point, that works.

    What not works?

    1 - Try autocalibrate, and i have a headcrash
    2 - Try autocompensation, i have another headcrash

    I think must be a configuraion problem…

    Attach, [c]config.g[/c], and [c]bed.g[/c]

    config.g

    [[language]]
    ; Configuration file for Duet Wifi (firmware version 1.20)
    ; executed by the firmware on start-up
    ;
    
    ; General preferences
    M111 S0 ; Debugging off
    G21 ; Work in millimetres
    G90 ; Send absolute coordinates...
    
    M83 ; ...but relative extruder moves
    M555 P1 ; Set firmware compatibility to look like RepRapFirmare
    M665 R165 L360.25 B175 H550; Set delta radius, diagonal rod length, printable radius and homed height
    M666 X0 Y0 Z0 ; Put your endstop adjustments here, or let auto calibration find them
    M208 Z0 S1 ; Set minimum Z
    
    ;Ajustar la escala en los ejes, en las Delta, bufff
    
    M579 X1 Y1 ; 
    
    ; Endstops
    M574 X2 Y2 Z2 S1 ; Define active high microswitches
    M557 R130 S30 ; Define mesh grid
    
    ; Escher Ir Differential sensor
    M558 P1 H10 F120 T1000 ; Set Z probe type to smart, dive height, and the probe + travel speeds
    G31 P500 X0 Y0 Z1.250 ; <------------------------------------------Set Z probe trigger value, offset and trigger height
    
    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S0 ; Drive 3 goes forwards
    M350 X32 Y32 Z32 E16 I1 ; Configure microstepping with interpolatio
    M92 X160 Y160 Z160 E2470 ; Set steps per mm
    M566 X600 Y600 Z600 E40 ; Set maximum instantaneous speed changes (mm/min)
    M203 X12000 Y12000 Z12000 E3000 ; Set maximum speeds (mm/min)
    M201 X600 Y600 Z600 E1500 ; Set accelerations (mm/s^2)
    M906 X1200 Y1200 Z1200 E7200 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout
    
    ; Heaters
    M143 S285 ; Set maximum heater temperature to 285C
    M301 H0 S1.00 P10 I0.1 D200 T0.4 W180 B30 ; Use PID on bed heater (may require further tuning)
    M305 P0 R4700 T100000 B3950 ; bed
    M305 P1 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 1
    
    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C
    
    ; Network
    M550 Duet3D ; Set machine name
    M587 S"DLink-869L.2,4" P"a1b2c3d4" I192.168.1.99; Configure access point. M587 S"NOMBRE RED" P"PASSWORD"
    M586 P0 S1 ; Enable HTTP
    M586 P1 S1 ; Enable FTP
    M586 P2 S1 ; Enable Telnet
    M552 S1
    
    ; Fans
    
    M106 P0 S0 I0 F255 H-1; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F255 H1 T50; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I0 F255 H1 T50; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    ; Custom settings are not configured
    
    ; Miscellaneous
    M501 ; Load saved parameters from non-volatile memory
    
    

    bed.g

    [[language]]
    ; bed.g; bed.g file for RepRapFirmware, generated by Escher3D calculator
    ; 16 points, 6 factors, probing radius: 140, probe offset (0, 0)
    
    M561                        ; clear any bed transform, otherwise homing may be at the wrong height
    G28                            ; home the printer
    
    M401	;Deploy BlTouch
    G30 P0 X0.00 Y135.00 Z-99999 H0
    G30 P1 X116.91 Y67.50 Z-99999 H0
    G30 P2 X116.91 Y-67.50 Z-99999 H0
    G30 P3 X0.00 Y-135.00 Z-99999 H0
    G30 P4 X-116.91 Y-67.50 Z-99999 H0
    G30 P5 X-116.91 Y67.50 Z-99999 H0
    G30 P6 X0.00 Y67.50 Z-99999 H0
    G30 P7 X58.46 Y-33.75 Z-99999 H0
    G30 P8 X-58.46 Y-33.75 Z-99999 H0
    G30 P9 X0 Y0 Z-99999 S6
    M402	;Retract Probe
    
    G1 X10 Y10 F3000
    
    M500
    
    

    Ideas????



  • when homed what is the distance from the nozzle to the bed?



  • aprox 5 mm



  • no homed is at the max distance so should be a lot more than 5mm
    I Think I know whats wrong but need that figure to prove it and to tell you what to alter if I'm Right


  • administrators

    The distance we need is the height of the nozzle above the bed when all 3 carriages are triggering the endstop switches.



  • Distance… 505 mm


  • administrators

    So you need H505 in the M665 command, not H550.



  • ok in that case you have an error in your Config.g

    This line M665 R165 L360.25 B175 H550 needs to be M665 R165 L360.25 B175 H505

    Also until you have it successfully calibrated comment out the M501 line at the end



  • ok…

    later try...

    This, change [c]M665 R165 L360.25 B175 H550[/c] for [c]M665 R165 L360.25 B175 H505[/c], can be the cause for autocalibration causes a headcrash?

    If i send a [c]AUTOCALIBRATION[/c]…. they should not stop the movement of Nozzle, when ZStop was on? When head reach bed, whatever the order M665



  • Results of [c]M122[/c], in case it gives more information:

    [[language]]
    M122
    === Diagnostics ===
    Used output buffers: 3 of 32 (8 max)
    === Platform ===
    RepRapFirmware for Duet WiFi version 1.20 running on Duet WiFi 1.0
    Board ID: 08DGM-95BNL-MGPSN-6JKDL-3S06L-92W7W
    Static ram used: 15448
    Dynamic ram used: 99024
    Recycled dynamic ram: 216
    Stack ram used: 1392 current, 4504 maximum
    Never used ram: 11880
    Last reset 00:03:12 ago, cause: power up
    Last software reset at 2018-01-20 12:49, reason: User, spinning module GCodes, available RAM 7784 bytes (slot 0)
    Software reset code 0x0003 HFSR 0x00000000, CFSR 0x00000000, ICSR 0x0441f000, BFAR 0xe000ed38, SP 0xffffffff
    Error status: 0
    Free file entries: 10
    SD card 0 detected, interface speed: 20.0MBytes/sec
    SD card longest block write time: 0.0ms
    MCU temperature: min 24.7, current 32.8, max 32.9
    Supply voltage: min 24.6, current 24.7, max 24.9, under voltage events: 0, over voltage events: 0
    Driver 0: standstill, SG min/max not available
    Driver 1: standstill, SG min/max not available
    Driver 2: standstill, SG min/max not available
    Driver 3: standstill, SG min/max not available
    Driver 4: standstill, SG min/max not available
    Date/time: 2018-01-21 07:28:43
    Cache data hit count 735649989
    Slowest main loop (seconds): 0.075306; fastest: 0.000041
    === Move ===
    MaxReps: 0, StepErrors: 0, FreeDm: 240, MinFreeDm 240, MaxWait: 0ms, Underruns: 0, 0
    Scheduled moves: 0, completed moves: 0
    Bed compensation in use: none
    Bed probe heights: 0.000 0.000 0.000 0.000 0.000
    === Heat ===
    Bed heaters = 0 -1 -1 -1, chamberHeaters = -1 -1
    === GCodes ===
    Segments left: 0
    Stack records: 1 allocated, 0 in use
    Movement lock held by null
    http is idle in state(s) 0
    telnet is idle in state(s) 0
    file is idle in state(s) 0
    serial is idle in state(s) 0
    aux is idle in state(s) 0
    daemon is idle in state(s) 0
    queue is idle in state(s) 0
    autopause is idle in state(s) 0
    Code queue is empty.
    Network state is running
    WiFi module is connected to access point 
    Failed messages: pending 0, notready 0, noresp 0
    WiFi firmware version 1.20
    WiFi MAC address 2c:3a:e8:0b:05:a1
    WiFi Vcc 3.36, reset reason Turned on by main processor
    WiFi flash size 4194304, free heap 13960
    WiFi IP address 192.168.1.106
    WiFi signal strength -66dBm, reconnections 0, sleep mode modem
    HTTP sessions: 1 of 8
    Socket states: 2 0 0 0 0 0 0 0
    Responder states: HTTP(1) HTTP(0) HTTP(0) HTTP(0) FTP(0) Telnet(0)
    
    


  • @peirof:

    ok…

    later try...

    This, change [c]M665 R165 L360.25 B175 H550[/c] for [c]M665 R165 L360.25 B175 H505[/c], can be the cause for autocalibration causes a headcrash?

    If i send a [c]AUTOCALIBRATION[/c]…. they should not stop the movement of Nozzle, when ZStop was on? When head reach bed, whatever the order M665

    Yes because in the M558 line you have H10 this tells the firmware to run down to the bed (H550 in your M665) to 10 mm short at high speed then slow down to probe for the last 10mm because you have the starting hight set to 45mm longer than you Z Actually is it tries to travel to 35mm below the bed before it starts to probe.

    The other thing you could do is to increase the H Value in the M558 to say 60 and try it but do remember that once the Calibration has finished and you put the correct figures into your Config.g (And you should do this) then you will have to reduce that M558 H back down to 10 or even 5.

    Hope this helps

    Doug



  • I have a dude…

    i do this:

    1- Power on Duet printer
    2- Homing
    3- Test Z-Probe (Mini IR Sensor). Seems work, in DWI, Zprobe=538
    ...
    and the problems
    ...
    4- Test autocalibrate
    5- The nozzle goes down slow
    , in the way i put an obstable in Mini Ir Sensor, the same works, zprobe=558... but movement dont stops
    6- Power off printer for avoid headcrash

    why dont stops to go down?
    G30 S-1... works, object stops go down nozzle



  • More info…

    Bed compensation.... WORKS!!!!!!!

    Why "cojones" [c]autocalibration[/c] fail??????????????????????



  • Hi,

    Bed compensation works…. but strange results...

    When you makes a [c]calibration[/c], Duet do the[c] bed.g[/c] contents, no?

    my bed.g, for if someone can see the fail….

    [[language]]
    ; bed.g
    ; called to perform automatic delta calibration via G32
    ;
    ; generated by RepRapFirmware Configuration Tool on Sun Jan 21 2018 07:57:47 GMT+0100 (Hora estándar romance)
    M561 ; clear any bed transform
    G28  ; home all towers
    ; Probe the bed at 10 peripheral and 6 halfway points, and perform 6-factor auto compensation
    ; Before running this, you should have set up your Z-probe trigger height to suit your build, in the G31 command in config.g.
    G30 P0 X0 Y154.58 H0 Z-99999
    G30 P1 X87.61 Y120.59 H0 Z-99999
    G30 P2 X138.78 Y45.09 H0 Z-99999
    G30 P3 X138.78 Y-45.09 H0 Z-99999
    G30 P4 X87.61 Y-120.59 H0 Z-99999
    G30 P5 X0 Y-154.58 H0 Z-99999
    G30 P6 X-91.11 Y-125.4 H0 Z-99999
    G30 P7 X-147.41 Y-47.9 H0 Z-99999
    G30 P8 X-147.41 Y47.9 H0 Z-99999
    G30 P9 X-91.11 Y125.4 H0 Z-99999
    G30 P10 X0 Y76.76 H0 Z-99999
    G30 P11 X60.2 Y34.76 H0 Z-99999
    G30 P12 X60.2 Y-34.76 H0 Z-99999
    G30 P13 X0 Y-76.76 H0 Z-99999
    G30 P14 X-67.12 Y-38.75 H0 Z-99999
    G30 P15 X-67.12 Y38.75 H0 Z-99999
    G30 P16 X0 Y0 H0 Z-99999 S6
    ; Use S-1 for measurements only, without calculations. Use S4 for endstop heights and Z-height only. Use S6 for full 6 factors
    ; If your Z probe has significantly different trigger heights depending on XY position, adjust the H parameters in the G30 commands accordingly. The value of each H parameter should be (trigger height at that XY position) - (trigger height at centre of bed)
    
    

    Another strange thing, is when i do a single [c]G30 S-1[/c], works. But when i try to [c]calibrate.g[/c], a series of G30 gcodes….DON'T WORK...


  • administrators

    1. In your M558 command, aset a high H value for now (e.g. H40) until you have calibration working.

    2. If that doesn't help, what happens if you send the first G30 lin from your bed.g file, i.e. G30 P0 X0 Y154.58 H0 Z-99999 ?

    3. Confirm that X0 Y154.58 is reachable by the IR sensor, and not off the edge of the bed or closer than 10mm to the edge.



  • More info…

    i have try, to do 1 line of [c]bed.g[/c], by console.

    I have sended [c]G30 P0 X0 Y154.58 H0 Z-99999[/c], and…

    The first thing, this command by console don't works.

    In this moment, i have sended [c]G30 X0 Y154.58 H0 Z-99999[/c], without P0 and… partially works, the nozzle goes down, until Zprobe trigger, and stop the movement, until this point works, but the nozzle dont go to [c]X0 Y154.58[/c], the test is meassured WHERE THE NOZZLE WAS…. i dont know if this behavoir is normal...

    NOTE: i have read the message of DC42, after post...



  • RESPOND

    @dc42:

    1. In your M558 command, aset a high H value for now (e.g. H40) until you have calibration working.

    2. If that doesn't help, what happens if you send the first G30 lin from your bed.g file, i.e. G30 P0 X0 Y154.58 H0 Z-99999 ?

    3. Confirm that X0 Y154.58 is reachable by the IR sensor, and not off the edge of the bed or closer than 10mm to the edge.

    1- In this moments, i have this [c]M558 P1 Z1 H40 F120 T4800[/c], think this change yesterday, i haved read in forum

    2- This is what I just tried and commented on the previous post

    3- In teory, yes. The bed has 310 mm of diameter/2= 155 mm, in the limit, i go to down this measure



  • NEWS!!!!!!!!!!!!!!!!!!!!!!!!!!!!

    WORKS….WORKS..... WORKS.......

    DC42.....YOU ARE THE BEST........

    MANY THANKS ..... MILLIONS OF THEM. If you come to Valencia (Spain) you are invited to a Paella Valenciana


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.