Motors are not running quiet



  • I got my DuetWifi yesterday.
    After hardwarewireing I was trying the movement of moters but the noise is very hight.

    in my config.g I have put in M350 X16 Y16 Z16 I1

    my Firmware:

    Firmwarename: RepRapFirmware for Duet WiFi
    Firmware Elektronik: Duet WiFi 1.0
    Firmware Version: 1.20.1 (2018-01-08)
    WiFi Server Version: 1.20
    Web Interface Version: 1.20

    Can anybody help?


  • administrators

    0. Are the motors moving correctly?

    1. Check that you have the motor currents set appropriately. Between 50% and 85% of the rated current of the motors is usually good.

    2. At some speeds you may excite resonances in the mechanics, which will make the machine noisier than at other speeds. All the same, you should find that with I1 (interpolation enabled) in the M350 command, the motors are a lot quieter than with I0 (no interpolation).

    HTH David



  • 0. yes motors are moving correct
    1. I´ll try to go down with the currents. at moment I´ve set 1200mA (motors can handle 2.5A)
    2. I´ve used Ramps Board with TMC2100 drivers, no issues and quiet
    And I´ve set parameter I1 for interpolation but nothing is changed

    I did an fault as I´ve pressed de erased button insted of reset
    After that I´ve installed firmware new by using Sa-ba
    But my WIFI connection isn´t stable. Also Firmware Elektronik is changed from 1.20 to Duet WiFi 1.0
    I used the docu on https://www.duet3d.com/wiki/Updating_main_firmware
    Any idea whats going wrong?

    Hardwareverion of board is 1.02


  • administrators

    Firmware Electronics always shows as Duet WiFi 1.0. It's the firmware version that should show as 1.20.

    Please run M350 without parameters to check that interpolation is enabled.

    If you were previously using TMC2100 drivers, you were almost certainly using no more than about 1.0A motor current.



  • Thats what I got from M350 command

    18:09:39M350
    Microstepping - X:16(on), Y:16(on), Z:16(on), E:16(on):16(on):16:16:16:16:16:16:16

    I´ve degrased motor current to 900mA but w/o success
    I tried to set 256 but nothing changed

    In both modes are the noise the same with or w/o interpolation



  • I have tried some diffrent settings and I guess somwthing goes wrong.

    As I used repetier FW on Ramps I used these settings for microstepping:

    [[language]]
    #define XAXIS_STEPS_PER_MM 160.32
    #define YAXIS_STEPS_PER_MM 160.32
    #define ZAXIS_STEPS_PER_MM 400
    
    

    TMC2100 drivers where working in 1/16 with Interpolation

    These are my settings for duetwifi:

    [[language]]
    ; Drives
    M569 P0 S1                                      ; Drive 0 goes forwards
    M569 P1 S1                                      ; Drive 1 goes forwards
    M569 P2 S0                                      ; Drive 2 goes backwards
    M569 P3 S0                                      ; Drive 3 goes backwards
    M350 E16 I1                                     ; Configure microstepping with interpolation
    M350 X16 Y16 Z16 I1                             ; Configure microstepping with interpolation
    M92 X160.32 Y160.32 Z820 E440                   ; Set steps per mm
    M566 X900 Y900 Z12 E120                         ; Set maximum instantaneous speed changes (mm/min)
    M203 X6000 Y6000 Z1200 E4800                    ; Set maximum speeds (mm/min)
    M201 X500 Y500 Z250 E250                        ; Set accelerations (mm/s^2)
    M906 X1200 Y1200 Z1400 E800 I30                 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30                                         ; Set idle timeout
    
    

    If I press X+1 X-Carriage goes about 10mm Thats not correct. So I guess drivers didn´t work with correct parameters

    Any chance to fix that?


  • administrators

    Apart from the fact that you have changed the Z steps/mm from 400 to 820, I can't see anything wrong. Please:

    1. Post your complete config.g file;

    2. Confirm that you are using 0.9deg X and Y motors;

    3. Run M92 without parameters and check that the X and Y steps/mm are as you have set them above.



  • 1. Here are the complete config.g

    [[language]]
    ; Configuration file for Duet WiFi (firmware version 1.20 or newer)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Sun Jan 21 2018 15:11:26 GMT+0100 (Mitteleuropäische Zeit)
    
    ; General preferences
    M111 S0                                         ; Debugging off
    G21                                             ; Work in millimetres
    G90                                             ; Send absolute coordinates...
    M83                                             ; ...but relative extruder moves
    M555 P5                                         ; Set firmware compatibility to look like Repetier
    ; Automatic saving after power loss is not enabled
    
    M667 S1                                         ; Select CoreXY mode
    M208 X0 Y0 Z0 S1                                ; Set axis minima
    M208 X330 Y330 Z300 S0                          ; Set axis maxima
    
    ; Endstops
    M574 X1 Y1 Z1 S1                                ; Set active high endstops
    M558 P0 H5 F120 T9600                           ; Set Z probe type to switch and the dive height + speeds
    G31 P600 X330 Y0 Z0.6                           ; Set Z probe trigger value, offset and trigger height
    M557 X15:285 Y15:285 S20                        ; Define mesh grid
    
    ; Drives
    M569 P0 S1                                      ; Drive 0 goes forwards
    M569 P1 S1                                      ; Drive 1 goes forwards
    M569 P2 S0                                      ; Drive 2 goes backwards
    M569 P3 S0                                      ; Drive 3 goes backwards
    M350 E16 I1                                     ; Configure microstepping with interpolation
    M350 X16 Y16 Z16 I1                             ; Configure microstepping with interpolation
    M92 X160.32 Y160.32 Z820 E440                   ; Set steps per mm
    M566 X900 Y900 Z12 E120                         ; Set maximum instantaneous speed changes (mm/min)
    M203 X6000 Y6000 Z1200 E4800                    ; Set maximum speeds (mm/min)
    M201 X500 Y500 Z250 E250                        ; Set accelerations (mm/s^2)
    M906 X1200 Y1200 Z1400 E800 I30                 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30                                         ; Set idle timeout
    
    ; Heaters
    M301 H0 S1.00 P10 I0.1 D200 T0.4 W180 B30       ; Use PID on bed heater (may require further tuning)
    M305 P0 T100000 B3988 C0 R4700                  ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120                                    ; Set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4725 C7.060000e-8 R4700        ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280                                    ; Set temperature limit for heater 1 to 280C
    
    ; Tools
    M563 P0 D0 H1                                   ; Define tool 0
    G10 P0 X0 Y0 Z0                                 ; Set tool 0 axis offsets
    G10 P0 R0 S0                                    ; Set initial tool 0 active and standby temperatures to 0C
    
    ; Network
    M550 PHEVO                                      ; Set machine name
    M552 S1                                         ; Enable network
    M587 S"routerwsid" P"routerpw" ; Configure access point. You can delete this line once connected
    M586 P0 S1                                      ; Enable HTTP
    M586 P1 S0                                      ; Disable FTP
    M586 P2 S0                                      ; Disable Telnet
    
    ; Fans
    M106 P0 S0 I0 F500 H-1                          ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H T45                        ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I0 F500 H T45                        ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on
    
    ; Custom settings are not configured
    
    

    2. I use 1,8 deg stepper
    ACT Motor 5pcs Nema17 Stepper 17HS5425L20P1-X2,48mm,2.5A with single plan

    3. M92
    Steps/mm: X: 160.320, Y: 160.320, Z: 820.000, E: 440.000:440.000:440.000:440.000:440.000:440.000:440.000:440.000:440.000



  • If you have 1.8 degree ungeared motors directly driving 20 tooth pulleys the steps per mm at 16x micro stepping should be 80. If you use 16 tooth pulleys, then the steps per mm should be 100.

    Z depends on the lead of your lead screws so without that information, I can't say what they should be.



  • You´re right. If I count i like http://reprap.org/wiki/Triffid_Hunter%27s_Calibration_Guide#XY_steps I got 80 steps/mm

    But my first issue is left. Drivers won´t work in interpolation mode. Noise is like A4988



  • Are you getting the correct amount of movement now, and in the correct direction for all axes?



  • I´ve changed to 80.16 an it seems to be ok but not quite


  • administrators

    There should be a large difference in the motor noise between x16 microstepping with interpolation on, and with interpolation off.

    You can also try increasing microstepping (but interpolation only works in x16 mode). If you put the changed M350 command after the M92 command in config.g, or you send it from the command line, then you won't have to change the steps/mm in M92.



  • I´ve tested today again and I can hear a different noise with Interpolation on and off.
    Tomorrow I will test some different speeds

    Tanks for your help


  • administrators

    What speeds have you been testing with so far, and what are the steps/mm ? Microstep interpolation doesn't work at very low or very high speeds, but it works at speeds in the typical range for 3D printers. I'd like to get to the bottom if this just in case there is a firmware or hardware bug affecting it.



  • I tested with 1000 mm/min quiet | 7000 mm/min more noise | 12000 mm/min bit more than 7000

    I guess it is ok and my tough was confused because wrong microsteppings

    Thank you for kindly support


  • administrators

    I have noticed that microstep interpolation is far more successful at reducing motor noise at low speeds than it is at high speeds. This isn't surprising, because at high speeds there isn't time for the chip to do high microstepping. For example, my delta has 200 microsteps/mm at x16. At 100mm/sec this gives a step pulse rate of 20kHz, which is half the chopper frequency. So the maximum theoretical microstep rate at this speed is x32.



  • Ah I see. It makes sense.

    Thanks David


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.