ERROR:Temperature reading fault on heater 1: open circuit



  • I am new to the DuetWifi Community, I have built several Smoothieboard printers, but this is my first on Duet Platform. I have all my axis working just find now I am on to the Heaters. So this is where I am having the real issue, any help you can provide would be great!

    Question 1: I have an external controller for my bed heater, is it possible to set up duet so it doesnt look to the Bed temp? I have ";" the line out for the bed temperature, but I am not sure that is the correct way to handle this.

    Queston 2: I have tried to set up several hotends (Dyze and 1730 both tested fine on a different control board) with both I keep getting the same error "Temperature reading fault on heater 1: open circuit" I have tested the F1 Fuse (Good) both Heaters (Good), I can not figure what I am doing wrong.

    Config:
    ; Thermistors and heaters
    ;*** You can use S and B parameters to define the parameters of the thermistors you are using
    ;M305 P1 T4500000 B5253 R4700 H0 L0
    ;M305 P1 T98630 B4211 R1000 H0 L0
    ;M305 P0 R4700 H0 L0 ; Put your own H and/or L values here to set the bed thermistor ADC correction
    M305 P1 R4700 H0 L0 ; Put your own H and/or L values here to set the first nozzle thermistor ADC correction
    ;M305 P2 R4700 H0 L0 ; Put your own H and/or L values here to set the second nozzle thermistor ADC correction
    M301 H1 P10 I0.10 D100 T0.50 S1.0 ; PID settings for extruder 0
    ;M301 H2 P10 I0.10 D100 T0.50 S1.0 ; PID settings for extruder 1
    M570 S120 ; Increase to allow extra heating time if needed

    ; Tool definition
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 S0 R0 ; Set tool 0 operating and standby temperatures
    ;*** If you have a dual-nozzle build, un-comment the following 3 lines
    ;M563 P1 D1 H2 ; Define tool 1
    ;G10 P1 S0 R0 ; Set tool 1 operating and standby temperatures


  • administrators

    1. Use M140 H-1 in config.g to tell the firmware there is no bed heater. Then the bed heater won't show up in DWC. Currently, it will still show up on PanelDue.

    2. The "open circuit" message means that the thermistor is or appears to be open circuit (I guess I ought to clarify the message). Your present config is set up for a Semtech 100K thermistor because it does not specify a T or B value, so it certainly won't work with a Dyze thermistor,. If your first commented-out M305 line was intended to configure the firmware for the Dyze thermistor, then I think it is wrong because AFAIR the Dyze has a resistance of 450Kohms at 25C, not 4.5Mohms.

    HTH David



  • Thanks for the M140 H-1 that worked perfectly!

    As for question 2
    I tried the following:

    M305 P1 T450000 B5253 R4700 H0 L0
    M305 P1 T45000 B5253 R4700 H0 L0

    any other ideas?

    Thanks for the help!


  • administrators

    Some suggestions:

    1. Are you certain that your thermistor wiring is OK and really isn't open circuit?

    2. The Dyze thermistor can be tricky to get working well because of its very high resistance at room temperature. Does your other hot end have a standard 100K thermistor? if so then I suggest you get that one working first. After that we can return to the Dyze.

    3. Try connecting the thermistor to the E1 thermistor input instead of E0. Configure a tool to use E1 (e.g. M563 P1 H2 D0) so that the E1 temperature shows up in DWC.

    4. If you are uncertain about your wiring, connect a resistor across the thermistor pins and see if you get a reading, e.g. a 100K resistor should give you a reading of 25C using standard or default M305 settings for a 100K thermistor.

    5. If both thermistor channels always read open circuit, this suggests that the VSSA fuse has blown. The usual cause of this is a short in the hot end or bed heater wiring between the thermistor wires and the heater wires. To check this, measure the resistance between the thermistor pin labelled VSSA and ground (e.g. the ground pin on one of the endstop connectors). It should measure just a few ohms.

    HTH David



  • I will chime in on this issue. I own a Dyze 500°C thermistor. Without a parallel resistor it gives me the disconnected fault. The real resistance at 25°C is really around 4.5MOhm and much higher at 20°C. The board works with a parallel 1 MOhm resistor. I actually made a wiring extension with parallel Dupont connector to be able to experiment with different resistors. it's not perfect, but the measurement error gets very small at 200-250°C which is my preferred printing temperature. If we had support for steinhart-hart parameters (on FW 1.17) I could probably make it read room temperature accurately, but right now, I have to live with 45-50°C readings at 20°C (from the parallel resistance error).

    I really wish there would be a firmware workaround to disregard the "disconnected" state for these thermistors at room temp.


  • administrators

    Thanks dcaron. If the Dyze thermistor has a resistance of 4.5M at 25C then I was wrong about the M305 command being incorrect.

    The thermistor disconnect detection is a safety feature, to prevent uncontrolled heating if the thermistor really does become disconnected.

    My personal view is that if you want to cover a wide temperature range, you should use a thermocouple or RTD instead of a thermistor, because they will give you much better accuracy over a wide temperature range than a thermistor can.



  • Thanks dc42,
    I've been told Dyze Design is working on a low thermal mass PT100 for their hotend. According to them, this should be available shortly. I will probably grab one if the price is reasonable. I already have the PT100 daughterboard ready! I agree the PT100 has desirable linear characteristics for wide range temperature measurements. The problem with thermistors is that they have to be specified for a narrower temperature range to be precise. The reasoning for the Dyze thermistor is still quite interesting regarding the precision and low response time around printing temperature. The only real flaw is the very low accuracy/high resistance at room temperature.
    I'm not affiliated with them whatsoever, but it's still a very good hotend with a lot of desirable characteristics.


  • administrators

    @dcaron:

    I've been told Dyze Design is working on a low thermal mass PT100 for their hotend. According to them, this should be available shortly. I will probably grab one if the price is reasonable. I already have the PT100 daughterboard ready!

    That's good news. Perhaps you should volunteer to test it with the Duet WiFi for them, if they send you a free one!



  • Hello all,

    I'm receiving the same error message "temperature reading fault on heater 1: open circuit". I replaced the fuse with a .25 amp fast acting fuse and 5 x 20 fuse holder, but that didn't work either. I made sure to solder the fuse to the same spot user "cap" did in this thread: https://www.duet3d.com/forum/thread.php?id=247. This is on my new kossel XL with the duet wifi. Everything was working fine until i replaced one of my fans on my hotend. I accidentally had it wired wrong and it burnt out the fan. Though the hot end was still heating up fine. It wasn't until i got the new fan, replaced it, that i started to get the above error message. When i checked my hotend for a short i indeed saw that the back of my z sensor board was touching the hotend. Fixing that and the fuse i assumed would be the end of it but the message remains. Even after resetting the hotend in the duet web control with command M562 P1.

    thoughts?


Log in to reply