Very new need help with external drivers


  • administrators

    No, you do not need a Z probe to get Z movement working.

    Your config indicates that you are using external drivers connected to the expansion connector E4 and E5 sets of pins to drive the Z motors. Therefore, how hot your Z motors get depends on the current that you have set your external drivers to and is nothing to do with the Duet. Motors run at their full rated current always get very hot, therefore it's normal to run them below rated current.

    Did you add M569 P7 and M569 P8 commands to config.g, with T parameters?



  • I did maybe I need to check wires on them because the motors turn on but do not move. Thanks for letting me know I don't need to get zprob working first


  • administrators

    If the motors turn on when you first try to move them but not before then, that means the Enable wires are OK. If there is no sign of movement when you command them, check that the Step inputs of your drivers are wired correctly. If the motors vibrate loudly but do not move consistently, then there could be a problem with the wiring between the drivers and the motors, or you could be trying to move them too fast.



  • i re weird and all is working now… now on the the BLtouch can you tell me the 5 pins it should be going to i cant seem to get any defant findings also in the firmware set up what option do I use?



  • all is working now but my E0 motor. it was working before the other

    M584 E4 X6 Y5 Z7:8 ; Apply custom drive mapping



  • ok thank you for the help… last question I got BLtouch working took some digging.

    how can I raise Z higher in between probs

    at the end of a print it homes Xand Y but when the X end stop is hit Z goes down 10mm then the same with Y how can i stop this?


  • administrators

    @codfish124:

    how can I raise Z higher in between probs

    H parameter (dive height) in the M558 command.

    @codfish124:

    at the end of a print it homes Xand Y but when the X end stop is hit Z goes down 10mm then the same with Y how can i stop this?

    What it does at the end of a print is determined by your slicer end gcode. So it's your slicer configuration that you need to change.



  • so i change this

    M558 P5 X0 Y0 Z1 H5 F100 T2000

    to M558 P5 X0 Y0 Z1 H10 F100 T2000

    ?

    I have looked in the Gcode and it just had G28 X0 Y0

    what it dose is raise Z 10mm homes X lowers Z 10mm the raises it then homes Y and lowers and raises Z



  • thanks for all your help i will be replacing more printer boards with duets no more mks!!!


  • administrators

    @codfish124:

    so i change this

    M558 P5 X0 Y0 Z1 H5 F100 T2000

    to M558 P5 X0 Y0 Z1 H10 F100 T2000

    ?

    I have looked in the Gcode and it just had G28 X0 Y0

    what it dose is raise Z 10mm homes X lowers Z 10mm the raises it then homes Y and lowers and raises Z

    1. Yes.

    2. Instead of G28 X0 Y0 at the end of config.g you might want to use e.g. G0 X0 Y0 F5000. Or you might find e.g. G0 X0 Y200 more convenient.



  • thanks you….

    can you give me some insight on right now I'm having a shifting problem Y- seems like .1mm a layer not bad so I'm thinking it in accels

    M566 X50 Y50 Z12 E120 ; Set maximum instantaneous speed changes (mm/min)


  • administrators

    Layer shifts are usually caused by the hot end catching on a blob or curl-up from the previous layer during a travel move. Remedies may include:

    • Z hop during retraction/travel moves (practical on deltas, less practical on other architectures)
    • Better print cooling to avoid the curl up, or better retraction settings to avoid the blobs
    • Higher motor current
    • Reduce travel move speed

    However, it you are getting a layer shift at every layer, that sounds as if it is acceleration or speed related. Use the motor EMF calculator at https://configurator.reprapfirmware.org/ to check that you are not trying to make the motors move too fast and reduce top speed if necessary (M203); otherwise increase Y motor current if the Y motor is running cool, or reduce acceleration.



  • thank you i am working on speeds now i added a fan to the Y motor i might get a water cooling setup for it but cant seem to find many options.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.