Configurator never creates config.g



  • Hi

    I'm trying to get my Duet Wifi set up, and using the configurator as suggested. I've run through the pages dozens of times, tried different browsers, disabling popup blocker, leaving everything at default, and just about everything I can think of, but I when I get to the end it never seems to have generated config.g. If I click on it, unlike the others which bring up a preview, nothing happens. If I click to download the zip, it sits at "generating" indefinitely.

    What am I missing please?

    Many thanks

    Ian


  • administrators

    What OS are you using and which browsers have you tried?



  • Hello

    Win10: chrome, Firefox and IE. Chrome and Firefox (latest builds) did as above, IE had a quirk where it wouldn't bring up the WiFi options; only a MAC address field.



  • Hello

    I have the same issue.
    OS: Linux
    Browsers: Chrome and Firefox

    In the java-script console i get the following error:

    ejs.min.js:1 Uncaught SyntaxError: Unexpected token ) while compiling ejs
        at new Function (<anonymous>)
        at Template.compile (ejs.min.js:1)
        at Object.compile (ejs.min.js:1)
        at handleCache (ejs.min.js:1)
        at Object.exports.render (ejs.min.js:1)
        at Object.success (model.js:618)
        at i (jquery-2.2.3.min.js:2)
        at Object.fireWith [as resolveWith] (jquery-2.2.3.min.js:2)
        at z (jquery-2.2.3.min.js:4)
        at XMLHttpRequest. <anonymous>(jquery-2.2.3.min.js:4)</anonymous></anonymous>
    

    Maybe this helps.

    Best regards


  • administrators

    Thanks, we'll take a look.


  • administrators

    Thanks for the report, it is fixed now.



  • Thank you for the quick responses and fix, I've not got my Duet up and running. A bit of a learning curve doing the config, but I'm really pleased with it.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.