DWC won't open. What am I missing? Solved

  • my original post

    I am in the early stages of getting the Duet Ethernet up and running. I have established a connection via YAT to the board- M115 firmware 1.18.2, M552 network enabled, M552 S1 OK, downloaded the DuetWebControl-1.20.zip (or do I need the core?). At this point I think Im one step away. I need to know where to put the DWC files. I think I read in the www folder on the boards sd card but how do I access that?

    The real problem was that after following the steps here https://duet3d.dozuki.com/Guide/1.%29+Getting+Connected+to+your+Duet/7?lang=en using the Duet Ethernet DWC (Duet Web Control) would not open in the browser. I either got a "DNS" error or "this site can't be reached".For those such as myself that are network retards it might help if the "getting connected" page had instructions on how to configure your modem/router in the event it doesnt automatically do it on its own. There may be other ways and different systems may be slightly different but here's what I did:

    In addition to steps on the "Getting Connected" page

    • move SD card from Duet to computer

    • open the sys folder, right click on config.g and open with notepad or similar. Change the 1 to a zero in the IP e.g. to (my network only allows a "0")

    • record IP address

    • record MAC address from the config.g. note: only the last 2 characters in each of the 6 sets is used e.g P0xBE:0xEF:, etc.
      alternately M540 will return the MAC address in the correct format

    • Open the routers web interface in browser and log in

    • go to LAN setup, Address Reservation and add IP, MAC address and device name

    • in address bar in browser enter Duet IP and DWC opens. YIPPEE!!!

  • Put it in a computer and drag and drop?

  • It seems that you need to follow procedures for upgrading firmware from v 1.19 and earlier from here https://duet3d.dozuki.com/Wiki/Installing_and_Updating_Firmware#main I had to do this myself recently and it took time to read through everything and follow all steps. For my upgrade, I have taken out the SD card and mounted it on PC, which allowed me easily copy paste files. I think WebControl files unzipped go into /www folder. Hope that helps.

  • Thanks guys. Its all a bit overwhelming at the moment. Lots of info to consume. cant wait to get over the hump

  • administrators

    Just upload the DuetWebControl.zip file through the Settings General tab of DWC. It will be unzipped and the files will be put in the correct folders automatically.

  • @dc42:

    Just upload the DuetWebControl.zip file through the Settings General tab of DWC. It will be unzipped and the files will be put in the correct folders automatically.

    I cant get the DWC to open

  • administrators

    In that case, put the SD card on a PC, rename or delete the old /www folder, create a new one, and unzip DuetWebControl into it.

  • Unfortunately progress for this evening went to hell. I went back and reread this turorial https://duet3d.dozuki.com/Guide/1.%29+Getting+Connected+to+your+Duet/7 and realized after sending the M552 S1 I wasnt getting an "network running" but instead a temperature error because up until this point I had nothing connected to the board other than the PanelDue, USB and ethernet. I unplugged and installed the thermocouple board and 2 probes but did not notice the TC board was off 1 set of pins. When I plugged it back in the panel Due is showing vertical lines only and I can no longer communicate with it through YAT so I killed the board or the paneldue . DC42 can you confirm which? on top of that the USB port I had it connected to on my PC no longer works. Dont know if its corrupt or dead. Expensive evening.

  • administrators

    I'm sorry to hear of your mishap. I suggest you unplug everything from the Duet and follow https://duet3d.dozuki.com/Wiki/FAQ#Section_What_to_do_if_your_Duet_or_Duet_WiFi_won_t_respond.

  • Sorry for adding to your workload DC. I went through the link you provided. All the correct LEDs are lit, I am connected and the com port is configured with your drivers but shows up as BOSSA. If i send a command through YAT such as M115 or M552 I get no response. Although it was faint I do think there was a slight smell off the board as if something burned. Not there this morning though. I also removed 1.18 firmware from the SD card and added 1.20 but no change.
    Unless you have another idea I will order a new board but have a couple questions
    -since I plugged the TC board in wrong (one set of pins off away from the main processor chip) is there a potential the TC board was damaged?
    -before connecting the new board is it ok to only have the TC board connected and no other components? This board will be used to test motion components for a new printer and only control 1 stepper motor for now.

  • administrators

    If it shows up as BOSSA then try to reinstall the firmware using fallback procedure #3 at https://duet3d.dozuki.com/Wiki/Installing_and_Updating_Firmware.

    Yes it is OK to have the TC board connected and no motion components connected.

  • Ok. Reestablished communication with the board and have FW 1.20. With the exception of the PanelDue still showing only vertical lines it appears we are back at the original issue. In YAT I have network enabled and running but when I enter duettest.local or the IP address shown in YAT in to the browser address bar I either get a "DNS Error" or "This site cant be reached". FWIW it appears all the DWC files are in the www folder on the SD.

    This is is in addition to the paragraph above from earlier today. I was looking at my SD card structure and it doesnt look exactly the same as here https://duet3d.dozuki.com/Wiki/Firmware_Overview#Section_SD_card_structure
    there were also android folders and a DCIM folder on it which I deleted. Dont know how they got there but they were dated the first day I put the SD card in my PC.
    I posted over on RepRap because that was the easiest way for me to let you see what the structure looks like currently

  • administrators

    1. PanelDue: you can try reinstalling the PanelDue firmware. See https://miscsolutions.wordpress.com/paneldue/.

    2. DNS error means that your PC/smartphone/tablet is trying to look the site up in DNS instead of going to it directly. What device and browser are using? You may need to enter http:// explicitly before the IP address to prevent it from trying to use a https connection.

    3. Does the www folder have the same structure as the contents of the DuetWebCobtrol.zip file? i.e. js, css and fonts subfolders, with mostly .gz files inside them and in /www.

  • 1-
    I will do that

    I am using a laptop (which has a ethernet port which I have connected to the board with same result), windows 10, chrome browser (tried firefox too). No go on explicitly.

    it appears the www folder is good. I took a snap shot of it open in the same post on reprap titled- www open

    Since I am building 2 printers side by side I'm going to go ahead and order the second Duet Ethernet now. I will try to get a better understanding of how this whole network thing works on my end and if still not resolved by the time the board gets here I'll try that one.

    Thanks for your dedicated support

  • disregard

  • Can I change the initial IP address that my Duet Ethernet assigned itself? If so, how do I do that? I would like to change it to 192.168.0.xx

  • Yes it is set with the M552 command in the Config.G File

  • Since I have yet to open the DWC I can send M552 192.168.1.xx through YAT/USB to set the new IP address?

  • administrators


    1. Send M552 S0, then send M552 P192.168.1.xx, then send M552 S1. You should then be able to connect DWC. In DWC go to the System editor and edit the M552 command in config.g to have that IP address.


    2. Move the SD card to a PC and use a text editor to make the same change to the M552 command in config.g.

  • I edited my initial post in this thread with the solution

Log in to reply