Fail to initialise wifi



  • Please forgive me if I am doing something dumb here, complete newby. I was able to upgrade firmware ok but now when I do a M552 SO I get this.

    M115
    FIRMWARE_NAME: RepRapFirmware for Duet WiFi FIRMWARE_VERSION: 1.20 ELECTRONICS: Duet WiFi 1.0 FIRMWARE_DATE: 2017-12-23<lf>ok <lf>M552 SO
    ok<lf>WiFi module started<lf>Error: Failed to initialise WiFi module, code -10 <lf>I have done a search on the forum but came up with nothing.

    Thank you for any help</lf></lf></lf></lf></lf>


  • administrators



  • I went through the out of step instructions and this is what I have now. Still no wifi as far as I can tell.
    === Diagnostics === <lf>Used output buffers: 1 of 32 (32 max) <lf>=== Platform === <lf>RepRapFirmware for Duet WiFi version 1.20 running on Duet WiFi 1.0 <lf>Board ID: 08DDM-9FAM2-LW4SD-6JKF2-3SJ6R-KLZRY <lf>Static ram used: 15448 <lf>Dynamic ram used: 99320 <lf>Recycled dynamic ram: 4016 <lf>Stack ram used: 3576 current, 4648 maximum <lf>Never used ram: 7640 <lf>Last reset 00:09:01 ago, cause: power up <lf>Last software reset details not available <lf>Error status: 4 <lf>Free file entries: 10 <lf>SD card 0 detected, interface speed: 20.0MBytes/sec <lf>SD card longest block write time: 0.0ms <lf>MCU temperature: min 35.7, current 36.0, max 36.3 <lf>Supply voltage: min 1.6, current 1.7, max 1.7, under voltage events: 0, over voltage events: 0 <lf>Driver 0: ok, SG min/max not available <lf>Driver 1: ok, SG min/max not available <lf>Driver 2: ok, SG min/max not available <lf>Driver 3: ok, SG min/max not available <lf>Driver 4: ok, SG min/max not available <lf>Date/time: 1970-01-01 00:00:00 <lf>Cache data hit count 632266159 <lf>Slowest main loop (seconds): 0.151117; fastest: 0.000036 <lf>=== Move === <lf>MaxReps: 0, StepErrors: 0, FreeDm: 240, MinFreeDm 240, MaxWait: 0ms, Underruns: 0, 0 <lf>Scheduled moves: 0, completed moves: 0 <lf>Bed compensation in use: none <lf>Bed probe heights: 0.000 0.000 0.000 0.000 0.000 <lf>=== Heat === <lf>Bed heaters = 0 -1 -1 -1, chamberHeaters = -1 -1 <lf>Heater 1 is on, I-accum = 0.0 <lf>=== GCodes === <lf>Segments left: 0 <lf>Stack records: 1 allocated, 0 in use <lf>Movement lock held by null <lf>http is idle in state(s) 0 <lf>telnet is idle in state(s) 0 <lf>file is idle in state(s) 0 <lf>serial is ready with "M122" in state(s) 0 <lf>aux is idle in state(s) 0 <lf>daemon is idle in state(s) 0 <lf>queue is idle in state(s) 0 <lf>autopause is idle in state(s) 0 <lf>Code queue is empty. <lf>Network state is running <lf>WiFi module is idle <lf>Failed messages: pending 0, notready 0, noresp 0 <lf>WiFi firmware version 1.20 <lf>WiFi MAC address 5c:cf:7f:a4:06:97 <lf>WiFi Vcc 3.43, reset reason Turned on by main processor <lf>WiFi flash size 4194304, free heap 19600 <lf>HTTP sessions: 0 of 8 <lf>Socket states: 0 0 0 0 0 0 0 0 <lf>Responder states: HTTP(0) HTTP(0) HTTP(0) HTTP(0) FTP(0) Telnet(0) <lf>ok <lf>What should I do from here.
    Thank you for your time</lf></lf></lf></lf></lf></lf></lf></lf></lf></lf></lf></lf></lf></lf></lf></lf></lf></lf></lf></lf></lf></lf></lf></lf></lf></lf></lf></lf></lf></lf></lf></lf></lf></lf></lf></lf></lf></lf></lf></lf></lf></lf></lf></lf></lf></lf></lf></lf></lf></lf></lf></lf></lf></lf></lf></lf></lf></lf>


  • administrators

    Are you sending M552 S0 (which is correct), or M552 SO which is what you have written?

    What result do you get when you send M552 S1?



  • This is what I get,
    RepRapFirmware for Duet WiFi Version 1.20 dated 2017-12-23 <lf><lf>Executing config.g…WiFi module is disabled <lf>Warning: Heater 0 appears to be over-powered. If left on at full power, its temperature is predicted to reach 275C. <lf><lf>Done! <lf>RepRapFirmware for Duet WiFi is up and running. <lf>WiFi module started <lf>Error: Temperature readi
    M552 S0 <lf>ok <lf>M552 S1 <lf>ok <lf>WiFi reported error: no known networks found <lf>Wifi module is idle</lf></lf></lf></lf></lf></lf></lf></lf></lf></lf></lf></lf></lf>



  • Anything on my last post helpful ?


  • administrators

    I am sorry, somehow I missed your post of 27 February.

    The "no known networks found" message means that it didn't find any of the networks whose SSIDs you entered in M587. So:

    1. Run M587 with no parameters to list the networks (probably just one) you have told it about. Check that the SSID listed matches exactly the SSID of the WiFi network you want it to connect to. SSIDs are case-sensitive.

    2. If the SSID matches exactly, then the problem is probably insufficient WiFi signal strength at the Duet.

    I am assuming that your WiFi network doesn't use a hidden SSID. if it does then you need to quote the SSID in the M552 command.



  • Adding to David's post above, make sure that the network you are connecting to is 2.4GHz, the ESP wifi module does not support 5GHz.



  • Thank you that fixed it, I had my SSID wrong.

    Thanks again for your time and help. Now to get my machine all setup.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.