Y endstop getting no respect.



  • So … I have a Cartesian printer that I'm setting up with a Duet3dWiFi. Just by happenstance of wiring, X and Z are "forwards" and Y is "backwards"... so I have:

    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S0 ; Drive 1 goes backwards
    M569 P2 S1 ; Drive 2 goes forwards

    Then later on I have:

    M574 X1 Y1 Z1 S0 ; Set active low endstops

    ... now I've also tried Y2 there... but the Y axis (the printbed in this instance) slams against the Y stop and then proceeds to grind the belt for awhile. Now... the LED representing the Y stop lights... so what gives? How do I fix this?

    For reference, here's the totality of config.g:

    ; Configuration file for Duet WiFi (firmware version 1.20 or newer)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Fri Mar 02 2018 16:36:01 GMT-0500 (EST)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves
    M555 P0 ; Set firmware compatibility to look like native output

    ; Network
    M550 PMy printer ; Set machine name
    M551 Phr92tkam ; Set password
    M552 S1 ; Enable network
    M587 S"ac.DaveG.ca" P"ac.DaveG.ca" I192.168.221.42 J192.168.221.1 K255.255.255.0 ; Configure access point and IP addresses. You can delete this line once connected
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S0 ; Drive 1 goes backwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M350 X16 Y16 Z16 E16 I0 ; Configure microstepping without interpolation
    M92 X100 Y100 Z5128 E600 ; Set steps per mm
    M566 X900 Y900 Z12 E120 ; Set maximum instantaneous speed changes (mm/min)
    M203 X30000 Y30000 Z180 E1200 ; Set maximum speeds (mm/min)
    M201 X500 Y20 Z100 E250 ; Set accelerations (mm/s^2)
    M906 X800 Y1200 Z2000 E800 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X200 Y200 Z200 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y2 Z1 S0 ; Set active low endstops
    M558 P0 H5 F60 T6000 ; Set Z probe type to switch and the dive height + speeds
    G31 P600 X0 Y0 Z0.5 ; Set Z probe trigger value, offset and trigger height
    M557 X15:185 Y15:185 S20 ; Define mesh grid

    ; Heaters
    M301 H0 S1.00 P10 I0.1 D200 T0.4 W180 B30 ; Use PID on bed heater (may require further tuning)
    M305 P0 T100000 B3950 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4725 C7.060000e-8 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C

    ; Fans
    M106 P0 B1 S1 I0 F10 H1 T45:140 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P1 S1 I0 F500 H0:1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I0 F500 H-1 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned off

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic saving after power loss is not enabled

    ; Custom settings are not configured

    ; Miscellaneous
    M501 ; Load saved parameters from non-volatile memory
    T0 ; Select first tool


  • administrators

    Please test your endstops as described in the commissioning tests at https://duet3d.dozuki.com/Wiki/Step_by_step_guide.

    What type of endstop is it?



  • OK. I solved that, but I ended up with more confusion.

    For the X, say, -ve X travells towards the endstop. Pressing "home" travels to the endstop and then sets the X position as '0'.

    Y is backwards, but it's configured that way (see above). -ve Y movement moves towards the endstop, but after pressing 'home' for Y, and the bed travelling to the endstop, the Y value is set to 200 … so the bed effectively cannot move (200 is the max Y).



  • NM. Solved this problem. The web config somehow put in a y2 in the endstop list rather than y1. Odd that homing still went in the right direction.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.