SD Card contents



  • So I was in the process of wiring and configuring my new Duet, and during a reboot it suddenly stopped responding. Noticed a kind of clicking sound, and when the sd card is ejected it changed speeds. Tried plugging it into laptop, not registering at all as hardware, and I know it's not the reader because other SD cards still work. Pretty sure for whatever reason the card died.

    I've got replacements, but is it just the results of the configurator that end up on there? Or is there some other process that I need to go through to set up a new card?


  • administrators



  • OK, have rebuilt the card using the web folders from the firmware and the files from configurator. Board is failing to boot up and the Wifi and SD heat shields are getting hot, even when it's only plugged into USB. M552 is only returning "Wifi is starting", if I try to add access point I just get a failed error message.

    Right before it went out I had most of my Hypercube Evolution wired up, was testing motor movement and getting it but backwards, so inverted direction in the config and rebooted once it finished PID tuning hot end, and it never rebooted correctly. The ticking sound is gone with the new SD card, but it's still not apparently booting correctly.


  • administrators

    If you have a multimeter then I suggest you check the voltage on the 3.3V rail. One place you can measure this is on the Z probe connector.



  • I'll check with the meter in a bit and post back. The FB group suggested yesterday that I try redoing the firmware. The Wifi firmware seemed to install correctly, the Server firmware failed with the same error as this guy, the comm write error https://www.duet3d.com/forum/thread.php?id=3423I


  • administrators

    If the WiFi module is getting hot and not just warm, it has probably failed. What's worrying me is the SD card socket getting hot too. If it only gets hot when there is an SD card inserted, that suggests to me too many volts on the +3.3V rail. If it gets hot regardless of whether an SD card is inserted, then I guess it could just be picking up heat from the WiFi module.



  • @dc42:

    If the WiFi module is getting hot and not just warm, it has probably failed. What's worrying me is the SD card socket getting hot too. If it only gets hot when there is an SD card inserted, that suggests to me too many volts on the +3.3V rail. If it gets hot regardless of whether an SD card is inserted, then I guess it could just be picking up heat from the WiFi module.

    My meter shows 3.1V across the 2nd and 4th pin which should be ground and 3.3 looking at the diagram. I suspect the heat in the SD shield might just be ambient spreading from the wifi, since it's right there. It's definitely not quite as hot.



  • And that's powered by VIN, which the web interface reported at 23.1V while it was working.


  • administrators

    Looks like your Duet needs a new WiFi module. If your Duet is still under warranty then I suggest you make a warranty claim.



  • Yep, it was gotten recently from Filastruder. Will contact them.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.