Jerk/accel settings not working for me



  • @dc42 said in Jerk/accel settings not working for me:

    @deckingman said in Jerk/accel settings not working for me:

    @phaedrux said in Jerk/accel settings not working for me:

    @deckingman I think I have seen this recently when printing some PETG with a higher pressure advance value. Jerky motion on curves leading to vertical banding where the extruder pauses/slows down very briefly on the curve.

    TBH, I've given up trying to use pressure advance. For whatever reason, my Diamond hot end needs high values and whilst pressure advance works really well for straight lines, I've never been able to get smooth curves. Initially it seemed it was just when using multiple extruders (mixing hot end) but later firmware seems to give me problems even when using a single extruder.

    Hi Ian,

    After I am back from Sweden next week, please provide an example single-extrusion GCode file and config.g settings for me to run on my bench system.

    Hi David,

    Yes I can do that but at the end of this very long thread https://forum.duet3d.com/topic/1935/more-strange-pressure-advance-behaviour/60, on 21st Jan you said this

    "Ian, I have just tried slicing my test circles using Cura 3.1 instead of S3D and the extrusion speed consistency is much better, about 1% instead of 8.4%. So until I change the pressure advance code to better handle changes in extrusion rate that shouldn't be there, you might like to try slicing your models with Cura instead of S3D. I think that will fix most of the problem."

    However, Cura and S3D aren't viable options for me because they aren't good for multi (more than 2) coloured objects. I guess I could use one or other but then I'm reduced to using 1 or maybe 2 colours and that's not what my printer is designed for. So, no offence intended, but it's just easier for me to stick with Slic3R and just not use pressure advance.


  • administrators

    I've added a page on known causes of jerky printing on the Troubleshooting section of the wiki, at https://duet3d.dozuki.com/Wiki/Jerky_movement_when_printing.



  • @Ret as already said. You should change your micro stepping to 1/32 at the max. No FFF printer will have any better results going higher. Also, change your steps/mm. If you are using pressure advance turn it off. You really need a good tune on your extruder before you ever mess with pressure advance.

    Your accelerations for movement on axis is high but very low for your extruder. I have a different printer but you might want to try my settings.

    M566 X750 Y750 Z90 E1200 ; Set maximum instantaneous speed changes (mm/min)
    M203 X18000 Y18000 Z6000 E9000 ; Set maximum speeds (mm/min)
    M201 X1800 Y1800 Z250 E10000 ; Set accelerations (mm/s^2)

    With a "Jerk" of 1mm/s on your extruder, you are going to have crazy strange stuff happening especially if you are using pressure advance. I would expect massive pauses on small circle/arcs. I actually complained about PA a while back but it was all in my tuning. I was having what you are but not to your extent.

    You might not want to use my Z settings as I know for a fact you have a completely different setup for your z than I do. You might not try this but honestly, it's probably the few things jamming you up.

    Also, I used to use S3D exclusively. Now I only use Cura 3.2.1+. But that requires a lot more tuning and tweaking of settings. S3D makes a lot of garbage code but it's easy to use and gives very good top layers. Make these changes and if your problems go away then you can start doing more tuning. Maybe give Cura a try. It's given me much better control over my prints and produced astonishing print quality. Best of luck.



  • @dc42, that probably want the best gcode to share that really makes my printer jerk, but if you pay close enough attention, you can see it’s not smooth and swift on round areas. I’m sure that article with be helpful for many people with jerky motions, nice write up. Unfortunately, I’ve tried all of that and might just have to settle with half my normal print speeds when using the duet or permanently stick with my Rambo.
    @Maglin Thank you for your response! As discussed above, I’ve tried from 16, all the way to 256, with and without pressure advance. They don’t seem to make a difference. Currently I’ve settled for 32 on the X/Y, with 64 for both Z and E so I can print down to 10 micron for some items. As people have stated before, “raise the jerk”, and I have but it completely ruins all my corners (unlike previously, with marlin) which isn’t an option. Even using pressure advance and coast settings, its very hard to eliminate those very rounded sharp corners. As I let everyone else know earlier, I’ve increased the E jerk to ridiculously high numbers to see if that had an effect, which it didn’t. Having to use Cura to get decent results seems very funny to me since all other firmware’s I’ve played with have no problem with S3D. Switching strictly to Cura is not an option for me either since I cannot add manual support which is a deal breaker in my line of work. I have used Cura with this board, and it does seem to do better but I simply cannot switch to it until it has that basic feature. I do appreciate your response


  • administrators

    Can you share some pics of the same print done on your Duet and on your Rambo, at the same speed, and with the same settings except increase extruder jerk in RRF? Also compare the print times.



  • @dc42
    Finally had time to do this test. But unfortunately missed the print time. But I did do a study to make sure FW wasn't limiting me someway or another. I wrote a small arduino program on my uno that measured the speed of the hotend to go from one micro-switch to another at a fixed distance. I then did the math to figure out how long in microseconds it should take. They were both very close to perfect. The rambo was more consistent with the time, but the duet was closer to my calculations.

    Printing on the rambo, everything went smooth(except the brim/skirt, s3d issue). Printed on the duetWifi, its very jerky around the rounded portions of the model, same with infill. I know yellow wasn't the best color, but it's what I was currently printing, so I didn't switch it. Even then, you can clearly see the vibration marks on the black, unlike the yellow.
    Here is a link to the images and Gcode. Black is duet, yellow is rambo.
    https://drive.google.com/open?id=1DkNnZv4c34fAN3zWl1TuJxT3eX1P-2Tw



  • @Ret One thing I noticed is that you do not have a M204 Pnnn Tnnn command in your config.g which limits acceleration while printing. I have not checked whether these are included in your sliced GCode files or not.

    All I know is that after converting from Marlin to RRF my printer was shaking like hell when printing short zig-zag infills because I missed to port the settings for limited acceleration while printing and the printer was basically moving at max speed after around 0.25s - which is more or less instantaneously.
    This is not exactly what you describe here but you might at least check if that makes a difference.

    You will find the configured values in Marlin as

    #define DEFAULT_ACCELERATION          400     // X, Y, Z and E acceleration for printing moves
    [...]
    #define DEFAULT_TRAVEL_ACCELERATION   1000    // X, Y, Z acceleration for travel (non printing) moves
    

    The first one would be the value for P and the last one for T. Default values in RRF for both values are 10000 and at least in my config they were much lower as you can see from the snippet I copied.

    As I said, this may not be the cause of your issue but something to try nevertheless.

    P.S.: Don't forget to reset the values for accel/max/jerk also to the values that Marlin uses.



  • Thank you for taking the time to add that. At the beginning of these posts, I had it in the startup script in S3D. Since then, I have moved it into the config file. After all this time, still can't seem to get a semi decent print with the duet. I'm hoping @dc42 will either have a firmware update or someone can come up with a feasible solution.



  • I'll see if I can find a moment to print that gcode file.



  • @phaedrux I'd love to see your results! You really shouldn't have to print more than a half inch to really see any issues(if you have any at all). Thank you!


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.