Bed Leveling problems



  • I can not seem to change the level of thickness the layer prints outs at. It is extremely thin. I can change the the line in G31 for the Z and it does not seem to matter what I change it to.

    ; bed.g
    ; called to perform automatic bed compensation via G32
    ;
    ; generated by RepRapFirmware Configuration Tool on Sun Mar 18 2018 16:24:30 GMT-0400 (Eastern Daylight Time)
    M561 ; clear any bed transform
    ; Probe the bed at 5 points
    G30 P0 X15 Y15 H0 Z-99999
    G30 P1 X15 Y300 H0 Z-99999
    G30 P2 X305 Y300 H0 Z-99999
    G30 P3 X300 Y15 H0 Z-99999
    G30 P4 X160 Y160 H0 Z-99999 S
    
    G29 S-1
    
    
    ; Endstops
    M574 X1 Y2 S0                  ; Set active low endstops
    
    ; Z-Probe
    M574 Z1 S0; Set endstops controlled by probe
    M558 P1 X0 Y0 Z1 I1 H5 F120 T6000          ; Set Z probe type to unmodulated and the dive height + speeds
    G31 P600 X30 Y-15 Z-3; Set Z probe trigger value, offset and trigger height
    M557 X15:305 Y15:305 S20       ; Define mesh grid
    
    

    ; homeall.g
    ; called to home all axes
    ;
    ; generated by RepRapFirmware Configuration Tool on Sun Mar 18 2018 16:24:47 GMT-0400 (Eastern Daylight Time)
    G91 ; relative positioning
    G1 Z5 F6000 S2 ; lift Z relative to current position
    G1 S1 X-325 Y325 F1800 ; move quickly to X and Y axis endstops and stop there (first pass)
    G1 X5 Y-5 F6000 ; go back a few mm
    G1 S1 X-325 Y325 F360 ; move slowly to X and Y axis endstops once more (second pass)
    G90 ; absolute positioning
    G1 X30 Y30 F6000 ; go to first bed probe point and home Z
    G29 S-1
    ;G30; home Z by probing the bed
    ;G1 Z5 F100 S2 ; uncomment this line to lift the nozzle after homing


  • administrators

    Do you have a config-override.g file in /sys, with another G31 command in it?



  • The only other config file is the config.g bak file



  • I can not figure out what is wrong 😕



  • After you home all, bed level, whatever you normally do, move the extruder nozzle to bed middle somewhere and lower it to Z=0 with a sheet of paper between the nozzle and the bed.

    You should find that adjusting your G31 Z value (1) has an effect here and (2) you can get it just right so the paper slides to your satisfaction. Also the tension on the paper should be repeatable after re-homing etc. :-))

    Assuming that is the case and you get the Z=0 set all happy, try the test print again and see how the first layer is? If it is too thin again, confirm the Z height in the GUI ? (baby stepping doesn't seem to change the GUI reading for me)

    You might guess from this post that I'm having a similar issue, but assuming that mine is due to a mount problem with the probe. Interested to see your results.



  • @robm:

    After you home all, bed level, whatever you normally do, move the extruder nozzle to bed middle somewhere and lower it to Z=0 with a sheet of paper between the nozzle and the bed.

    You should find that adjusting your G31 Z value (1) has an effect here and (2) you can get it just right so the paper slides to your satisfaction. Also the tension on the paper should be repeatable after re-homing etc. :-))

    Assuming that is the case and you get the Z=0 set all happy, try the test print again and see how the first layer is? If it is too thin again, confirm the Z height in the GUI ? (baby stepping doesn't seem to change the GUI reading for me)

    You might guess from this post that I'm having a similar issue, but assuming that mine is due to a mount problem with the probe. Interested to see your results.

    Exact [ pretty much ] test I keep doing but … Im not getting the same amount of drag or z height after setting z0 with sheet of paper ... makeing arbitrary moves in x y z and then rehoming .... then a move to center of bed to Z0 yields - non repeatability .10 off or greater. All done after issuing gcode to disable mesh grid compensation.

    Baffled, Babysitting and Babystepping my first layers ...



  • hmmm. Pretty much same here. I have multi-touch enabled (M558 Annn) I think up to 5 tries. 70% of the time stops after 2 tries, sometimes goes 3 or even 4.
    Usually think I have it all configured and repeatable with Z=0 for the sheet of paper, plus bed levelling all nice, then go to print and have to babystep up 0.15-0.30 as it starts etching my bed surface. It seems pretty consistent that the first layer is always too low / too tight when printing rather than when jogging the head around with the GUI.

    My probe is a precision piezo but as noted not happy with the current mount; thinking about going back to the IR sensor but was hoping for something unaffected by the bed surface. There are some other current posts which have this same "have to baby step up randomly 0.30 at the beginning of the print" comment. I have a cartesian printer, 1.21RC5 - yours?

    Do you have lettering or artwork on your bed? That affects the IR probe.



  • Well I ended wiping my config and retrying and I got to adjust finally. Not sure why it was not adjust when I would tell it to before. Now my next problem is a crazy bed mesh reading when running the grid mesh compensation.https://drive.google.com/file/d/18ihHH_7ADmfOu3huW9wljNji0O7GC_6P/view?usp=sharing


  • administrators

    What type of printer is it? Is it a prusa i3 style printer with dual Z leadscrews, one at each end of the X axis; and if so, what is the Z steps/mm @ x16 microstepping?



  • It is tronxy x5s, with dual a corey XY style with dual z leadscrews. steps/mm x32


  • administrators

    It looks to me that your leadscrews have got out of sync. This happens on printers with dual lZ eadscrews, because when you lose power and then restore it, each motors jumps to a nearby multiple of 4 steps that matches the motor current; and the 2 motors may jump in opposite directions.

    For now I suggest you resync the motors manually to level the bed or gantry. When you have your printer running well, you may wish to do this resync automatically, as described at https://duet3d.dozuki.com/Wiki/Bed_levelling_using_multiple_independent_Z_motors.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.