After 19 hours of printing: Printing paused:heater fault



  • This:

    https://e3d-online.com/v6-plated-copper-heater-block
    
    

  • administrators

    Copper has a thermal capacity per unit volume about 50% higher than aluminium, so that explains the 50% higher dead time.

    I suggest you increase the D parameter in the M307 H1 command enough to make the undulations go away. Try increasing it by 20%.



  • I faced similar issue: searched forum, but none of the proposed solution helps.

    as a sudden it gives heater fault. im on 1.21…

    1-a) i replaced heater cartridge and checked all connections, including PT-100.
    all looks fine. Run M303 H1 P1 S230 . No issues… M500 ..

    1-b) after restart and even after power off problems does not disappear.. 😞
    printer does resume with m562 + m916 but minutes later all repeats again…

    2-a) increased tolerance M570 S120 H1 P10 to avoid some peaks.
    2-b) after M562+M916 it starts printing, but in less than a second temperature starts dropping very slowly.
    chart is clean (no spikes, holes etc)

    1. i thought it is a large file… tried to print 101010 cube. same at around 50% completion ....
      replaced SD card, no luck. i think i have tried everything but PT-100 sensor that i do not have in stock...

    what can i do to fix the issue???

    [c]21:30:42 Error: Heating fault on heater 1, temperature rising much more slowly than the expected 0.3°C/sec
    21:30:32 T-1
    21:30:30 M562
    21:29:48 Printing paused
    21:29:46 Error: Heating fault on heater 1, temperature excursion exceeded 15.0°C
    Resume-after-power-fail state saved
    [/c]

    M307 H0 A90.0 C700.0 D10.0 S1.00 V0.0 B1
    M307 H1 A272.9 C189.4 D2.2 S1.00 V12.0 B0
    M307 H2 A340.0 C140.0 D5.5 S1.00 V0.0 B0
    M307 H3 A340.0 C140.0 D5.5 S1.00 V0.0 B0
    M307 H4 A340.0 C140.0 D5.5 S1.00 V0.0 B0
    M307 H5 A340.0 C140.0 D5.5 S1.00 V0.0 B0
    M307 H6 A340.0 C140.0 D5.5 S1.00 V0.0 B0
    M307 H7 A340.0 C140.0 D5.5 S1.00 V0.0 B0


  • administrators

    The "temperature rising more slowly than expected" error normally means the heater has not been tuned. You saved the results to config-override.g with M500, but does config.g have a M501 command at the end to run config.g?

    The "temperature excursion exceeded" error is explained on the wiki page. The error message you pasted says the limit is 15C (the default), which is not what your M570 command indicates.



  • David, can it be something with my board or firmware (fault detection algorithm) ??
    i replaced heat cartridge again... and system was printing fine for a day or two. yesterday as a sudden heater fault again.
    i pulled it from outlet and decided to try next morning... results are very strange... very.

    my steps:

    1. i switched system on and
    2. almost immediately connected via web interface.
    3. almost immediately i faced "temperature excursion exceeded 15.0C"

    in wiki this error residing in "maintaining temperature" section. but in my case it was only heating up for few seconds.

    config.g related
    M563 P0 D0 H1 F0
    G10 P0 S200 R180
    M570 S120 H1 P10 T15
    M305 P1 X200

    @dc42, how that can take place???? how does duet board detect failure???
    is there something i can test on the board?

    0_1523348384794_1.png


  • administrators

    If you got that heating fault message after you reconnected DWC to the Duet after the Duet had already reported a heating fault, then that message is probably a duplicate of an earlier one.

    If you restarted the Duet after that heating fault, then I suspect you have both temperature setting and tool selection commands in config.g. I see that you have G10 P0 S200 R180 in config.g. Do you have a T0 command in config.g as well? If so, do you really mean to heat up the extruder as soon as the printer is turned on?



  • yes, T0 is there.

    and i keep printer off when not printing, and i found it convenient to heat up head immediately.

    by the way, is there similar command to heat up bed?

    i still got the same error after ~30 sec after power on....
    "Error: Heating fault on heater 1, temperature excursion exceeded 15.0°C"

    so what is your verdict over my machine?


  • administrators

    I never expected anyone to put a heating command in config.g so I haven't tested it or thought through the potential complications.



  • i removed G10 from config.g now printer starts without error.

    after print starts .... some time later temperature very slowly goes down.

    could it be some power issues? i have ordered new heaters, but afraid that would not help .


  • administrators

    Yes it could be power issues. Check the VIN voltage display in Due Web Control. Also check that the screws in the terminal blocks that the heaters are connected to and the screws in the VIN terminal block are still tight.



  • what kind of AWG will be suitable for 1m cable and 50W heater?


  • administrators

    Is the heater 12V or 24V?



  • now it is 12v, after upgrade will be 24


  • administrators

    A 12V 50W heater draws about 4.2A and a 24V 50W heater draws 2.1A. There are tables online giving maximum recommended current for different wire gauges.



  • well, my cable is 0.75 sq.mm. that is more than enough for 4 amps and 1 m... will test other cable, but do not think it will help.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.