Dual Z problem with Version 1.21



  • I got a problem with my printer after updating to 1.21.
    i have dual z and after the update its look like one motor is slower then the other.
    its the same if i home or do G1 Z10 S2.
    i cant even downgrad back to 1.20 šŸ˜•
    could someone help me?

    here my config.g

    
    ; Configuration file for Duet WiFi (firmware version 1.17)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Fri Jun 16 2017 18:06:21 GMT+0200 (MitteleuropƤische Sommerzeit)
    M80
    ;M307 H2 A-1 C-1 D-1
    
    ; General preferences
    M111 S0                         ; Debugging off
    G21                             ; Work in millimetres
    G90                             ; Send absolute coordinates...
    M83                             ; ...but relative extruder moves
    M555 P2                         ; Set firmware compatibility to look like Marlin
    M208 X0 Y0 Z0 S1                    ; Set axis minima
    M208 X250 Y250 Z250 S0                     ; Set axis maxima
    
    ; Endstops
    M574 X1 Y1 Z0 S0 ; Define active low and unused microswitches
    
    M558 P5 X0 Y0 Z1 H2 F1000 T6000             ; Set Z probe type to unmodulated, the axes for which it is used and the probe + travel speeds
    G31 X0.0 Y0.0 Z0.9 P600                    ; Set Z probe trigger value, offset and trigger height
    ; Drives
    M569 P0 S1                         ; Drive 0 goes forwards
    M569 P1 S1                         ; Drive 1 goes forwards
    M569 P2 S0                         ; Drive 2 goes forwards
    M569 P3 S1                         ; Drive 3 goes forwards
    M569 P4 S0                        ; Drive 4 goes forwards
    
    ; Motor remapping for dual Z
    M584 X0 Y1 Z2:4
    M671 X-15:260 Y127:127 S5
    
    M350 X64 Y64 Z64:64 E16 I1                 ; Configure microstepping with interpolation
    M92 X320 Y320 Z1600:1600 E418.5                ; Set steps per mm
    M566 X600 Y600 Z16:16 E120                 ; Set maximum instantaneous speed changes (mm/min)
    M203 X7200 Y7200 Z100:100 E1200                 ; Set maximum speeds (mm/min)
    M201 X3200 Y3200 Z50:50 E200                 ; Set accelerations (mm/s^2)
    M906 X1000 Y1000 Z800:800 E900 I30             ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30                         ; Set idle timeout
    
    ; Heaters
    M143 S270                         ; Set maximum heater temperature to 270C
    M301 H0 S1.00 P10 I0.1 D200 T0.4 W180 B30         ; Use PID on bed heater (may require further tuning)
    M305 P0 R4700 T100000 B3950                ; Bed thermistor (P0) is 100K @ room temp
    M305 P1 R4700 T100000 B4388                 ; Set thermistor + ADC parameters for heater 0
    
    ; Tools
    M563 P0 D0 H1                         ; Define tool 0
    G10 P0 X0 Y0 Z0                     ; Set tool 0 axis offsets
    G10 P0 R0 S0                         ; Set initial tool 0 active and standby temperatures to 0C
    
    ; Network
    M550 PPrusa-I3                         ; Set machine name
    M552 S1                         ; Enable network
    M587 S"FRITZ!Box Fon WLAN 7390" P"xxxxxxx"; Configure access point and IP addresses. You can delete this line once connected
    M586 P0 S1                         ; Enable HTTP
    M586 P1 S0                         ; Disable FTP
    M586 P2 S0                         ; Disable Telnet
    
    ; Fans
    ;M106 P1 S1.00 T60 H1 F100
    
    ;M106 P0 S0.3 I0 F500 H-1                 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T70                 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    ;M106 P2 S1 I0 F500 H1                  ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on
    T0
    
    

  • administrators

    To downgrade to 1.20, rename the 1.20 version of DuetWiFiFirmware.bin or DuetEthernetFirmware.bin (as appropriate to your Duet) to Duet2CombinedFirmware.bin, and upload it in the usual way.

    Please downgrade and tell us whether that resolved the problem.

    btw in your M350, M92, M201, M203. M566 and M906 commands you don't need to give the Z value twice, because both drivers automatically use the same values.



  • a downgrade to 1.20 worked and the z axis works perfect šŸ™‚
    thank you


  • administrators

    Thanks. Please describe the exact problem that you were getting with firmware 1.21.



  • the problem after updating to 1.21 was that the 2 z screws didnt move synchron,its looked like the motor on the z connect was half as fast like the motor on e1



  • I would love to upgrade to 1.21 but is this problem solved or was it a configuration problem?



  • I had the same problem on 1.19 check this : - setting > machine properties > drive 2 and 4 and see if they have to same figures.
    For some reason it set drives 2 and 3 identical and set drive 4 to the extruder settings , so to get around it by making the Z motors 2 and 3 .



  • I only see X,Y,Z and E0 no other drives , not as numbers. I have this in my config
    M584 X0 Y1 Z2:4 ;driver 0=x;1=y,2+4=z
    and that works in 1.20



  • AlexLin:
    I'm running the exact same motor/drive/axis combination as you.
    And I'm having no problems with 1.21.


  • administrators

    The problem is that in your M584 command you didn't list the new extruder driver numbers. See the GCodes wiki page.



  • OK got it.Now it worksā€¦....so that should havebeen a problem in 1.20 too?


  • administrators

    Yes it should, so I don't know why you didn't have that problem before.



  • Im having an issue where my dual z motors move at different speeds after an upgrade to 1.21.
    its on a wanhao di3 printer.
    It homes x and y correctly, and was working until i upgraded. also another issue i have is that when a print would complete (back when it worked) the exruder would go in reverse for about 10 mins and i had to hard power it down.. not sure what thats about either. i do i have a duet wifi for my delta as well and no issues.

    ; Configuration file for Duet WiFi (firmware version 1.21)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Mon Aug 20 2018 13:26:19 GMT-0500 (Central Daylight Time)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    ; Network
    M550 Pwanhao-di3 ; Set machine name
    M552 S1 ; Enable network
    M587 S"SAMPLE_a0ebfe" P"" ; Configure access point. You can delete this line once connected
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S0 ; Drive 0 goes backwards
    M569 P1 S0 ; Drive 1 goes backwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M350 X128 Y128 Z128 E16 I0 ; Configure microstepping without interpolation
    M92 X640 Y640 Z3200 E96 ; Set steps per mm
    M566 X54000 Y54000 Z720 E7200 ; Set maximum instantaneous speed changes (mm/min)
    M203 X600000 Y600000 Z420000 E300000 ; Set maximum speeds (mm/min)
    M201 X1000 Y1000 Z100 E5000 ; Set accelerations (mm/s^2)
    M906 X855 Y855 Z855 E855 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X200 Y200 Z180 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 z1 S0 ; Set active low endstops

    ; Z-Probe
    M558 P0 H25 F7200 T6000 ; Disable Z probe but set dive height, probe speed and travel speed
    M557 X25:175 Y25:175 S20 ; Define mesh grid

    ; Heaters
    M305 P0 T100000 B3950 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4388 C0 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S250 ; Set temperature limit for heater 1 to 250C

    ; Fans
    M106 P0 S0.3 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I0 F500 H1 T45 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic power saving
    M911 S10 R11 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; Set voltage thresholds and actions to run on power loss

    ; Custom settings are not configured

    ; Miscellaneous
    M501 ; Load saved parameters from non-volatile memory
    T0 ; Select first tool



  • @good1228 said in Dual Z problem with Version 1.21:
    Quote...............
    also another issue i have is that when a print would complete (back when it worked) the exruder would go in reverse for about 10 mins and i had to hard power it down.. not sure what thats about either.
    ..........end of quote

    The usual cause of that is the slicer end code retracting the extruder by a relative amount, (say 3mm), but the Duet board has been given a M82 command so it thinks that is an absolute value. That is to say, rather than retracting by 3mm in this example, it retracts all the filament up to 3mm after the extruder was last set to zero (which usually happens at the beginning of a print). So basically it tries to retract all the filament that was used in the print apart from the last 3mm (in this example).


  • administrators

    @good1228 said in Dual Z problem with Version 1.21:

    Im having an issue where my dual z motors move at different speeds after an upgrade to 1.21.
    its on a wanhao di3 printer.
    It homes x and y correctly, and was working until i upgraded.

    I don't see any M584 command in your config.g, so I presume that you have the Z motors connected to the Za and Zb motor connectors. Is that the case? If so then your Z axis is probably binding, perhaps because the two motors have got out of sync, or because the motor current is too low.

    also another issue i have is that when a print would complete (back when it worked) the exruder would go in reverse for about 10 mins and i had to hard power it down.. not sure what thats about either. i do i have a duet wifi for my delta as well and no issues.

    See @deckingman's response. You need to add either M83 or G92 E0 before the G1 E-nnn command in your slicer end gcode (or in stop.g if that is where you have it).


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.