BL Touch Configuration



  • I recently purchased a Duet Wifi, and cant seem to get the bltouch working. Ive followed the guide on the wiki for setup without the Duex. When I power up the printer the BLtouch completes its self test, however when sending commands to it thru the console it doesn't respond. Below is my config.g file. Any help would be greatly appreciated as I am fairly new to this. Thanks in advance.

    [c]
    ; Configuration file for Duet WiFi (firmware version 1.20 or newer)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Wed Mar 07 2018 17:20:05 GMT-0500 (Eastern Standard Time)

    ; General preferences
    G90 ; Send absolute coordinates…
    M83 ; ...but relative extruder moves

    ; Network
    M550 PMy printer ; Set machine name
    M552 S1 ; Enable network
    ;*** Access point is configured manually via M587
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S0 ; Drive 2 goes backwards
    M569 P3 S1 ; Drive 3 goes forwards
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X80 Y80 Z1600 E94.4962144 ; Set steps per mm
    M566 X900 Y900 Z12 E120 ; Set maximum instantaneous speed changes (mm/min)
    M203 X6000 Y6000 Z300 E1200 ; Set maximum speeds (mm/min)
    M201 X500 Y20 Z250 E250 ; Set accelerations (mm/s^2)
    M906 X800 Y800 Z800 E800 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X200 Y270 Z170 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 S0 ; Set active low endstops
    M558 P0 H10 F120 T6000 ; Disable Z probe but set dive height, probe speed and travel speed
    M557 X15:185 Y15:255 S20 ; Define mesh grid
    M574 X1 Y1 S0 ; X home to min. Y home to max. Normally Opened limit switches.
    M574 Z1 S2 ; Define Z to use Probe. Home to Min
    M307 H3 A-1 C-1 D-1 ;
    M558 P5 X0 Y0 Z1 H5 F100 T2000
    G31 X1 Y1 Z1 P25

    ; Heaters
    M301 H0 S1.00 P10 I0.1 D200 T0.4 W180 B30 ; Use PID on bed heater (may require further tuning)
    M305 P0 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C

    ; Fans
    M106 P0 S1 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I0 F500 H T45 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic power saving
    M911 S10 R11 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; Set voltage thresholds and actions to run on power loss

    ; Custom settings are not configured

    ; Miscellaneous
    M501 ; Load saved parameters from non-volatile memory
    T0 ; Select first tool

    [/c]



  • You can probably delete this line

    M558 P0 H10 F120 T6000 ; Disable Z probe but set dive height, probe speed and travel speed

    That one came from the configurator and gets replaced a couple lines down by…

    M558 P5 X0 Y0 Z1 H5 F100 T2000

    Which you can change the P5 probe type to be P9 which is specifically for BLTouch in firmware 1.21

    Check your config-override.g for a conflicting M307 heater config that is over writing your heater pin unbinding.

    This guide will prove very helpful.

    https://betrue3d.dk/bltouch-on-duet-wifi-configuratio-and-usage/



  • Thanks for the quick reply. I deleted the first M558 P0 H10 F120 T6000 and changed the probe type to P9. The BLtouch still wont respond. Also, I dont seem to have a config-override.g file. Ive actually tried both the wiki guide as well as the one you just linked.


  • administrators

    1. Which firmware version? Look in the Settings General tab of DWC to find out, or send M115.

    2. How have you wired your bltouch to the Duet?

    3. What do you have in your deployprobe.g and retractprobe.g files?



  • Does it light up at all? If it's flashing it is in alarm and needs to be released before it will accept a command. Sometimes mine will be in alarm right on power up because I think my pin is sticking.

    Can you hear it make a small buzz sound if you send it a command?

    What commands are you using the deploy and retract?

    Have you verified that you are connected to the right pins? The wiki describes connecting it to heater pin 3 and that guide uses heater pin 7. which one are you actually using?



  • Firmware version 1.21

    The bltouch is wired to Heater3 as per the wiki guide.

    Deploy: M280 P3 S10 I1

    Retract: M280 P3 S90 I1

    The BLtouch does its self test and the light goes solid red when printer is first powered on, but wont respond to an M280 P3 S10 I1 command thru the console, nor will it deploy when trying to home.



  • Can you hear it make a small buzz sound if you send it a command?

    Try adding i1 to your the M558 command in config.g to invert the signal. Then try to deploy and retract.


  • administrators

    Have you used M307 H3 A-1 C-1 D-1 to make heater 3 pin available for use? Run M307 H3 by itself to check, it should respond that heater 3 is disabled.



  • Tried adding the I1 to the M558, still nothing. The bltouch doesnt make any sounds.

    Running M307 H3 returns "Heater 3 is disabled"


  • administrators

    Probably a wiring issue then.



  • I've checked the wiring multiple times and even tried a buddies known working bltouch.



  • You could try heater pin 7 instead of 3. See if that makes a difference for you.


  • administrators

    Can you confirm that you are running with VIN power applied and the internal 5V regulator is enabled?



  • The jumper is on the internal 5v pins, and Vin LED illuminated.


  • administrators

    Can you post a photo showing how the bltouch is connected to the Duet?



  • Heres a closeup of the wiring. https://ibb.co/e1hqkS


  • administrators

    The wiring looks OK to me and I didn't spot anything wrong with the commands you are using. The +5V and ground connections must be more or less OK if the bltouch self test works and the red light comes on. So it's either a problem with the orange control wire, or with the heater 3 output on the Duet. When you tried your friend's bltouch, did you use his cable too?



  • Sorry its taken me so long to reply, Ive been quite busy and haven't had much time for the printer. The BL touch is now working. I tried a new wire and sure enough, that was it. Thank you for all the help, its been greatly appreciated.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.