Do home in Z max, help! Doubt in config



  • Hello everybody,
    in one of my machines i have the sensor (normal swith NO) in Z max and really i don't know like configure this.
    Duet Ethernet 1.21 firmware

    I test this config:

    [[language]]
    ; Endstops
    M574 X1 Y1 Z2 S0               ; Set active low endstops
    
    ; Z-Probe
    M558 P0 H5 F120 T6000          ; Set Z probe type to switch and the dive height + speeds
    G31 P600 X0 Y0 Z2.5            ; Set Z probe trigger value, offset and trigger height
    
    

    Now when i press Home Z, the axis search the swith (move in Z+) and stop well when find the swith, but when i press Z- 100mm(for move to the nozzle) only move a little and no more!

    The switch is connected to connect Z Stop connector, perhaps i must connect in Z probe?
    I want remark than in the machine everything work perfectly, the unique thing than still not work is this. But the axis move well.

    Thanks!



  • When you home to max your setting G92 to max z height and not zero correct?



  • Yes the DWC show 0, the home Z do well, but after only move some mm in Z-



  • Do you have Z plus and Z minus mixed up by chance? Z zero (homed) is nozzle near the bed, a +100mm move will create a 100mm gap from nozzle to the bed. So if DWC shows 0 then it should not move in the Z- this is to prevent damage to the nozzle or bed.

    If you really are using Zmax to home your Zhome (or homeall) code needs to set G92 to the max height of your Z and not Zero as is normally done.

    So G92 Z300 for a 300 max z printer.

    Or perhaps i'm missing your point?


  • administrators

    You do not need to use G92 with a Z max homing switch. But you do need to set the M208 Z parameter correctly.



  • Sorry i am confused.
    My M208 is correctly configured, i suppose:

    [[language]]
    M208 X0 Y0 Z0 S1               ; Set axis minima
    M208 X300 Y300 Z400 S0         ; Set axis maxima
    
    

    Could you explain me?


  • administrators

    Where you have Z400 use the exact Z height at which your Z max endstop triggers.



  • Yes i have like this, but when i press Home Z, the axis search the swith (move in Z+) and stop well when find the swith, but when i press Z- 100mm(for move to the nozzle) only move a little and no more!



  • Are your leadscrews binding?



  • Oh sorry, i don't understand "leadscrews binding"? Could you explain me?


  • administrators

    Please post your config.g, homeall.g and homez.g files.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.