Dual Z constantly out of sync

  • I have my dual z split into using two drivers. I don't remember why I did that but it might have been to quiet them. It was too long ago to remember.

    After every print, I find the Z is slightly out of sync. I have an IR probe and while it gets me to a consistent height at start, the leveling has never worked right on this printer, so I just disable steppers and manually rotate each z rod until it's in sync. It's much better to eyeball this.

    Obviously, this is not an acceptable solution. The IR probe should consistently level the bed better than I can by hand and there should not be any reason for the dual Z to go out of sync so frequently.

    Please help me correct this.

  • Are the screws dead centre and are you probing dead centre? You can't level a bed using only 2 points. 2 points define a line but it takes 3 points to define a plane. I guess if you probed dead in line with the Z screws and those screws are dead centre, then it might level the bed along the line between those two points. Assuming the screws were centre left and centre right, then the bed might be level from left to right along that centre line but who knows where it will be from front to back? So basically, to level the bed using firmware and a probe, you need 3 screws each driven by their own motor. Alternatively, if you use 3 screws then you can drive them with a single motor and a continuous belt. Combined with a flat bed plate, that negates the need to level it at all (after initially setting it).

  • administrators

    It's common for dual Z motors to go out of sync when they are powered off. So avoid powering them off between prints.

    As you have independent motors driving them, you can use the Z probe to do true bed levelling after you power the printer on and home it. See https://duet3d.dozuki.com/Wiki/Bed_levelling_using_multiple_independent_Z_motors.

  • I did that.. It work but you need to run it at least 2, and even better 3 times to get it level… Even with the Motors in Series.. My bed tilted a bit on power off

  • administrators

    If you find it under corrects, use the M671 F parameter to tell the firmware to increase the amount of correction.

  • I have a robo3d R1+. It's a mendel type machine. Does that help explain this any? Mesh leveling is absolute crap for me.


Looks like your connection to Duet3D was lost, please wait while we try to reconnect.