Did I fry my bltouch?



  • I think I fried my Bltouch. After rebuilding parts of my printer I accidentally wired it wrong. In the process I also updated to the latest firmware and set probe type to 9.

    The bltouch still deploys and retracts, it also does the self test upon startup. But the sensor value remains 0 when I touch the pin and trigger a retract.

    Is there anything I can do to check if I fried it, or maybe is it just a wrong setting?



  • The trigger time for the BLTouch is really short so it's hard to see on the probe display. I think you're alright if it's still deploying and triggering on the self test. Have you tried manually triggering it with your finger during a home?



  • I did try manually and it didn't work. The probe retracted, but the bed didn't stop homing. After that I tried several settings and only looked at the sensor value. Maybe I should try manually again.



  • Can you post your relevant config entries as well? M558, G31, deploy and retract macros.



  • Just tried manually triggering the probe while homing, but it still doesn't cause the bed to stop homing.
    Also when I use this command: M280 P3 S120 I1, it keeps deploying and retracting. It doesn't stop.

    My config:

    ; Endstops
    M574 X1 Y1 S1 ; Set active high endstops
    M574 Z1 S2 ; Set endstops controlled by probe
    M307 H3 A-1 C-1 D-1 ; bltouch
    M558 P9 X0 Y0 Z1 H5 F1000 T2000 A10 R0.5 S0.008 ; bltouch
    G31 X-25 Y20 Z2.8 P25 ; bltouch offset
    M557 X15:265 Y25:275 S20 ; Define mesh grid

    deployprobe.g (in sys folder):
    M280 P3 S10 I1

    retractprobe.g (in sys folder):
    M280 P3 S90 I1



  • Anyone? Specially this bit: Also when I use this command: M280 P3 S120 I1, it keeps deploying and retracting. It doesn't stop.



  • @bartolomeus M280 P3 S120 I1 is the selt test. It causes the probe to deploy and retract repeatedly until you either trigger it by touching the pin to verify that it triggers, or send it M280 P3 S160 I1 to release the alarm and retract the pin.

    Can you verify your wiring? It sounds like it's connected properly to the servo and power pins, but possibly not to the probe input. If it is wired correctly, I'm not sure how to verify if your board was damaged or not.



  • I double checked the wiring a few times. I've had it working before. I also replaced the wires to rule that out. The signal wire is in pin 8 on the expansion header. I'm afraid I did fry the bltouch after all...



  • How did you have it wired incorrectly in the first place?

    It still lights up and takes commands properly, it just doesn't trigger properly?

    So when you do the self-test and you touch the pin, does it stop, or just keeps deploying and retracting?



  • @phaedrux ohohoh, wait thanks to your reply I looked again at my wiring. There's one thing I might have screwed up. Gonna try again in 20 mins.



  • @phaedrux Succes! I did have it wired wrong. I had the extension cable going to the z probe port on the duet wired wrong. Working now. Thanks!



  • Glad you got it working.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.