Mesh Grid Offset?



  • ZeroedByte 8 Apr 2018, 15:37
    I'm trying to get the auto bed leveling figured out on my delta.
    My inductive sensor sits 40mm on the +y axis.
    The issue I'm running into is, when I set my radius to like 70, it only probes half the bed.
    The whole -y side on zero doesn't seem to get probed.
    I changed the G31 offset in config.g, and that's the only place I've run a G31.
    What am I missing? 😞


  • administrators

    Please post your config.g file.



  • ; Configuration file for Duet WiFi (firmware version 1.17 to 1.19)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Fri Apr 06 2018 17:56:30 GMT-0600 (Mountain Daylight Time)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves
    M555 P5 ; Set firmware compatibility to look like Repetier
    M665 R138 L346.06 B60 H190.65 ; Set delta radius, diagonal rod length, printable radius and homed height
    M666 X0 Y0 Z0 ; Put your endstop adjustments here, or let auto calibration find them

    ; Network
    M550 PSeth's Delta ; Set machine name
    M552 S1 ; Enable network
    M587 S"Gandy Network" P"kittenrules" ; Configure access point. You can delete this line once connected
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X200 Y200 Z200 E895 ; Set steps per mm
    M566 X1200 Y1200 Z1200 E1200 ; Set maximum instantaneous speed changes (mm/min)
    M203 X18000 Y18000 Z18000 E1200 ; Set maximum speeds (mm/min)
    M201 X1000 Y1000 Z1000 E1000 ; Set accelerations (mm/s^2)
    M906 X1000 Y1000 Z1000 E800 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 Z0 S1 ; Set minimum Z

    ; Endstops
    M574 X2 Y2 Z2 S1 ; Set active high endstops

    ; Z-Probe
    M558 P1 I1 X0 Y0 Z0 H5 F1400 T6000 ; Set Z probe type to unmodulated, the axes for which it is used and the dive height + speeds
    G31 P500 X0 Y40 Z0.608 ; Set Z probe trigger value, offset and trigger height
    M557 R70 S20 ; Define mesh grid

    ; Heaters
    M305 P0 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S100 ; Set temperature limit for heater 0 to 100C
    M305 P1 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C

    ; Fans
    M106 P0 S0 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I0 F500 H1 T45 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Custom settings are not configured*

    I was also confused as to how to calibrate the endstop offset, I came from Repetier and the G132 offset tools.


  • administrators

    To put the nozzle at X0 Y-20 would require the nozzle to be at X0 Y-60 so it should at least probe that point. To probe X-20 Y-20 would put the nozzle at X-20 Y-60 which is 62.4mm from bed centre, so that should be probed too, same for X20 Y-20. But all the other points on that half of of the bed will be omitted because probing them isn't possible while keeping the nozzle within the bed radius.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.