External power relay board, 5v & signal??



  • Hi Guys,
    I'm overhauling a large 1m printer, added Duet, and am getting up to speed, however, I have 1 issue that have no idea how to resolve - the printer was previously turned on and off by a press button (LED ring) switch, that is connected to a small relay board that controls the mains 220v - press the button, power gets to the mainboard and 5v from the mainboard goes to this relay board; that then returns via a signal cable to the mainboard, and the machine stays on - press again and the machine turns off...
    I have found where to connect 5v and ground (Expansion Breakout Board) TO the relay, so now when pressing the button the machine stays on, but do not know where to connect the SIGNAL back to the Duet.. the machine cannot be turned off 😞

    I attach varios photos, maybe someone has seen this setup before and can help me get it working!
    ![0_1523286221299_IMG_4628.jpg](Uploading 100%)
    ![0_1523286259575_IMG_4632.jpg](Uploading 100%)
    On the old board, the top left red square is the signal, the mid-right red square is the LED_5V output...
    On the power relay, at the bottom is the push switch 3-wire connection, left is 220v in and out, and right are the SIGNAL and 5V in.

    Any help appreciated!

    Thanks!
    Andy
    🙂


  • administrators

    @andymidtf can you try uploading the pictures again,max size is 2048kb cheers!



  • @t3p3tony trying that now...



  • 0_1523286752417_IMG_4632.jpg



  • 0_1523286834510_IMG_4628.jpg



  • @andymidtf SIGNAL is actually only 2 wires connected, left and middle


  • administrators

    If the push button is connected to the relay board, what provides the initial 5V to turn the relay on? Or does the push button bypass the relay contacts and feed mains to the PSU?



  • @dc42 Push button relay board controls mains voltage (left side of relay board, 220v in and out) to PSU, that then powers main board - main board outputs 5v (LED_5v) back to input 5v to relay board, and so relay board maintains mains out...

    then there is the SIGNAL output from relay board, that inputs on mainboard (signal) - with original main board I must assume that this signal was what then cut 5v back to the relay, as pressing the button when the machine is powered on then turns off the machine, but...

    now I have permanent 5v coming from heater6 on expansion breakout board connected, so when pressing button the duet stays on (without this connected, the power does not stay on), but I do not know how to connect the signal back again so that the power turns off when pressed again - I was thinking of trying to connect this signal out from relay board to ATX 5v in on duet (with appropriate jumper placed), but the signal out does not seem to give any voltage at all 🤔


  • administrators

    If your relay board has an optically isolated control input, connect that control input between +5V from the expansion connector and PS_ON. Put M80 at the start of your config.g file to turn the relay on when the board starts up.



  • @dc42 Hi David,
    I'm not sure if that is exactly what it is, I don't have enough knowledge to say!

    From what I can gather, you mean that it is possible that the previous board OUTPUT a signal from the SIGNAL connector, to the relay board SIGNAL connection...? And that connecting 1 wire from 5v on the expansion breakout board, and the other (gnd? -ve) from PS_ON, both will go to the SIGNAL connector on the relay board...? I may not need another pair to 5v-in then, as did the original board?

    On another note, but can't find a way to send you a message from your PanelDue blog, I have just tried updating the FW on the 5" PanelDue v3.0a I bought; I didn't realise immediately that I couldn't use the same version as I'd previously used for my older Duet 0.8.5, and after pressing erase then reset, now I get an error "SAM-BA operation failed", and the screen is obviously dead still... any way of rescuing this now?

    Thanks!
    Andy
    🙂


  • administrators

    Disconnect the Panel Due from the Duet, then connect it to your PC via USB. If your PC runs Windows then is should show up under Ports as Bossa Port. If not, try another USB port on your PC. After that, you should be able to program it using Bossa.

    Alternatively, upgrade your Duet to 1.20 or 1.21 firmware.



  • @dc42 Panel Due was actually about to be installed, I was trying to upgrade FW before installing... I use Mac... I previously had an earlier version de bossac in a folder that I had successfully used to update my Duet 0.6 and 0.85... I tried to use it 1st and it did not respond - then I saw the instructions about bossac1.8, downloaded for Mac, was only able to install the Bossa.app, am unable to copy bossac and bossash to /usr/bin, MacOS Sierra does not let me... then tried using the Bossa.app to update, and still got similar error...

    Duet is 1.21 now... what do you mean by this? That the 1.21 FW will detect the Panel and auto-magically resolve the issue? That would be fantastic! I am at work now, will be going to the printer in a few hours, and will try this as soon as I get there!
    Or I have to do something else as well?

    Sorry for so many questions, my head is a cloud at the moment, my best friend died monday, and it seems everything I've touched since I found out I have broken 😞

    Thanks
    Andy
    🙂


  • administrators

    I'm sorry to hear about your friend.

    I misread your email, I thought you were trying to downgrade PanelDue firmware to communicate with a Duet 0.8.5 running older firmware.

    What happens if you load Bossa on your Mac and press the auto-scan button - does it find the connected PanelDue?



  • I had the same Problems trying ti install Bossa on my Mac and had to find a Windows Machine to do it so if Someone knows how to get a Mac to allow you to drag the necessary files to /usr/bin I would like to know as well.



  • @dc42 Hi David,

    Yeah, I'm not too clear with explanations, my family also complains of that 🤦
    This is a new DuetEthernet... and new PanelDue... the app finds the board OK, but still gives error - there is no auto-scan, there is a refresh button, then the serial port appears:0_1523452188100_Screen Shot 2018-04-11 at 14.06.04.png
    can see the board connected at the bottom of the window
    but still gives an error when I press "write"
    0_1523452213994_Screen Shot 2018-04-11 at 14.06.13.png



  • @dc42 just realised I had to mark the 3 boxes, "erase all", "lock", and "boot to flash", but either still gives same error, or just closes the app without warning.

    @Dougal1957 found out what was up with the /usr/bin, looks like it is System Integrity Protection, can be disabled (you should reenable!) going to RecoveryHD (CMD-R at startup), and then opening terminal and writing "csrutil disable" ("enable"), you can then copy what you want to the protected system folders.

    @dc42 said that, from terminal "bossac -e -w -v -b /Users/andy/Downloads/PanelDue-v3-5.0.bin" still gives "SAM-BA operation failed" 😞 adding the -p /dev/cu.usbmodem1411 flag just gives a "0 bytes to flash"...


  • administrators

    Have you tried pressing Erase and Reset on the PanelDue again, with USB power connected, to make sure that the chip is fully erased?

    Have you checked the file size of the .bin file that you are trying to flash?



  • @dc42 Hi David, about relay board... connected +5v from expansion connector, and PS_ON from, well, PS_ON (!), to the 5v_in on the relay, +ve and -ve...

    works great for turning on via power button, and turning off via software - I don't really see any way of this working to power on AND off via the power button..? Not a great issue now, as can power off from screen (now that it works!) and from webpage 😉

    thanks!
    Andy
    🙂



  • @dc42 yes, I have tried several times pressing Erase (at least 1 second) and Reset on the PanelDue again, with USB connected...

    OPPS!! F***! how did that happen!?! file size is 0!! 🤦 🤦
    Success! with PanelDue-v3-5.0 FW loaded!

    I will just add that, as I can't stop from messing, I then tried PanelDue-v3-5.0-nologo, and THE ISSUE CAME BACK! Even when tried again with PanelDue-v3-5.0!! However, after closing the app, disconnecting the PanelDue, and reconnecting again, I have again managed to load the PanelDue-v3-5.0-nologo FW (sorry David, the logo took ages to disappear! Maybe with a shorter display time I'd have left it! 😀 )

    And a quick PD about the new forum UI, about the Emoji menu, heres a screen shot of how it comes up for me - is a bit difficult to close, have to use top right corner of the close button as when I hover the mouse over there, the last Emoji tab highlights and blocks the lower half off... not sure if this is Chrome for MacOS issue, or everyone will see it like this? Again, is not an issue, but I imagine the forum UI devs would like to know about it! 😉
    0_1523461481512_Screen Shot 2018-04-11 at 16.42.53.png 0_1523461488002_Screen Shot 2018-04-11 at 16.43.02.png

    Thanks a million David!
    Andy
    🙂


  • administrators

    I'm glad you got it programmed. Re the emojis, I suggest you mention that in the "New forum" thread because Tony might not see it here.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.