Probing speed changes with no reason



  • So I am having a weird issue here. I have a precision piezo to act as a z-probe/endstop on my corexy. It works fairly well with the following exception: sometimes the z speed on probing will randomly slow down.

    I have this:

    ; Endstops
    M574 X1 Y2 Z0 S0 ; Define active low and unused microswitches
    
    ; Piezo
    M558 P1 I0 R0.4 F420 X0 Y0 Z1
    G31 X0 Y0 Z-0.360 P600
    

    Firmware is latest (1.21) and it's a duet wifi+duex2.

    And I have like 5 points defined on bed.g for 3 lead screw bed leveling. The thing is, sometimes one of the probe points will just be REALLY slow. Like less than half the speed of the other ones (that is set to 420 on G31 above).
    I think there must be something to be related to jerk or changing speeds too fast, but I am unsure how to solve that. Maybe lower the travel time between the points so it has more time to 'recover'?

    Thanks for any help.

    Also I am pretty sure that I should change my M558 because apparently it changed on 1.20.



  • Does it have that "slow down as it approaching the bed" thing causing the issue? I thought that setting was only for induction or IR sensors.

    maybe something in here? https://duet3d.dozuki.com/Wiki/Connecting_a_Z_probe#Section_Mode_Num_1


  • administrators

    The slow down is intentional for sensors that provide an analogue output that increases as it gets nearer the bed. It allows you to use a higher initial probing speed. But I'm not sure that the piezo sensor is intended to be used in analog mode.



  • @dc42 said in Probing speed changes with no reason:

    The slow down is intentional for sensors that provide an analogue output that increases as it gets nearer the bed. It allows you to use a higher initial probing speed. But I'm not sure that the piezo sensor is intended to be used in analog mode.

    Well it only happens on one of the points, that's what I think it's weird.
    And I was following @DjDemonD post here.

    EDIT: just noticed this was added after I configured it the first time:

    Please note as of RRF version 1.20 you can use M558 P8 instead (other parameters are the same) which is a digital probe but without filtering or smoothing of the signal. This increases accuracy, as it takes less time to react to a trigger.

    I will try that when I finish this 5h print...



  • You can use it in analogue mode, but I personally find it works best on M558 P8 (unfiltered digital mode). No slow down should occur.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.