New build, no movement



  • Just got my new printer finished and all is wired up but when I go to move an axis I am getting this in the console.

    12:30:07 AMM120
    G91
    G1 X-1 F6000
    M121
    Error: G0/G1: insufficient axes homed
    Error: Pop(): stack underflow!

    The new printer is a CoreXY style printer and the board came out of a previous Cartesian printer that I was using, so while doing my wiring I was testing with the existing firmware and settings to make sure everything was working. Once all was finished I decided to update from 1.17 to the latest and in the process wiped my SD card. I put everything back on it and got the wifi back up and running but now I cannot get any of the motors to move. Everything is updated, firmware, web control and wifi server to 1.21. I used the RRF configuration tool to create my config files so I may have gotten something wrong?


    ; Configuration file for Duet WiFi (firmware version 1.20 or newer)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Fri Apr 06 2018 21:41:07 GMT-0400 (Eastern Daylight Time)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    M667 S1 ; Select CoreXY mode

    ; Network
    M550 PBOXX ; Set machine name
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet
    M552 S1 ;Enable WiFi

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M569 P4 S1 ; Drive 4 goes forwards
    M584 X0 Y1 Z2 E5:6 ; Apply custom drive mapping
    M350 X32 Y32 Z16 E16:16 I1 ; Configure microstepping with interpolation
    M92 X160 Y160 Z3200 E420:420 ; Set steps per mm
    M566 X900 Y900 Z12 E120:120 ; Set maximum instantaneous speed changes (mm/min)
    M203 X30000 Y30000 Z400 E2000:2000 ; Set maximum speeds (mm/min)
    M201 X800 Y800 Z200 E300:300 ; Set accelerations (mm/s^2)
    M906 X1100 Y1100 Z1000 E1000:1000 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X350 Y350 Z350 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y2 S1 ; X home to min. Y home to max. Normally Closed limit
    M574 Z1 S2 ; Define Z to use Probe. Home to Min

    ; Z-Probe
    ; BLTouch - Heaters
    M558 P5 H5 F500 T4000 X0 Y0 Z1 ; Set Z probe type/mode 5. H=Dive Height. F=Speed the bed moves
    G31 P25 X34 Y0 Z0.0 ; Z probe trigger value, offset in relation to nozzle. And trigger height adjustment
    M307 H7 A-1 C-1 D-1 ; Disable the 7th Heater to free up PWM channel 5 on the Duex board.
    M557 X15:335 Y15:335 S20 ; Define mesh grid



  • Just add this line to the end of your config.g:

    M564 H0 ; Allow movement of axes before homing



  • @whosrdaddy said in New build, no movement:

    M564 H0 ; Allow movement of axes before homing

    I will add that and see what happens. Thanks


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.