Print stops after 15 Layers



  • Hello there,

    i've got a Problem with my Printer and it looks like it stops after printing 15 Layers. (Adalinda thing:246198)
    I sliced anything like usual with normal Settings and with Simplify 3D but after a second try at the same g-code it stops there
    and i cann't pause or stop the Print.
    The only way to get the control back is to use the Emergency Stop bottom and home X (lift Z before) remove as fast as i can the 15 Layers of Fail and home all after that.

    I realy don't know what type of Problem this is?
    Duet Firmware Problem or Simplify 3D.

    I hope someone can help me with that.


  • administrators

    Please provide a link to the gcode file.




  • administrators

    What M350 microstepping settings are you using, and what are the X and Y steps/mm? If you provide your config.g file then i can run it on my bench system.



  • Here it is: https://pastebin.com/MiekVJ49

    I use:
    Firmware Electronics: Duet WiFi 1.0 or 1.01
    Firmware Version: 1.21 (2018-03-21)
    WiFi Server Version: 1.21
    Web Interface Version: 1.21

    Btw. cool Interview with Tom. 👍 ☺


  • administrators

    Thanks. There is a known bug in firmware 1.21 and 2.0beta that if you use very high microstepping so that the rate of step pulse generation can't keep up, the movement code may lock up on certain sequences of GCode. As you are using x256 microstepping, I think that it what is happening.



  • So the only way to get it working is to wait for a fix or use 128 microstepping? (or maybe increase the model by a few procent?)


  • administrators

    Most users find the default x16 microstepping with interpolation to x256 gives good results. Native x256 microstepping typically makes it impossible for the firmware to generate step pulses fast enough for fast travel moves. So even when this bug is fixed (which should be soon - the first report of it was only about two weeks ago, so I haven't had time to track it down yet), if you use x256 microstepping then you won't get the maximum travel speed.



  • @dc42 i don't need speeds like 100 mm/s i need just exact moves that give me awesome print Results.
    For that i even take 40 mm/s as long the quality is on point. 🙂

    What was the default Setting with interpolation?


  • administrators

    @as-3d-druck said in Print stops after 15 Layers:

    @dc42 i don't need speeds like 100 mm/s i need just exact moves that give me awesome print Results.
    For that i even take 40 mm/s as long the quality is on point. 🙂

    What was the default Setting with interpolation?

    The default setting is x16 microstepping with interpolation to x256. It is unlikely that your mechanics will be able to place the print head to better than one 1/16 microstep. However, if you want to continue using x256 native microstepping then you probably only need to reduce the travel speeds, which you can do in the M203 command in config.g.



  • Thx i will try that. ☺ 👍


Log in to reply