BlTouch issue.... (One more....)



  • I am having problems with the Z-probe that I am using, at the moment a BlTouch sensor.

    Until yesterday it worked, following the instructions in [https://betrue3d.dk], correctly. But since yesterday it does not work correctly, I want to think that it will be a problem in the wiring, but I do not know where to put it in ....

    I explain ...

    1- When I turn on the printer, the sensor performs the initial test, extends and collects.
    2- After the initial test, the sensor stays collected, with the light on
    3- When I send the macros, which I have configured, to extend, collect, and test. THEY DO NOT WORK. The macros that I have used so far, and that have worked for me are:

    3.1.- Extend: M280 P3 S10 I1
    3.2.- Regoger: M280 P3 S90 I1
    3.3.- Test: M280 P3 S120 I1
    3.4.- Reset: M280 P3 S160 I1

    I think it goes without saying that if I try to calibrate the BlTouch, it does not deploy ...

    I have checked with a multimeter, the continuity of the cables that go from the BlTouch to the Duet board

    If the sensor does the initial test correctly:

    A- Where is the problem, if it is in the wiring?
    B- On the two cables that connect it with the Z-Probe Socket?
    C- Any kind of test I can do to discard things?
    D- At the moment, I have the BlTouch connected in Heater3. What do you recommend?

    Thank you

    I have this lines in config.g...

    ;BlTouch

    M307 H3 A-1 C-1 D-1 ; Disable the 3th Heater to free up PWM channel 3 on the Duex board
    M558 P9 X0 Y0 Z1 H5 F100 T2000 A4 R0.5 ;M558 P9 H5 F500 T4000 X0 Y0 Z1 ; Set Z probe type/mode 9. H=Dive Height. F=Speed the bed moves



  • Are you sure you have it connected to the third heater pin? In betrue3d.dk they have it connected to another pin (heater 7).


  • administrators

    Here are some possibilities:

    1. Servo (orange) wire of the bltouch not connected to the correct pin on the Duet, or a bad crimp connection in that cable. See https://duet3d.dozuki.com/Wiki/Connecting_a_Z_probe#Section_BLTouch for how it should be connected.

    2. Heater 3 hasn't been disabled. Send M307 H3 and it should report "Heater 3 is disabled".

    3. Faulty bltouch.

    4. Faulty Duet heater 3 output.

    5. Using P9 in the M558 command, but you are using firmware earlier than 1.21 so type 9 is not supported. Send M558 and check that is reports type 9.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.