Corexy 3 lead screws problem with height



  • Hello I have a problem with my corexy printer I am using 3 lead screw 2 screws in parallel connected to the Z and 1 screw connected to the extruder, the spindles move up and down without problem, what happens when I do z homing each screw is at a height different, is there any way to solve this problem?

    I am using the duetwifi plate

    1_1524592032091_IMG_20180424_193936.jpg 0_1524592032091_IMG_20180424_193927.jpg



  • I'm not exactly sure what the problem is.

    Are they starting level?
    Can you manually turn them when the power is off so that they are level?
    Are they going out of sync after being used?
    Are you using auto bed leveling?



  • Hello when it is off if I can move them to level them, but every time I go up and under the bed each one is always at a different height, I am not using the automatic leveling of the bed, I understand that for this function the 3 advance screws they have to be connected in different divers, I use 2 in parallel.



  • Can you post your config.g?

    I'm wondering if maybe one of your motors is skipping steps or binding. Is it always the same screw that is out?

    This is the main reason I went for a single motor with 3 lead screws belted together on my DBot z axis. It's hard to keep the motors in sync.



  • Thanks for your help my config.g is the following

    ; Configuration file for Duet WiFi (firmware version 1.20 or newer)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Sun Apr 08 2018 20:13:54 GMT+0200 (Hora de verano romance)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    M667 S1 ; Select CoreXY mode

    ; Network
    M550 PD-BOT ; Set machine name
    M552 S1 ; Enable network
    ;*** Access point is configured manually via M587
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S0 ; Drive 0 goes forwards
    M569 P1 S0 ; Drive 1 goes forwards
    M569 P2 S0 ; Drive 2 goes backwards
    M569 P3 S0 ; Drive 3 goes backwards
    M584 X0 Y1 Z2:3 E4 ; Apply custom drive mapping
    M350 X16 Y16 Z16 E16 I1 ; XYZ and E0 microstepping
    M92 X100 Y100 Z400 E420 ; Set steps per mm
    M566 X900 Y900 Z12 E120 ; Set maximum instantaneous speed changes (mm/min)
    M203 X6000 Y6000 Z200 E1200 ; Set maximum speeds (mm/min)
    M201 X500 Y20 Z250 E250 ; Set accelerations (mm/s^2)
    M906 X800 Y800 Z800 E800 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X300 Y260 Z450 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y2 S0 ; X home to min. Y and Z home to max. Normally Closed limit switches.
    M574 Z2 S2 ; Define Z to use Probe. Home to Min

    ; Z-Probe
    M558 P9 X0 Y0 Z2 H5 F100 T4000 A10 R0.5 S0.008 ;Set Z probe type/mode 5. H=Dive Height. F=Speed the bed moves
    G31 X-19 Y-37 Z1.52 P25 ; Z probe trigger value, offset in relation to nozzle. And trigger height adjustment
    M557 X15:280 Y15:245 S30 ; Define mesh grid
    M376 H20 ;
    M375 ; Load heightmap.csv

    ; Heaters
    M301 H0 S1.00 P10 I0.1 D200 T0.4 W180 B30 ; Use PID on bed heater (may require further tuning)
    M305 P0 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C
    ; BLTouch - Heaters
    M307 H7 A-1 C-1 D-1 ; Disable the 7th Heater to free up PWM channel 5 on the Duex board.

    ; Fans
    M106 P0 S0.3 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I0 F500 H1 T45 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic saving after power loss is not enabled

    ; Custom settings are not configured



  • An image of the result of my bltouch probe0_1524597367605_2018-04-24.png



  • Are all your Z motors are the same model?

    Everything looks ok in your config as far as I can tell.

    One thing I would try would be to increase your Z motor current to 85% of the rated current. This may help to keep the motors from skipping steps.



  • The engines for z are these:

    https://www.amazon.es/gp/product/B06XQWMDWT/ref=oh_aui_detailpage_o04_s00?ie=UTF8&psc=1

    The maximum current they support is 1.7A



  • @ivang In that case try increasing the motor current for the z axis.
    M906 Z1400



  • I have manually leveled with the printer off and the problem remains exactly the same, I think I am going to try to put 2 advance screws instead of 3

    0_1524600500004_2018-04-24 (1).png


  • administrators

    Instead of connecting 2 of the motors in parallel to the Z output, I suggest you connect them separately to the Za and Zb connectors so that they are in series. Otherwise, the two connected in parallel will get half as much current as the third one, which means they will generate half as much torque.



  • I had a similar issue and it turned-out one of the Z-motors was going bad. Just a thought...



  • Sorry but I have them connected in series in ZA and ZB I do not know why I put it in parallel, I really have it connected in series, I do not understand why every time you go up and down the bed it stays at a different height, especially when I turn off and turn on the printer is a disaster the lead screw connected to the ZB is 5mm lower than the ZA and the spindle connected to the Extruder is 7 or 8 mm lower, although I raise them manually and the level again happens the same, my screws advance and nuts are from T8x8


  • administrators

    Looking at these lines:

    M203 X6000 Y6000 Z200 E1200 ; Set maximum speeds (mm/min)
    M201 X500 Y20 Z250 E250 ; Set accelerations (mm/s^2)

    the M203 line looks reasonable, but the Z acceleration of 250 in the M201 line looks much too high to me. Try reducing it.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.