Issue with heat pause after G32?



  • So for my scenario I G28 and G32 at start of every print, and so my nozzle isn't leaking all over I set temperature after(I have a cold bed anyway). This works great for me except if I do a print, leave printer on and turn off hotend, then start another print, regardless of if it is a temp already or not, it will start printing right after G32 instead of waiting for temp to be reached.



  • How are you setting the temp?



  • Now that you ask I re-looked at what I had set and it's M104 instead of M109 - wonder why it waits on the first print though? Is there something built in to not start a print unless temp has reached temp that only is flagged first print?



  • Possibly the slicer is setting the temp and waiting? Or maybe it won't start until it's past the cold extrude temp limit?



  • @phaedrux Well yeah that is my code from slicer - and when it starts the second time and doesn't wait it just spams error about cold extrusion, which makes sense. Just curious what safety net is working the first print but not the second. Could be that once the temp reaches a specific point it's flagged in the software but doesn't ever get set back once it falls?



  • What slicer do you use? What does your start-up code look like from the sliced G-code file?


  • administrators

    It may be that you have a T0 command in config.g so that tool 0 is selected the first time you print; but when you do the second print, no tool has been selected. The solution is to have T0 at the start of the file, before the M104 command.



  • I've changed it to this but it was M104 instead of M109

    G28
    G32
    G1 Z5
    M109 S[extruder0_temperature] T0
    

    So this was my start script generated in an example gcode ready to print

    G90
    M82
    M106 S0
    G28
    G32
    G1 Z5
    M104 S230 T0
    G92 E0
    G1 E-2.0000 F1200
    G1 Z1.200 F1002
    ; process TPU
    ; layer 1, Z = 0.300
    T0
    

    On that same subject, will M109 also make it stay at whatever height I assume until heat is reached? In the first code I posted I move it to Z5 (cause I am printing on a shirt and don't want the head heating up touching the shirt obviously) but with M104 it just moved right down and heated up just above the bed which is right on the shirt. I assume it will but haven't had a chance to test as I'm at work.


  • administrators

    The M109 command will prevent execution of the following commands until the hot end temperature has been reached. As a side effect, if no tool is selected then M109 will select the tool whose number is given in the T parameter, or the lowest-numbered tool if there is no T parameter.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.