Auto tune cancelled because target temperature was not reached



  • I am pulling my hair out with this and sure it must be something wrong in the gcode. My hotend does not heat up vast fast therefore i get "Auto tune cancelled because target temperature was not reached". I have checked the heater cartridge it is 4.3 ohms which according to my searches is correct. I have 12.3 volts constantly to the cartridge.
    My thermister matches within 2deg of the reading from my Klein meter and thermister.

    I have even tried another heat cartridge and thermister with the same results.

    Could someone please enlighten me as to what Iam doing wrong. I have Googled and read until my eyes are poping out.

    Any help in a direction to fix this would be greatly appreciated.

    Thank you in advance



  • Do you have a silicone sock or any other type of thermal insulation installed? Is your part cooling fan blowing on the block?



  • I understand you are triying to auto tune the PID. Which P value are you using for M301 command?. Try increasing it to ramp up the heating curve, until you get a good result without overshoot warnings.



  • This is what is in the heater section of my Config.g file ; Thermistors and heaters
    ;*** You can use S and B parameters to define the parameters of the thermistors you are using
    M305 P0 T100000 B4388 R4700 H0 L0 ; Put your own H and/or L values here to set the bed thermistor ADC correction
    M305 P1 T100000 B4725 R4700 H0 L0 ; Put your own H and/or L values here to set the first nozzle thermistor ADC correction
    M305 P2 T100000 B3974 R4700 H0 L0 ; Put your own H and/or L values here to set the second nozzle thermistor ADC correction
    M301 H1 P10 I0.10 D100 T0.50 S1.5 ; PID settings for extruder 0
    M301 H2 P10 I0.10 D100 T0.50 S1.0 ; PID settings for extruder 1
    M570 S12000 ; Increase to allow extra heating time if needed
    M307 H0 A199.0 C962.6 D4.5 B0
    M307 H1 A406.3 C166.4 D10.3 B0



  • @phaedrux I do have a sock on it and no part cooling fan yet


  • administrators

    What is the exact M303 command you are sending to tune the heater, and which firmware version are you using?



  • M303 H1 S240 Firmware version is 1.20



  • Sorry I didn't type that correctly.
    M303 H1 P1 S240


  • administrators

    Can your hot end actually reach 240C? It sounds to me that it can't. This is odd because the heater power should be 35W, which should be plenty especially with a silicone sock. What does the temperature graph look like when you try to auto tune?



  • 0_1525010745105_Auto Tune.JPG


  • administrators

    Either it's not running at full PWM, or the heater power is very much lower than it should be, or your thermistor is under-reading by a large amount.

    I see an error in your thermistor configuration:

    M305 P1 T100000 B4725 R4700 H0 L0 ; Put your own H and/or L values here to set the first nozzle thermistor ADC correction

    You have used B4725, which is correct for the Semitec GT104-2 thermistor only if you also add the C7.060000e-8 parameter. See https://e3d-online.dozuki.com/Guide/V6+RepRap+Firmware+Configuration/26?lang=en.



  • @dc42 Thank you for catching that I corrected M305.
    I found the cause of my problem, the heat block was tight against the heatsink. I went back and looked at the Titan Aero assembly instructions and saw a picture of it ( Thank God for pictures).

    They should put something in their instructions for dummies like me.

    Everything auto tuned perfectly and have it set up in the firmware.

    Now on to the rest of the setup, Thanks for being here for us newby's


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.