BLTouch issues



  • Hi,

    after spending some hours with setting up my BLTouch, i got it working, but i dont think its working the it's supposed to be. Some problems i ran into:

    • the probe did not deploy automatically when homing with G30 (M558 P9 was set which should automatically deploy/retract i assumed) so i added M401/402 commands
    • after triggering the pin immediately retracted, fell do again hitting the glass, then retracted due to my M402 i guess and moved on to probe the next point where it deployed again

    Shouldnt the probe deploy, retract as it hits the surface, deploy again and move to the next probing point without the retract move before travelling to next point? As mentioned earlier, the probe does not deploy automatically in Mode P9. Here are my bed.g, homez.g and config.g files.

    Thanks in advance for any help, if someone can even understand my rather confusing text.

    Video: https://youtu.be/JmPQB6cXZaE

    config.g

    ; Configuration file for Duet WiFi (firmware version 1.20 or newer)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Sat Mar 31 2018 15:11:41 GMT+0200 (CEST)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    ; Network
    M550 PDrucker ; Set machine name
    M551 P123 ; Set password
    M552 S1 ; Enable network
    M587 S"xxx" P"xxx" ; Configure access point. You can delete this line once connected
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S1 ; X axis
    M569 P1 S0 ; Y axis
    M569 P2 S0 ; Z axis
    M569 P3 S1 ; Extruder
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X80 Y80 Z2133.333 E871 ; Set steps per mm
    M566 X1200 Y1200 Z50 E150 ; Set maximum instantaneous speed changes (mm/min)
    M203 X6000 Y6000 Z180 E1200 ; Set maximum speeds (mm/min)
    M201 X500 Y500 Z250 E250 ; Set accelerations (mm/s^2)
    M906 X800 Y800 Z800 E800 I10 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S2 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X145 Y175 Z180 S0 ; Set axis maxima

    ; Endstops
    M574 Y1 S1
    M574 X1 S3
    M574 Z1 S2

    ; Z-Probe

    M307 H3 A-1 C-1 D-1 ; BLTouch
    M558 P9 X0 Y0 Z1 H5 F100 T2000 ; BLTouch used by Z axis, dive height 5mm, mode 9
    G31 X0 Y0 Z1.53 P50 ; Z probe trigger value, offset in relation to nozzle. And trigger height adjustment

    ; Heaters

    M305 P0 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S100 ; Set temperature limit for heater 0 to 100C
    M305 P1 T100000 B4725 C7.06e-8 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S250 ; Set temperature limit for heater 1 to 250C

    ; Fans
    M106 P0 S0.7 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I0 F500 H1 T45 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    T0 ; Select first tool


    bed.g

    ; bed.g (automatic bed compensation) (called by softkey in webcontrol, heightmap loaded with G29 S1)

    G28 ; home all axes first
    M557 X5:145 Y5:145 S35 ; Define mesh grid
    G29 S0 ; run probing and calculate bed compensation


    homez.g

    ; homez.g (SENSOR)

    G91 ; relative positioning
    G1 Z3 F100 S2 ; lift Z 3mm relative to current position
    G90 ; absolute positioning
    G1 X80 Y80 F3000 ; go to first probe point
    M401
    G30 ; home Z by probing the bed
    M402



  • Edit: i commented m401 and 402 out and the problem is still the same as seen in the video. maybe its because my z moves up too slowly after triggering?



  • Just to clarify, do you have the servo deploy and retract commands in the deploy probe.g and retract probe.g files?

    Are you using firmware 1.21?

    The pin popping back out like that seems to be normal behavior now. It isn't a probing activation. Mine does that too and there have been posts from others with the same thing.

    Does the probe function otherwise?



  • @phaedrux yes i have those commands inside the files. and yes i am using 1.21.

    the probe does function so i guess i shouldnt worry too much about it. t

    thanks for your fast response!



  • @ab4d So does G30 automatically deploy the probe as required or do you have to do it manually still? It should be autpmatic.



  • @phaedrux it deploys it automatically now. the only thing that bothers me, as i said, is the pin popping back out immediately after triggering instead of staying inside while homing

    and

    the pin NOT staying out while moving to next probe point,

    but as you said, that seems to be normal behaviour


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.