Extruder motor stuttering/skipping



  • A few days ago my Titan Aero started stuttering while extruding and retracting. After a lot of troubleshooting I was conviced that it was a bad cable, but that does not seem to be the only problem.
    I used the pancake motor that came with my Titan Aero and it was running successfully for a few days after finaly installing it on my printer. Then one morning when I wanted to change filament it startet suttering a bit while retracting. I didn't think much of it so I inserted the new filament and startet to print. While printing it stuttered more often so I cancelled the print and got on with the troubleshooting. Trying higher temperatures, doing cold pulls, pushing the filament manually,... I could cofirm that it was not a clogged nozzle. I then disassembled the extruder and tried to run the motor on its own which resultet in more stuttering and ended in the motor only stuttering and not moving at all. I then tried the motor from my old extruder, which also did stutter. I then tried another motor driver (was using E0 exclusively before that) but it also stuttered. Than I used another motor cable and the motor turned without a problem. So I reassembled the Titan Aero, first with the pancake motor, but it started stuttering again, then with the other motor and I finally got filament extruding. I then tried a print, not bothering with finetuning the extruder steps, just modifying it for the 1.8° stepper instead of the 0.9° pancake stepper. The print started fine, but after a few layers it began to stutter again. I cancelled the print, tried again with higher temperatures and slower extrusion speeds, but it begins to stutter more frequently again. I now stopped everything because I don't want to damage another motor.
    I'm at a loss. It's not just the motor, it was not just the cable, it's not a clogged nozzle and it does not seem to be too high pressure on the motor shaft. What can I look for now? I also tried adjusting the motor current (was set to 1200mA for my old extruder, which I also used with the Titan Aero pancake motor without problems, that one is rated for 1400mA), but that doesn't do anything, either...

    I need help, please 😕


  • administrators

    It could indicate a partially-blown stepper driver. To test this, if the E1 motor output is free then I suggest you reconfigure the firmware to use it instead of E0. If you don't already have a M584 command in config.g, you can do this by adding M584 E4:3 in config.g, before any M906 or M350 commands.



  • Thanks for the suggestion. I just tried it, but it also does stutter. Just to confirm, M584 E4:3 just remaps the driver internally, the output still is the on marked as E1 on the board?
    Yesterday I did try E1 with reconfiguring the tool (M563 P0 D1 H1), also with stuttering. 😕


  • administrators

    I was assuming that you had the extruder connected to E0 motor output originally, so that by moving it to E1 you would be using a different stepper driver. Is that correct, or was it already connected to E1?



  • It was connected to E0, after your post I moved it to E1 and added M584 E4:3 to my config, before any M906 and M350 commands. Then restarted the printer. (It was also powered down while swapping the connectors).


  • administrators

    Thanks. So unless both E0 and E1 drivers are faulty, which is very unlikely, it is a problem with the motor, the cable, or the settings (you eliminated the extruder by testing the motor by itself). What M201, M203 and M92 settings do you have for the extruder, what are the motor specifications, and are you using 12V or 24V power?



  • Yes, well. I already swapped the cable, and that did work at first. As for the motor, I guess the E3D pancake motor is busted, I did not try it again after it didn't work with the new cable, the other motor I'm currently using worked flawlessly in my old extruder assembly and worked fine until I installed it on the Titan Aero with the new cable and printed for a while (didn't work with the old cable).
    I'm running on 12V. The E3D pancake motor is a 0.9° 12V motor rated at 1400mA, the other motor is from an 'old' Wanhao i3 and the specifications are not clear, but it is a 1.8° 12V motor, and it ran for about 1 year at 1200mA without problems.
    My settings are as follows:

    M201 X2000 Y2000 Z100 E250
    M203 X18000 Y18000 Z300 E1200
    M92 X80 Y80 Z400 E418
    

  • administrators

    Your extruder setting look conservative to me, so I suspect the motor too.

    Be warned, there are at least 2 different pinouts used on stepper motors with 6-pin JST connectors. So check that the phases are correctly connected at the plug that goes into the Duet, especially if using a cable and a motor from 2 different sources.



  • The pinout seems to be the same for both motors and cables. The motor that is currently installed was installed with the same cable for about one year, but with an MK10 extruder. Now that is 'in' the Titan Aero it is giving me troubles. Also the Titan Aero with the pancake motor was working fine for at least a few days. Could this be a problem with the bearings (that E3D had a while ago...)?


  • administrators

    @darookee said in Extruder motor stuttering/skipping:

    Also the Titan Aero with the pancake motor was working fine for at least a few days. Could this be a problem with the bearings (that E3D had a while ago...)?

    I wondered that at first, but you said you had tested the motor connected to E0 by itself and it was still stuttering. If you disconnect the motor from the Duet, how easy is it to turn the extruder gear?



  • I disconnected the motor and tried turning on the black gear. It was a bit hard to move. I disassembled the extruder body and tried turning and it moved freely... So then I reassembled everything and did not tighten any of the screws, than turned the gear and tightened one screw after another. When I tightened the one through the bearings and gear it started to get harder to turn, than I unscrewed it a bit. I'm currently heating the printer up. I checked the screws multiple times but never noticed this... gnah 😐



  • The print just finished. It occasionally clicked and clacked a bit, I tried loosening the screw a bit more, but that does not do anything. But I guess it's not a Duet problem. Thanks for the help! 😄


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.