I can't get the Bltouch working



  • No you don't need to redo the configurator. You should be able to just plug the new bltouch in and see if it does the same thing.



  • I did that it does the same thing X and Y home and with the new probe does the same thing as the video.



  • @saltypetz said in I can't get the Bltouch working:

    G31 X0 Y0 Z0 P25

    Try changing this to G31 X0 Y0 Z0 P500



  • @saltypetz said in I can't get the Bltouch working:

    I did that it does the same thing X and Y home and with the new probe does the same thing as the video.

    The probe of the BLtouch shouldn't do the dance move (in&out) all the time.
    If this still happens with your new BLtouch you really should check the wiring and configuration again.

    The probe should move two times out&in when the printer is powered up, then it should stay rectracted (in).
    If your BLtouch does this fine the next thing to check if you can manually deploy and retract the probe with the commands:
    for Deploy: M280 P3 S10 I1
    for Retract: M280 P3 S90 I1

    My BLTouch Z-Probe is always shown in the webinterface with a value of "0", but it works fine for me. As it is mentioned in the guides, the value may change so fast when probing that it just isn't displayed when it is triggered.

    Is this is all working for you to this point ? This has to work before trying to probe the bed makes sense.



  • Now for some reason I can't get in the wifi web page I have tried everything. Pronnterface work with the plug in and YAT. The Wifi light on the wifi board is on without turning off solid blue. I can turn it off with YAT and back on then solid again. I can't get in the Duet page with the wire pluged in.



  • In Pronterface face it moves x and y all homes Z stops before bed then probe up and down. I still can't in the wifi. I tried all the comands.



  • Just got back in something happen to the sd card all the files where gone just get in back on line.



  • I must be getting close. I am going to post a few pictures. There is one problem I never had I home X and the motor keeps running like the endstop is not working.

    All you have to do is add this to chrome and you can see the pictures.

    https://www.dropbox.com/s/j7lr3i15hi7z7dy/20180509_130226.jpg?dl=0
    https://www.dropbox.com/s/372llgg43gdg7mt/20180509_130548.jpg?dl=0

    Thank you as alway for the help



  • I have it printing with no filament but it is printing high above the bed with simplify3D. The BLT pin is down light is off. Some has to be a little for in my setting I used the other person Tevo black widow information to try to make it work i will post a video of what I have now. How do i post the video so it will shop up here.

    ![https://youtu.be/vcCtyz6l8gQ](image url)

    Thank for any help I have been trying for weeks.


  • administrators

    You can upload your video to YouTube and post the link here.



  • I uploaded the video but I cant make it show up here.

    link text



  • I really think it is something in my setting. I copy the other tevo black widow and tried it and it didn't work.


  • administrators

    Which firmware version are you using? Look on the Settings General page of DWC or send M115 to check.



  • Firmware Name: RepRapFirmware for Duet 2 WiFi/Ethernet
    Firmware Electronics: Duet WiFi 1.02 or later
    Firmware Version: 1.21 (2018-03-21)
    WiFi Server Version: 1.21
    Web Interface Version: 1.19.3

    M115
    FIRMWARE_NAME: RepRapFirmware for Duet 2 WiFi/Ethernet FIRMWARE_VERSION: 1.21 ELECTRONICS: Duet WiFi 1.02 or later FIRMWARE_DATE: 2018-03-21



  • This is Pronteface. Everything homes no problem it's just the BLTouch.0_1526577591051_20180517_131755.jpg



  • Here are all my files.

    To test the setup with the nozzle maybe a 100mm up from the bed you can check if the trigger signal is reaching the Duet by attempting to extend the pin by using the following command:

    M280 P3 S10 I1 (This works perfect)

    Then put the Sensor in to test mode by inputting the following command:

    M280 P3 S120 I1 (This one the pin goes in and out)

    config.g
    ; Configuration file for Duet WiFi (firmware version 1.20 or newer)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Thu May 17 2018 10:09:24 GMT-0400 (Eastern Daylight Time)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    ; Network
    M550 PMy printer ; Set machine name
    M552 S1 ; Enable network
    ;*** Access point is configured manually via M587
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S0 ; Drive 1 goes forwards
    M569 P2 S0 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M569 P4 S1 ; Drive 4 goes forwards
    M350 X16 Y16 Z16 E16:16 I1 ; Configure microstepping with interpolation
    M92 X80 Y80 Z4000 E420:420 ; Set steps per mm
    M566 X900 Y900 Z12 E120:120 ; Set maximum instantaneous speed changes (mm/min)
    M203 X6000 Y6000 Z180 E1200:1200 ; Set maximum speeds (mm/min)
    M201 X500 Y20 Z250 E250:250 ; Set accelerations (mm/s^2)
    M906 X800 Y800 Z800 E800:800 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z1 S1 ; Set axis minima
    M208 X580 Y250 Z580 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 S1 ; Set active high endstops

    M307 H3 A-1 C-1 D-1 ;
    M558 P9 X0 Y0 Z1 H5 F100 T2000
    G31 X0 Y0 Z0 P25
    ;Bltouch

    ; Heaters
    M305 P0 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    M305 P1 X150 T"K" ; Set thermistor + ADC parameters for heater 0
    M143 H1 S370 ; Set temperature limit for heater 1 to 370C
    M305 P2 X151 T"K" ; Set thermistor + ADC parameters for heater 1
    M143 H2 S370 ; Set temperature limit for heater 2 to 370C

    ; Fans
    M106 P0 S0.3 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I0 F500 H1 T45 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C
    M563 P1 D1 H ; Define tool 1
    G10 P1 X0 Y63 Z0 ; Set tool 1 axis offsets
    G10 P1 R0 S0 ; Set initial tool 1 active and standby temperatures to 0C

    ; Automatic saving after power loss is not enabled

    ; Custom settings are not configured

    ; deployprobe.g
    ;
    Probe deployment routine for BLTouch
    ;
    M280 P3 S10 I1 ; Set servo position to deploy

    ; retractprobe.g
    ;
    ; Probe retraction routine for BLTouch
    ;
    M280 P3 S90 I1

    As Phaedrux said to try.

    ; homeall.g
    ;
    G91 ; relative positioning
    G1 Z5 F3000 S2 ; lift Z relative to current position
    G1 S1 X-585 Y-255 F1800 ; move quickly to X and Y axis endstops and stop there (first pass)
    G1 X5 Y5 F3000 ; go back a few mm
    G1 S1 X-585 Y-255 F360 ; move slowly to X and Y axis endstops once more (second pass)
    G90 ; absolute positioning
    G1 X100 Y100 F3000 ; go to first bed probe point and home Z
    G30 ; home Z by probing the bed
    G1 X0 Y0 F3000 ; return to origin
    ;

    ; homey.g
    ; called to home the Y axis
    ;
    ; generated by RepRapFirmware Configuration Tool on Sat Mar 03 2018 14:29:04 GMT-0500 (Eastern Standard Time)
    G91 ; relative positioning
    G1 Z1 F6000 S2 ; lift Z relative to current position
    G1 S1 Y-275 F1800 ; move quickly to Y axis endstop and stop there (first pass)
    G1 Y5 F6000 ; go back a few mm
    G1 S1 Y-275 F360 ; move slowly to Y axis endstop once more (second pass)
    G1 Z-1 F6000 S2 ; lower Z again
    G90 ; absolute positioning

    ; homey.g
    ; called to home the Y axis
    ;
    ; generated by RepRapFirmware Configuration Tool on Sat Mar 03 2018 14:29:04 GMT-0500 (Eastern Standard Time)
    G91 ; relative positioning
    G1 Z1 F6000 S2 ; lift Z relative to current position
    G1 S1 Y-275 F1800 ; move quickly to Y axis endstop and stop there (first pass)
    G1 Y5 F6000 ; go back a few mm
    G1 S1 Y-275 F360 ; move slowly to Y axis endstop once more (second pass)
    G1 Z-1 F6000 S2 ; lower Z again
    G90 ; absolute positioning

    ; homez.g
    ; called to home the Z axis
    ;
    G91 ; relative mode
    G1 Z4 F200 S2 ; raise head 4mm to ensure it is above the Z probe trigger height
    G90 ; back to absolute mode
    G1 X167 Y130 F2000 ; put head over the centre of the bed, or wherever you want to probe
    G30 ; lower head, stop when probe triggered and set Z to trigger height
    G1 Z5. F400.


  • administrators

    The "Insufficient axes homed" message is probably because you are telling it to home Z without homing X and Y first - which is a problem because your homez.g file includes an XY movement command.

    When you execute a simple G30 command (as described in "Test and calibrate the Z probe"), what should happen is:

    1. Probe deploys.

    2. Head moves towards the bed at the probing speed. At this point the Z probe reading should be zero.

    3. When you put an obstacle below the probe to trigger it, it should retract and the movement should stop.

    At which point does it fail? If it deploys but then retracts immediately, that suggests that the white output wire isn't connected to the correct pin on the Z probe connector.



  • So where do you think I should start back at the beginning. I don't understand all the g-code you use with the duet wifi. I am new to this board but I never had to to all this and it's been 2 weeks or more I have been trying. But to tell you the truth I am lost.

    Thank for the help.



  • Does your z-probes sensor value still read 1000 all the time in the web-interface/display ?

    Mine only read "1000" when I disconnect the BLTouch's black/white wires from the duet's "z-probe in"/"gnd" pins.
    When it is connected the it reads "0" all the time for me and works correctly.

    If yours still read 1000 all the time maybe you just have to check your connections, maybe you have a broken cable or bad contact in your bltouch cable/connection to the duet.

    So you should test (both values read after powering the printer on and the probe had done its automatic start-test):
    What is your probes value shown when the sensor cable is connected to the duet ?
    What is your probes value shown when the sensor cable to the duet is disconnected ?



  • I does show 1000. I save a copy of the factory sd just uploaded it now the Z-Probe is reading 252 all factory sd card.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.