Stall detection on Z still not working!



  • Re: How to tune Stall Detection?

    Since this old post has been hijacked, I open a new one.
    Stall detection on Z is still not working for me, no matter what I try. This is one of the most important features I bought the Duet Wifi for.
    Stall detection on X an Y works though.

    There must be a solution to this...
    I am currently using v1.21.



  • https://forum.duet3d.com/topic/3986/how-to-tune-stall-detection/35

    and

    https://forum.duet3d.com/topic/3986/how-to-tune-stall-detection/37

    Have you followed these suggestions?

    Maybe the Z motors you are using need to be changed?

    Sounds like higher Z homing speeds help when using Z lead screws.



  • The Stallguard depends on a set of base parameters:

    • Motor parameters (EMF constant, inductance, and resistance): Unfortunately to modify these variables you have to change motors and is not an option for tuning.
    • Supply voltage: for me stallguard started working on Z with 24V, but never worked with 12V (at least I could not make it work relyably, it would stall completely or not at all).
    • Current: I got best result with lower currents. I runt he gode "M913 Z40" to reduce the current to 40% before I home, then I restore the 100%.
    • Speed: For me F600 is working fine. You need to find the correct speed, but everytime you change something, the response on other parameter settings will vary. For that reason, I started with currrent and once I see the motor moving, I fix the value and do not change again.
    • And last but not least the amount of mechanical load: Try to modify the weight on the Z and see if it makes any changes.


  • So one thing I have found is that changing the motor current for drives other than X, Y, Z and E does not seem to work.

    This is a problem for my usecase because I want to home the two motors of my Z-axis independently. So the left one is mapped as U and the right one as V.
    When I try to set the motor current to let's say 25% (M913 U25 V25), this does not work. When moving U or V after this will always move it with full power.
    Is it possible to set the current by drive numbers instead of axes?



  • Okay, so now it does not even work on X any more... I have no idea what I am doing wrong 😞


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.