Duet wifi fan and heater not working



  • Hi I been converting my tevo little monster to a duet wifi with smart effector. I got it configured (I think) and was able to run a g32 successfully.
    I used the reprap config tool to set up.my .g files.
    I tried using the web controll and sending gcode through the console to turn on the fan and heaters. I get 0v at the terminal blocks for the bed and hot end. The berdair pump won't turn on either. The pump will blip twice during startup though so I know that works.

    Any ideas?



  • Also I think I elected bang-bang for the heating style? Not entirely sure about that though.



  • have you configured a tool that encompases the bed\heater\fans ??.



  • Forgot to add that your tool should look something like this:

    M563 P0 D0 H1 F0 F1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C



  • Here is my heater, fan and tool code

    Heaters
    M140 H1 ; Remap heated bed to heater 1
    M301 H1 P-1 ; Set heater 1 to bang-bang mode
    M305 P1 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C
    M305 P2 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 2
    M143 H2 S280 ; Set temperature limit for heater 2 to 280C

    ; Fans
    M106 P0 S0.3 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H2 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I0 F500 H2 T45 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H2 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C



  • alt text

    In case the pic dissent show up this should link to it
    https://photos.app.goo.gl/Tn0Mljiy72QYZWqo1



  • If it helps, this is my config, but I don't do any re-maping:

    ; Bed
    M143 H0 S150 ; Set Max temperature limit for heater 0 (Bed) to 150C
    M301 H0 S1.00 P10 I0.1 D200 T0.4 W180 B30 ; Use PID on bed heater (may require further tuning)
    M305 P0 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 0 (Bed)

    ; Hot End
    M143 H1 S290 ; Set Max temperature limit for heater 1 (HotEnd 1) to 290C
    M305 P1 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 1 (Hotend 1)
    M307 H1 A228.5 C122.8 D7.4 S1 B0 ; Set PID for heater 1 (Hotend 1)



  • and for the fans:

    ; Fans
    M106 P0 I0 F10 H-1 ; Set fan 0 (Part Cooling fan) value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 T50 H1 ; Set Fan 1 (Extruder 0 fan) comes on at 50 degrees
    M106 P2 S0.5 T55 H100:101:102 ; Set fan 2 (Duet Board) to come on half power if any driver chip reaches 55 degrees


  • administrators

    You need to select the tool by sending T0 before you can heat it. But Fan 0 as you have configured it should start running at 30% PWM as soon as you power up the Duet. Also the illumination LEDs should come on at 30% brightness.

    Your M301 command for the bed is obsolete and may be the reason the bwe heater doesn't work. You should delete it, restart and run bed heater tuning to generate a M307 command for it.



  • ok i got this stepper for my extruder and the data sheet says its pin out is
    Black(A+), Green(A-), Red(B+), Blue(B-)
    so im wondering is a1 a+ and a2 A-? and same for b?

    0_1526944601791_stepper.jpg



  • never mind we figured it out. i got the heaters and pump working now thank you all


Log in to reply